aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-10-18 21:04:23 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-10-18 21:04:23 +0800
commitf38e52b4640e2df549f92c82a279fb1cf3fefa5c (patch)
treec0a0292e70cb98a22497f1f1674a8c26653506ca /audio
parent82e08157b84908c7a6d910f135c4963efd3e32d4 (diff)
downloadfreebsd-ports-gnome-f38e52b4640e2df549f92c82a279fb1cf3fefa5c.tar.gz
freebsd-ports-gnome-f38e52b4640e2df549f92c82a279fb1cf3fefa5c.tar.zst
freebsd-ports-gnome-f38e52b4640e2df549f92c82a279fb1cf3fefa5c.zip
- Support OPTIONS
- Add LICENSE - Respect CFLAGS - Add MAKE_JOBS_SAFE PR: 161623 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/timemachine/Makefile24
1 files changed, 19 insertions, 5 deletions
diff --git a/audio/timemachine/Makefile b/audio/timemachine/Makefile
index d2bf10d78896..9fea9cdc44f7 100644
--- a/audio/timemachine/Makefile
+++ b/audio/timemachine/Makefile
@@ -7,23 +7,37 @@
PORTNAME= timemachine
PORTVERSION= 0.3.3
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://plugin.org.uk/timemachine/
MAINTAINER= ports@FreeBSD.org
COMMENT= JACK audio capture tool
+LICENSE= GPLv2
+
LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
+ lo.7:${PORTSDIR}/audio/liblo \
sndfile.1:${PORTSDIR}/audio/libsndfile
-GNU_CONFIGURE= yes
+OPTIONS= LASH "Enable LASH support" off
+
+USE_GNOME= gnomehack gtk20
USE_GMAKE= yes
-USE_GNOME= gtk20
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if exists(${LOCALBASE}/lib/liblash.so.2)
+.if defined(WITH_LASH)
LIB_DEPENDS+= lash.2:${PORTSDIR}/audio/lash
+.else
+CONFIGURE_ARGS+=--disable-lash
.endif
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^PACKAGE_CFLAGS=/s|-g||; \
+ /^PACKAGE_LIBS=/s|-g||' ${WRKSRC}/configure
+
+.include <bsd.port.mk>