aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-02-25 19:02:26 +0800
committermarino <marino@FreeBSD.org>2015-02-25 19:02:26 +0800
commit072a31bfe92a80e83f9e49005d6b8b433e8ebc83 (patch)
treedde77b3c7d119bc53cbf06566f275c0ec21b9a41 /audio
parent39864ffb89a27a0c594c3c1a1a94e0fbd3e99b44 (diff)
downloadfreebsd-ports-gnome-072a31bfe92a80e83f9e49005d6b8b433e8ebc83.tar.gz
freebsd-ports-gnome-072a31bfe92a80e83f9e49005d6b8b433e8ebc83.tar.zst
freebsd-ports-gnome-072a31bfe92a80e83f9e49005d6b8b433e8ebc83.zip
audio/patchage: Set environment during make and install phases
While here, unsuppress the commands so the build gets logged.
Diffstat (limited to 'audio')
-rw-r--r--audio/patchage/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/audio/patchage/Makefile b/audio/patchage/Makefile
index 8d0a506e9210..56db007accd9 100644
--- a/audio/patchage/Makefile
+++ b/audio/patchage/Makefile
@@ -42,13 +42,15 @@ post-patch:
${WRKSRC}/autowaf/autowaf.py
do-configure:
- @(cd ${WRKSRC} && ./waf ${WAF_VERBOSE} --prefix=${PREFIX} \
+ (cd ${WRKSRC} && ./waf ${WAF_VERBOSE} --prefix=${PREFIX} \
--mandir=${MANPREFIX}/man --no-alsa --no-lash configure)
do-build:
- @(cd ${WRKSRC} && ./waf ${WAF_VERBOSE} ${WAF_JOBS} build)
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ./waf ${WAF_VERBOSE} ${WAF_JOBS} build)
do-install:
- @(cd ${WRKSRC} && ./waf ${WAF_VERBOSE} --destdir=${STAGEDIR} install)
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ./waf ${WAF_VERBOSE} --destdir=${STAGEDIR} install)
.include <bsd.port.post.mk>