aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2003-04-21 14:46:00 +0800
committersumikawa <sumikawa@FreeBSD.org>2003-04-21 14:46:00 +0800
commit0b18c20fd6679d760fd53e7170fa9e5ac5f8664b (patch)
tree1940e42b9f1927a8497861153bfaa6517f6ab9be /audio
parent1dcbc1bab1334c070453c5c073a4ea2bb5b8c32a (diff)
downloadfreebsd-ports-gnome-0b18c20fd6679d760fd53e7170fa9e5ac5f8664b.tar.gz
freebsd-ports-gnome-0b18c20fd6679d760fd53e7170fa9e5ac5f8664b.tar.zst
freebsd-ports-gnome-0b18c20fd6679d760fd53e7170fa9e5ac5f8664b.zip
Add gtkpod 0.50, a GUI to upload songs and playlists to iPod.
PR: 47602 Submitted by: David Le Brun <david@dyn-ns.net>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gtkpod/Makefile43
-rw-r--r--audio/gtkpod/distinfo1
-rw-r--r--audio/gtkpod/pkg-descr19
-rw-r--r--audio/gtkpod/pkg-plist5
5 files changed, 69 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 37893571928e..1f0032bf9b4d 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -105,6 +105,7 @@
SUBDIR += gsi
SUBDIR += gsm
SUBDIR += gtkgep
+ SUBDIR += gtkpod
SUBDIR += holyshout
SUBDIR += icecast
SUBDIR += icecast2
diff --git a/audio/gtkpod/Makefile b/audio/gtkpod/Makefile
new file mode 100644
index 000000000000..4f5c1c3a26e6
--- /dev/null
+++ b/audio/gtkpod/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: gtkpod
+# Date created: 28 January 2003
+# Whom: David Le Brun <david@dyn-ns.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkpod
+PORTVERSION= 0.50
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= david@dyn-ns.net
+COMMENT= A GUI to upload songs and playlists to iPod
+
+LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20 \
+ id3-3.8.2:${PORTSDIR}/audio/id3lib \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+pre-configure:
+# install locale correctly (share dir instead of lib dir)
+ @${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|(libdir)/locale|(datadir)/locale|' \
+ ${WRKSRC}/po/Makefile.in.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/gtkpod/distinfo b/audio/gtkpod/distinfo
new file mode 100644
index 000000000000..7a1e6a70f50a
--- /dev/null
+++ b/audio/gtkpod/distinfo
@@ -0,0 +1 @@
+MD5 (gtkpod-0.50.tar.gz) =3D 505b34ef5a6ccaf6592c0890c7044e6c
diff --git a/audio/gtkpod/pkg-descr b/audio/gtkpod/pkg-descr
new file mode 100644
index 000000000000..0113cdd73fb3
--- /dev/null
+++ b/audio/gtkpod/pkg-descr
@@ -0,0 +1,19 @@
+gtkpod is a graphical user interface to upload and manage songs to your iPod.
+
+It allows you to :
+ * Read your existing iTunesDB (i.e. import the existing contents of
+ your iPod).
+ * Add mp3 files to the iPod. You can choose the charset the ID3 tags
+ are encoded in from within gtkpod. The default is the charset currently
+ used by your locale setting.
+ * When adding songs, gtkpod detects duplicates (option).
+ * Remove songs from the iPod.
+ * Create and modify playlists.
+ * Modify ID3 tags -- changes are also updated in the original file (option)
+ * Write the updated iTunesDB and added songs to your iPod.
+ * Work offline and synchronize your new playlists / songs with the iPod
+ at a later time
+
+Nota: you need a Windows iPod
+
+WWW: http://gtkpod.sourceforge.net
diff --git a/audio/gtkpod/pkg-plist b/audio/gtkpod/pkg-plist
new file mode 100644
index 000000000000..ba741a56f124
--- /dev/null
+++ b/audio/gtkpod/pkg-plist
@@ -0,0 +1,5 @@
+bin/gtkpod
+share/locale/de/LC_MESSAGES/gtkpod.mo
+share/locale/ja/LC_MESSAGES/gtkpod.mo
+%%PORTDOCS%%/share/doc/gtkpod/README
+%%PORTDOCS%%@dirrm share/doc/gtkpod