aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-07-26 22:31:26 +0800
committerbapt <bapt@FreeBSD.org>2013-07-26 22:31:26 +0800
commit16290da7412fca43c68f7eebba6c3e547911b1b3 (patch)
treeae2dd29f34810152633676a1be73d67617be4287 /audio
parente04e783f5828f8cce7f23cae54325bf26b814014 (diff)
downloadfreebsd-ports-gnome-16290da7412fca43c68f7eebba6c3e547911b1b3.tar.gz
freebsd-ports-gnome-16290da7412fca43c68f7eebba6c3e547911b1b3.tar.zst
freebsd-ports-gnome-16290da7412fca43c68f7eebba6c3e547911b1b3.zip
Add an explicit dependency on iconv and pkgconfig
Fix build with newer binutils Use options helpers
Diffstat (limited to 'audio')
-rw-r--r--audio/osd-lyrics/Makefile26
1 files changed, 8 insertions, 18 deletions
diff --git a/audio/osd-lyrics/Makefile b/audio/osd-lyrics/Makefile
index 9ded90e35fa7..fad998fdf494 100644
--- a/audio/osd-lyrics/Makefile
+++ b/audio/osd-lyrics/Makefile
@@ -22,35 +22,25 @@ CONFIGURE_ENV= DATADIRNAME=share
# Cannot enable -Werror yet: Clang does not like the code `printf(_("..."))',
# see this bug for details: http://llvm.org/bugs/show_bug.cgi?id=3814
#CONFIGURE_ARGS= --with-werror
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake iconv pkgconfig
USE_GNOME= gtk20
USE_SQLITE= yes
INSTALLS_ICONS= yes
PORTDOCS= AUTHORS ChangeLog NEWS README
+LDFLAGS= -liconv
OPTIONS_DEFINE= DOCS MPD XMMS2 AMAROK
MPD_DESC= Enable MPD support
XMMS2_DESC= Enable XMMS2 support
AMAROK_DESC= Enable Amarok 1.4 support
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMPD}
-LIB_DEPENDS+= mpd:${PORTSDIR}/audio/libmpd
-.else
-CONFIGURE_ARGS+= --disable-mpd
-.endif
+MPD_LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd
+MPD_CONFIGURE_OFF= --disable-mpd
+XMMS2_LIB_DEPENDS= xmmsclient:${PORTSDIR}/audio/xmms2
+XMMS2_CONFIGURE_OFF= --disable-xmms2
+AMAROK_CONFIGURE_ENABLE= amarok1
-.if ${PORT_OPTIONS:MXMMS2}
-LIB_DEPENDS+= xmmsclient:${PORTSDIR}/audio/xmms2
-.else
-CONFIGURE_ARGS+= --disable-xmms2
-.endif
-
-.if ${PORT_OPTIONS:MAMAROK}
-CONFIGURE_ARGS+= --enable-amarok1
-.endif
+.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}