aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-05-03 22:47:57 +0800
committerjbeich <jbeich@FreeBSD.org>2018-05-03 22:47:57 +0800
commit5e7cdb01be2596c247a8d7c6aaabbec5a6139b9e (patch)
tree84ab07dac7dcd718c1ed23b50c264f916339de00 /audio
parent3a1ee31e19df34d5a002dc3f9528fb71f6ed8f4f (diff)
downloadfreebsd-ports-gnome-5e7cdb01be2596c247a8d7c6aaabbec5a6139b9e.tar.gz
freebsd-ports-gnome-5e7cdb01be2596c247a8d7c6aaabbec5a6139b9e.tar.zst
freebsd-ports-gnome-5e7cdb01be2596c247a8d7c6aaabbec5a6139b9e.zip
audio/flite: link shared libs against libm
$ echo 'int main() {}' | cc -xc - -lflite -L/usr/local/lib /usr/local/lib/libflite.so: undefined reference to `log' /usr/local/lib/libflite.so: undefined reference to `fmod' /usr/local/lib/libflite.so: undefined reference to `exp' /usr/local/lib/libflite.so: undefined reference to `sin' /usr/local/lib/libflite.so: undefined reference to `pow' cc: error: linker command failed with exit code 1 (use -v to see invocation) Reported by: mat (via ffmpeg) Obtained from: Debian
Diffstat (limited to 'audio')
-rw-r--r--audio/flite/Makefile2
-rw-r--r--audio/flite/files/patch-shlib_deps14
2 files changed, 15 insertions, 1 deletions
diff --git a/audio/flite/Makefile b/audio/flite/Makefile
index 1af315903e7f..1173cc27e73a 100644
--- a/audio/flite/Makefile
+++ b/audio/flite/Makefile
@@ -3,7 +3,7 @@
PORTNAME= flite
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.speech.cs.cmu.edu/flite/packed/${PORTNAME}-${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-release
diff --git a/audio/flite/files/patch-shlib_deps b/audio/flite/files/patch-shlib_deps
new file mode 100644
index 000000000000..ea8e246e99bb
--- /dev/null
+++ b/audio/flite/files/patch-shlib_deps
@@ -0,0 +1,14 @@
+Respect LDFLAGS in shared libraries
+https://bugs.debian.org/577335
+
+--- config/common_make_rules.orig 2009-07-30 14:52:56 UTC
++++ config/common_make_rules
+@@ -123,7 +123,7 @@ $(LIBDIR)/%.so: $(LIBDIR)/%.shared.a
+ @ rm -rf shared_os.$* && mkdir shared_os.$*
+ @ rm -f $@ $@.${PROJECT_VERSION} $@.${PROJECT_SHLIB_VERSION}
+ @ (cd shared_os.$* && ar x ../$<)
+- @ (cd shared_os.$* && $(CC) -shared -Wl,-soname,`basename $@`.${PROJECT_SHLIB_VERSION} -o ../$@.${PROJECT_VERSION} *.os)
++ @ (cd shared_os.$* && $(CC) -shared -Wl,-soname,`basename $@`.${PROJECT_SHLIB_VERSION} -o ../$@.${PROJECT_VERSION} *.os $(LDFLAGS))
+ @ (cd $(LIBDIR) && ln -s `basename $@.${PROJECT_VERSION}` `basename $@.${PROJECT_SHLIB_VERSION}` )
+ @ (cd $(LIBDIR) && ln -s `basename $@.${PROJECT_SHLIB_VERSION}` `basename $@` )
+ @ rm -rf shared_os.$*