aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-07-19 17:18:51 +0800
committeredwin <edwin@FreeBSD.org>2004-07-19 17:18:51 +0800
commit6a0b92e02e92f1c946181961978e8fa5d5e816e5 (patch)
treee5197f37cc359f057a6b7ab3b23450ca39913f86 /audio
parentcdc421224d21dd02c98bd993b02fdcecf46db35a (diff)
downloadfreebsd-ports-gnome-6a0b92e02e92f1c946181961978e8fa5d5e816e5.tar.gz
freebsd-ports-gnome-6a0b92e02e92f1c946181961978e8fa5d5e816e5.tar.zst
freebsd-ports-gnome-6a0b92e02e92f1c946181961978e8fa5d5e816e5.zip
New port: audio/mt-daapd
mt-daapd scans a directory for music files and makes them available via the Apple proprietary protocol DAAP. DAAP clients can browse the directory and retrieve individual files, either by streaming or by downloading them. WWW: http://mt-daapd.sourceforge.net/ PR: ports/64077 Submitted by: Meno Abels <meno.abels@adviser.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mt-daapd/Makefile52
-rw-r--r--audio/mt-daapd/distinfo2
-rw-r--r--audio/mt-daapd/files/mt-daapd.conf86
-rw-r--r--audio/mt-daapd/files/mt-daapd.sh24
-rw-r--r--audio/mt-daapd/files/patch-gcc295481
-rw-r--r--audio/mt-daapd/pkg-descr6
-rw-r--r--audio/mt-daapd/pkg-plist31
8 files changed, 283 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 2b3208617e06..3cbc6822b41f 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -231,6 +231,7 @@
SUBDIR += mppdec
SUBDIR += mpt
SUBDIR += mq3
+ SUBDIR += mt-daapd
SUBDIR += muse
SUBDIR += musepack
SUBDIR += musicbox
diff --git a/audio/mt-daapd/Makefile b/audio/mt-daapd/Makefile
new file mode 100644
index 000000000000..c2e874677a69
--- /dev/null
+++ b/audio/mt-daapd/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: mt-daapd
+# Date created: 10 March 2004
+# Whom: Meno Abels <meno.abels@adviser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mt-daapd
+PORTVERSION= 0.1.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= mt-daapd
+
+MAINTAINER= Meno.Abels@Adviser.com
+COMMENT= Multithread daapd yet another Server for Apple iTunes
+
+LIB_DEPENDS= id3tag.2:${PORTSDIR}/audio/libid3tag
+
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" prefix="${PREFIX}" \
+ LDFLAGS="${LDFLAGS}" LIBS="${LIBS}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}"
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= AUTOCONF=autoconf259 AUTOHEADER=autoheader259 CC="${CC} -pthread"
+CONFIGURE_ARGS= --with-id3tag=${PREFIX}
+
+USE_AUTOHEADER_VER= 259
+WANT_AUTOCONF_VER= 259
+
+DAAPD_USER= daapd
+DAAPD_GROUP= daapd
+
+FILES_SUB= USER=${DAAPD_USER} GROUP=${DAAPD_GROUP} \
+ PREFIX=${PREFIX} LOGDIR=${LOGDIR} DOCSDIR=${DOCSDIR} \
+ LOCALBASE=${LOCALBASE}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README AUTHORS COPYING CREDITS \
+ ChangeLog INSTALL NEWS TODO
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+ ${SED} ${FILES_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/mt-daapd.sh > ${WRKDIR}/mt-daapd.sh
+ ${INSTALL_SCRIPT} ${WRKDIR}/mt-daapd.sh ${PREFIX}/etc/rc.d/mt-daapd.sh
+ ${SED} ${FILES_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/mt-daapd.conf > ${WRKDIR}/mt-daapd.conf
+ ${INSTALL_DATA} ${WRKDIR}/mt-daapd.conf ${PREFIX}/etc/mt-daapd.conf.sample
+
+.include <bsd.port.mk>
diff --git a/audio/mt-daapd/distinfo b/audio/mt-daapd/distinfo
new file mode 100644
index 000000000000..e7eefe786a6f
--- /dev/null
+++ b/audio/mt-daapd/distinfo
@@ -0,0 +1,2 @@
+MD5 (mt-daapd-0.1.1.tar.gz) = 8d2cbc30d73610aa974ca22a18c47b50
+SIZE (mt-daapd-0.1.1.tar.gz) = 284805
diff --git a/audio/mt-daapd/files/mt-daapd.conf b/audio/mt-daapd/files/mt-daapd.conf
new file mode 100644
index 000000000000..547f67701615
--- /dev/null
+++ b/audio/mt-daapd/files/mt-daapd.conf
@@ -0,0 +1,86 @@
+# $Id: mt-daapd.conf,v 1.3 2004/01/04 20:13:19 rpedde Exp $
+#
+# This is the mt-daapd config file.
+#
+
+#
+# web_root (required)
+#
+# Location of the admin web pages. This should be correct
+#
+
+web_root %%PREFIX%%/share/mt-daapd/admin-root
+
+#
+# port (required)
+#
+# What port to listen on. It is possible to use a different
+# port, but this is the default iTunes port
+#
+
+port 3689
+
+#
+# admin_pw (required)
+#
+# This is the password to the administrative pages
+#
+
+admin_pw mt-daapd
+
+#
+# mp3_dir (required)
+#
+# Location of the mp3 files to share
+#
+
+mp3_dir %%PREFIX%%/share/mt-daapd/mp3
+
+#
+# servername (required)
+#
+# This is both the name of the server as advertised
+# via rendezvous, and the name of the database
+# exported via DAAP
+#
+
+servername mt-daapd
+
+#
+# runas (required)
+#
+# This is the user to drop privs to if running as
+# root. If mt-daapd is not started as root, this
+# configuration option is ignored. Notice that this
+# must be specified whether the server is running
+# as root or not.
+#
+
+runas %%USER%%
+
+#
+# playlist (optional)
+#
+# This is the location of a playlist file.
+# This is for Apple-style "Smart Playlists"
+# See the mt-daapd.playlist file in the
+# contrib directory for syntax and examples
+#
+# Note that static playlists will still
+# show up, even if this directive is not
+# specified
+#
+
+playlist %%PREFIX%%/etc/mt-daapd.playlist
+
+#
+# password (optional)
+#
+# This is the password required to listen to MP3 files
+# i.e. the password that iTunes prompts for
+#
+
+#password mp3
+
+
+
diff --git a/audio/mt-daapd/files/mt-daapd.sh b/audio/mt-daapd/files/mt-daapd.sh
new file mode 100644
index 000000000000..c3d7428fa2e6
--- /dev/null
+++ b/audio/mt-daapd/files/mt-daapd.sh
@@ -0,0 +1,24 @@
+#!/bin/sh
+# $FreeBSD$
+
+MT_DAAPD=/usr/local/sbin/mt-daapd
+MT_DAAPD_CONF=/usr/local/etc/mt-daapd.conf
+
+
+case "$1" in
+ start)
+ if [ -r "${MT_DAAPD_CONF}" ]; then
+ ${MT_DAAPD} -c ${MT_DAAPD_CONF}
+ echo -n ' mt-daapd'
+ fi
+ ;;
+ stop)
+ killall -TERM mt-daapd
+ ;;
+ *)
+ echo ""
+ echo "Usage: `basename $0` { start | stop }"
+ echo ""
+ exit 64
+ ;;
+esac
diff --git a/audio/mt-daapd/files/patch-gcc2954 b/audio/mt-daapd/files/patch-gcc2954
new file mode 100644
index 000000000000..a9e6fdf00fdc
--- /dev/null
+++ b/audio/mt-daapd/files/patch-gcc2954
@@ -0,0 +1,81 @@
+diff -nur ../../mt-daapd-0.1.1/src/configfile.c ./src/configfile.c
+--- ../../mt-daapd-0.1.1/src/configfile.c Tue Jan 20 05:41:20 2004
++++ ./src/configfile.c Mon Mar 15 09:21:00 2004
+@@ -122,11 +122,10 @@
+ int config_read(char *file) {
+ FILE *fin;
+ char *buffer;
+- int err;
++ int err=0;
+ char *value;
+ char *comment;
+ char path_buffer[PATH_MAX];
+- err=0;
+ CONFIGELEMENT *pce;
+ int handled;
+
+Only in ./src: configfile.o
+Only in ./src: daap-proto.o
+Only in ./src: daap.o
+Only in ./src: db-memory.o
+Only in ./src: err.o
+Only in ./src: lexer.o
+Only in ./src: mDNS.o
+Only in ./src: mDNSPosix.o
+Only in ./src: mDNSUNP.o
+diff -nur ../../mt-daapd-0.1.1/src/main.c ./src/main.c
+--- ../../mt-daapd-0.1.1/src/main.c Tue Jan 27 06:30:25 2004
++++ ./src/main.c Mon Mar 15 09:19:38 2004
+@@ -417,13 +417,13 @@
+ int status;
+ int parseonly=0;
+ int foreground=0;
+- config.use_mdns=1;
+
+ #ifdef DEBUG
+ char *optval="d:c:mpf";
+ #else
+ char *optval="c:mpf";
+ #endif /* DEBUG */
++ config.use_mdns=1;
+
+ fprintf(stderr,"mt-daapd: version %s\n",VERSION);
+ fprintf(stderr,"Copyright (c) 2003 Ron Pedde. All rights reserved\n");
+Only in ./src: main.o
+diff -nur ../../mt-daapd-0.1.1/src/mdns/mDNSUNP.h ./src/mdns/mDNSUNP.h
+--- ../../mt-daapd-0.1.1/src/mdns/mDNSUNP.h Thu Oct 23 23:43:01 2003
++++ ./src/mdns/mDNSUNP.h Mon Mar 15 09:23:00 2004
+@@ -93,7 +93,9 @@
+ #endif
+
+ #if !defined(HAVE_SOCKLEN_T)
++#ifndef __FreeBSD__
+ typedef unsigned int socklen_t;
++#endif
+ #endif
+
+ #define IFI_NAME 16 /* same as IFNAMSIZ in <net/if.h> */
+Only in ./src: mp3-scanner.o
+Only in ./src: mt-daapd
+Only in ./src: parser.o
+Only in ./src: playlist.o
+Only in ./src: rend-posix.o
+Only in ./src: rend-unix.o
+Only in ./src: restart.o
+Only in ./src: uici.o
+diff -nur ../../mt-daapd-0.1.1/src/webserver.c ./src/webserver.c
+--- ../../mt-daapd-0.1.1/src/webserver.c Sun Jan 4 06:27:43 2004
++++ ./src/webserver.c Mon Mar 15 09:20:21 2004
+@@ -919,9 +919,9 @@
+ *
+ */
+ int ws_testarg(ARGLIST *root, char *key, char *value) {
++ char *retval=ws_getarg(root,key);
+ DPRINTF(ERR_DEBUG,"Checking to see if %s matches %s\n",key,value);
+
+- char *retval=ws_getarg(root,key);
+ if(!retval)
+ return 0;
+
+Only in ./src: webserver.o
+Only in .: stamp-h1
diff --git a/audio/mt-daapd/pkg-descr b/audio/mt-daapd/pkg-descr
new file mode 100644
index 000000000000..7a9c76241f9f
--- /dev/null
+++ b/audio/mt-daapd/pkg-descr
@@ -0,0 +1,6 @@
+daapd scans a directory for music files and makes them available via
+the Apple proprietary protocol DAAP. DAAP clients can browse the
+directory and retrieve individual files, either by streaming or by
+downloading them.
+
+WWW: http://mt-daapd.sourceforge.net/
diff --git a/audio/mt-daapd/pkg-plist b/audio/mt-daapd/pkg-plist
new file mode 100644
index 000000000000..46b0e6c5ce7e
--- /dev/null
+++ b/audio/mt-daapd/pkg-plist
@@ -0,0 +1,31 @@
+@comment $FreeBSD$
+etc/mt-daapd.conf.sample
+etc/rc.d/mt-daapd.sh
+sbin/mt-daapd
+share/mt-daapd/admin-root/aspl-license.html
+share/mt-daapd/admin-root/aspl-license.txt
+share/mt-daapd/admin-root/config-update.html
+share/mt-daapd/admin-root/config.html
+share/mt-daapd/admin-root/ftr.html
+share/mt-daapd/admin-root/gpl-license.html
+share/mt-daapd/admin-root/gpl-license.txt
+share/mt-daapd/admin-root/hdr.html
+share/mt-daapd/admin-root/index.html
+share/mt-daapd/admin-root/linkOpaque.gif
+share/mt-daapd/admin-root/linkTransparent.gif
+share/mt-daapd/admin-root/mt-daapd.css
+share/mt-daapd/admin-root/mt-daapd.png
+share/mt-daapd/admin-root/required.gif
+share/mt-daapd/admin-root/status.html
+share/mt-daapd/admin-root/thanks.html
+%%PORTDOCS%%@dirrm share/mt-daapd/admin-root
+%%PORTDOCS%%@dirrm share/mt-daapd
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%