aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-08-01 13:40:20 +0800
committertobik <tobik@FreeBSD.org>2018-08-01 13:40:20 +0800
commit7780c73440d1cb804759bf5688f23d88547d8141 (patch)
treeb111aa84c9b9ec39f93e0c174401c6f356571cb6 /audio
parent799003bb84f36b8e6ab2503ed7087c994d9ee594 (diff)
downloadfreebsd-ports-gnome-7780c73440d1cb804759bf5688f23d88547d8141.tar.gz
freebsd-ports-gnome-7780c73440d1cb804759bf5688f23d88547d8141.tar.zst
freebsd-ports-gnome-7780c73440d1cb804759bf5688f23d88547d8141.zip
audio/mp3plot: Fix build with Clang 6
/usr/include/c++/v1/memory:2097:9: error: cannot initialize a member subobject of type 'boost::shared_ptr<mp3plot::bitrate_plotter> *' with an rvalue of type 'int' : __value_(_VSTD::forward<_Up>(__u)){}; ^ ~~~~~~~~~~~~~~~~~~~~~~~~ /usr/include/c++/v1/memory:2187:9: note: in instantiation of function template specialization 'std::__1::__compressed_pair_elem<boost::shared_ptr<mp3plot::bitrate_plotter> *, 0, false>::__compressed_pair_elem<int, void>' requested here : _Base1(std::forward<_Tp>(__t)), _Base2() {} ^ http://beefy12.nyi.freebsd.org/data/head-amd64-default/p475478_s336801/logs/errors/mp3plot-0.6.0_21.log
Diffstat (limited to 'audio')
-rw-r--r--audio/mp3plot/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/audio/mp3plot/Makefile b/audio/mp3plot/Makefile
index 3154425d1a4b..d522917d02a3 100644
--- a/audio/mp3plot/Makefile
+++ b/audio/mp3plot/Makefile
@@ -16,6 +16,8 @@ BROKEN_powerpc64= fails to configure: C++ compiler cannot create executables
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
+USE_CXXSTD= c++98
+
OPTIONS_DEFINE= GD IMAGEMAGICK
OPTIONS_DEFAULT=GD