aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-01-04 06:40:22 +0800
committerdanilo <danilo@FreeBSD.org>2014-01-04 06:40:22 +0800
commit84b520d90f2d7b56c778a231a88a2c6bd0bed5da (patch)
treedb7b3a22ac11fffd02e189209362aed949a3bc74 /audio
parent525c649486c8e20486d72aa51464a38e5429bf8c (diff)
downloadfreebsd-ports-gnome-84b520d90f2d7b56c778a231a88a2c6bd0bed5da.tar.gz
freebsd-ports-gnome-84b520d90f2d7b56c778a231a88a2c6bd0bed5da.tar.zst
freebsd-ports-gnome-84b520d90f2d7b56c778a231a88a2c6bd0bed5da.zip
- Update from 0.9.0 to 0.9.2
- Add SIDPLAY2 option while here - Add NLS option PR: ports/185325 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-sid/Makefile38
-rw-r--r--audio/xmms-sid/distinfo4
-rw-r--r--audio/xmms-sid/pkg-plist20
3 files changed, 44 insertions, 18 deletions
diff --git a/audio/xmms-sid/Makefile b/audio/xmms-sid/Makefile
index 22e3bdb6190a..0df2fe7fa73d 100644
--- a/audio/xmms-sid/Makefile
+++ b/audio/xmms-sid/Makefile
@@ -2,23 +2,49 @@
# $FreeBSD$
PORTNAME= xmms-sid
-PORTVERSION= 0.9.0
+PORTVERSION= 0.9.2
CATEGORIES= audio
MASTER_SITES= http://www.tnsp.org/xs-files/
MAINTAINER= ports@FreeBSD.org
COMMENT= XMMS input plugin to play SID files
-LIB_DEPENDS= libsidplay.so:${PORTSDIR}/audio/libsidplay
-BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
-RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+LICENSE= GPLv2 # (or later)
+
+BUILD_DEPENDS= xmms>0:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms>0:${PORTSDIR}/multimedia/xmms
+
+OPTIONS_DEFINE= NLS SIDPLAY2
+SIDPLAY2_DESC= LibSIDPlay2 support
+OPTIONS_SUB= yes
USE_BZIP2= yes
USES= gettext
USE_GNOME= gtk12
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-silent-rules
USE_LDCONFIG= yes
-CONFIGURE_ARGS+= --prefix=${PREFIX} \
- --with-sidplay1=${LOCALBASE}
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSIDPLAY2}
+LIB_DEPENDS+= libsidplay2.so:${PORTSDIR}/audio/libsidplay2
+USES+= pkgconfig
+CONFIGURE_ARGS+=--with-sidplay2 --without-sidplay1
+.else
+LIB_DEPENDS+= libsidplay.so:${PORTSDIR}/audio/libsidplay
+CONFIGURE_ARGS+=--with-sidplay1 --without-sidplay2
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|--libs libsidplay2|--libs-only-L libsidplay2|' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/audio/xmms-sid/distinfo b/audio/xmms-sid/distinfo
index 128996e07d0b..7b8d022f0819 100644
--- a/audio/xmms-sid/distinfo
+++ b/audio/xmms-sid/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xmms-sid-0.9.0.tar.bz2) = 49e86dfc46f192b654150f1d8ac8db6658e86f7dff2ca9b730fca80b637584b6
-SIZE (xmms-sid-0.9.0.tar.bz2) = 640314
+SHA256 (xmms-sid-0.9.2.tar.bz2) = c73fe24b31f5aa846fe16a0220d0166dab08562be048b68f2b1a38b0cb7ecd3a
+SIZE (xmms-sid-0.9.2.tar.bz2) = 647227
diff --git a/audio/xmms-sid/pkg-plist b/audio/xmms-sid/pkg-plist
index 229269d77e7b..fc895496797a 100644
--- a/audio/xmms-sid/pkg-plist
+++ b/audio/xmms-sid/pkg-plist
@@ -1,11 +1,11 @@
lib/xmms/Input/libxmmssid.so
-share/locale/de/LC_MESSAGES/xmms-sid.mo
-share/locale/en@boldquot/LC_MESSAGES/xmms-sid.mo
-share/locale/en@quot/LC_MESSAGES/xmms-sid.mo
-share/locale/fi/LC_MESSAGES/xmms-sid.mo
-share/xmms-sid/Kummatti_City.sid
-@dirrmtry share/locale/en@quot
-@dirrmtry share/locale/en@quot/LC_MESSAGES
-@dirrmtry share/locale/en@boldquot
-@dirrmtry share/locale/en@boldquot/LC_MESSAGES
-@dirrm share/xmms-sid
+%%NLS%%share/locale/de/LC_MESSAGES/xmms-sid.mo
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/xmms-sid.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/xmms-sid.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xmms-sid.mo
+%%DATADIR%%/Kummatti_City.sid
+%%NLS%%@dirrmtry share/locale/en@quot
+%%NLS%%@dirrmtry share/locale/en@quot/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/en@boldquot
+%%NLS%%@dirrmtry share/locale/en@boldquot/LC_MESSAGES
+@dirrm %%DATADIR%%