aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-01-09 17:39:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-01-09 17:39:45 +0800
commit9ec91ae2cf13f7babb94d909c2fc837cbc738ac0 (patch)
treeb40ba7b696c307048a19421595436b548ec2c488 /audio
parent72d5a19be3daca206f8f281295babfbf446aeebc (diff)
downloadfreebsd-ports-gnome-9ec91ae2cf13f7babb94d909c2fc837cbc738ac0.tar.gz
freebsd-ports-gnome-9ec91ae2cf13f7babb94d909c2fc837cbc738ac0.tar.zst
freebsd-ports-gnome-9ec91ae2cf13f7babb94d909c2fc837cbc738ac0.zip
- Fix license
- Use GNU_CONFIGURE - Remove always true OSVERSION based condition
Diffstat (limited to 'audio')
-rw-r--r--audio/mp3c/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/audio/mp3c/Makefile b/audio/mp3c/Makefile
index b56907b5be5a..63c6b268e1a8 100644
--- a/audio/mp3c/Makefile
+++ b/audio/mp3c/Makefile
@@ -10,15 +10,16 @@ MASTER_SITES= ftp://ftp.wspse.de/linux/wspse/
MAINTAINER= ports@FreeBSD.org
COMMENT= CD to mp3c converter with a console frontend
-LICENSE= GPLv2
+LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= mp3info:audio/mp3info \
cdrecord:sysutils/cdrtools
USES= ncurses
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= "--prefix=${PREFIX}"
+GNU_CONFIGURE= yes
+
+DEFAULT_CDROM_DEVICE?= cd0
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
@@ -26,14 +27,6 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000031
-DEFAULT_CDROM_DEVICE= cd0
-.else
-DEFAULT_CDROM_DEVICE= acd0
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|rcd0d|${DEFAULT_CDROM_DEVICE}|g' \
-e 's|/dev/cdrom|/dev/${DEFAULT_CDROM_DEVICE}|g' \
@@ -42,4 +35,4 @@ post-patch:
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/cdrip.sh ${STAGEDIR}${LOCALBASE}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>