aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2006-10-04 06:54:04 +0800
committerdanfe <danfe@FreeBSD.org>2006-10-04 06:54:04 +0800
commita282f70806095bd4b4f408828d323f4fc1576694 (patch)
treecd441abd868714799300903e10f1ad1d9e414465 /audio
parent1ee9d65bbe77ff48073056272e1335f0cb57c8b7 (diff)
downloadfreebsd-ports-gnome-a282f70806095bd4b4f408828d323f4fc1576694.tar.gz
freebsd-ports-gnome-a282f70806095bd4b4f408828d323f4fc1576694.tar.zst
freebsd-ports-gnome-a282f70806095bd4b4f408828d323f4fc1576694.zip
- Fix the build with GCC 4.1
- Mute the target so comment does not show up
Diffstat (limited to 'audio')
-rw-r--r--audio/soundtouch/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/audio/soundtouch/Makefile b/audio/soundtouch/Makefile
index 71f7593436b7..59fb8ffb1e53 100644
--- a/audio/soundtouch/Makefile
+++ b/audio/soundtouch/Makefile
@@ -19,12 +19,14 @@ USE_ZIP= yes
WRKSRC= ${WRKDIR}/SoundTouch-${PORTVERSION}
-post-patch:
- @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|; s|$$(prefix)/doc|$$(datadir)/doc|' \
+post-patch: .SILENT
+ ${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|; s|$$(prefix)/doc|$$(datadir)/doc|' \
${WRKSRC}/source/example/bpm/Makefile.in \
${WRKSRC}/source/example/SoundStretch/Makefile.in \
${WRKSRC}/source/SoundTouch/Makefile.in \
${WRKSRC}/include/Makefile.in ${WRKSRC}/Makefile.in
+ # Fix for GCC 4.x
+ ${REINPLACE_CMD} -e 's|SoundTouch::||' ${WRKSRC}/include/SoundTouch.h
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's/ install-pkgdocDATA$$//' \
${WRKSRC}/Makefile.in