aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorrodrigo <rodrigo@FreeBSD.org>2015-09-10 04:19:38 +0800
committerrodrigo <rodrigo@FreeBSD.org>2015-09-10 04:19:38 +0800
commita55ac04d4b30b72d02f248f7799a5bf17de15df8 (patch)
treec91650bc7b80f3c866ebffba7029442974914aac /audio
parentda66696bf1da93d9722e9c8abc36e8d5709a03a3 (diff)
downloadfreebsd-ports-gnome-a55ac04d4b30b72d02f248f7799a5bf17de15df8.tar.gz
freebsd-ports-gnome-a55ac04d4b30b72d02f248f7799a5bf17de15df8.tar.zst
freebsd-ports-gnome-a55ac04d4b30b72d02f248f7799a5bf17de15df8.zip
Unbreak port, update MASTER_SITES
Fix port Makefile and pkg-plist to comply with new rules and features Submitted by: Chris Petrik <chris@bsdjunk.com> (by private email)
Diffstat (limited to 'audio')
-rw-r--r--audio/lmms/Makefile10
-rw-r--r--audio/lmms/distinfo4
-rw-r--r--audio/lmms/pkg-plist2
3 files changed, 8 insertions, 8 deletions
diff --git a/audio/lmms/Makefile b/audio/lmms/Makefile
index 003ba382deb9..34d4434bb039 100644
--- a/audio/lmms/Makefile
+++ b/audio/lmms/Makefile
@@ -6,14 +6,12 @@ PORTVERSION= 0.4.15
PORTREVISION= 4
PORTEPOCH= 2
CATEGORIES= audio
-MASTER_SITES= SF
MAINTAINER= rodrigo@FreeBSD.org
COMMENT= All-in-one sequencer, drum machine, sampler, and more
LICENSE= GPLv2
-BROKEN= Unfetchable
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac \
libfluidsynth.so:${PORTSDIR}/audio/fluidsynth \
@@ -25,7 +23,7 @@ LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac \
RUN_DEPENDS= ${LOCALBASE}/share/ladspa/rdf/caps.rdf:${PORTSDIR}/audio/caps-plugins \
${LOCALBASE}/lib/ladspa/cmt.so:${PORTSDIR}/audio/cmt \
${LOCALBASE}/share/ladspa/rdf/swh-plugins.rdf:${PORTSDIR}/audio/swhplugins \
- ${LOCALBASE}/share/ladspa/rdf/tap-plugins.rdf:${PORTSDIR}/audio/tap-plugins \
+ ${LOCALBASE}/share/ladspa/rdf/tap-plugins.rdf:${PORTSDIR}/audio/tap-plugins
OPTIONS_DEFINE= JACK PULSEAUDIO SDL
@@ -33,7 +31,10 @@ USE_LDCONFIG= yes
USE_XORG= xft
USE_QT4= corelib gui xml moc_build uic_build rcc_build \
qmake_build
-USES= cmake pkgconfig tar:bzip2 desktop-file-utils shared-mime-info dos2unix
+USE_GITHUB= yes
+GH_ACCOUNT= LMMS
+GH_TAGNAME= v${PORTVERSION}
+USES= cmake desktop-file-utils dos2unix pkgconfig shared-mime-info
CMAKE_ARGS= -DWANT_ALSA:BOOL=OFF \
-DWANT_CALF:BOOL=OFF \
-DWANT_CAPS:BOOL=OFF \
@@ -79,6 +80,5 @@ post-install:
${STAGEDIR}${PREFIX}/share/pixmaps/lmms.png
# make it setuid-root to be able to set realtime priority
# (root privileges are dropped in the main routine)
- ${CHMOD} u+s ${STAGEDIR}${PREFIX}/bin/lmms
.include <bsd.port.mk>
diff --git a/audio/lmms/distinfo b/audio/lmms/distinfo
index 396a4c0255c2..41009f73a1c3 100644
--- a/audio/lmms/distinfo
+++ b/audio/lmms/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lmms-0.4.15.tar.bz2) = 0104caaea8adf7b51b0fc4ff2ab26364d1da5751a8fcbf6772704c8ef57a020b
-SIZE (lmms-0.4.15.tar.bz2) = 14211150
+SHA256 (LMMS-lmms-0.4.15-v0.4.15_GH0.tar.gz) = b516f89d2dba3a34ec57668291ba537d70a2b9fd29a872407ce1d9df4b02df77
+SIZE (LMMS-lmms-0.4.15-v0.4.15_GH0.tar.gz) = 15828961
diff --git a/audio/lmms/pkg-plist b/audio/lmms/pkg-plist
index c84decd33326..406e74f52cba 100644
--- a/audio/lmms/pkg-plist
+++ b/audio/lmms/pkg-plist
@@ -1,4 +1,4 @@
-%%QT_BINDIR%%/lmms
+@(,,4755) %%QT_BINDIR%%/lmms
include/lmms/AudioAlsa.h
include/lmms/AudioDevice.h
include/lmms/AudioDummy.h