aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-24 21:54:00 +0800
committerbapt <bapt@FreeBSD.org>2013-05-24 21:54:00 +0800
commitaa4c51b3d99d43d5492c5fb1b2e35db9b333db92 (patch)
treea47023cbc12e21bd34abe8bf21ba2c1aa8d9d293 /audio
parentb630f421bcb8e069bb20c4297385885d119a0430 (diff)
downloadfreebsd-ports-gnome-aa4c51b3d99d43d5492c5fb1b2e35db9b333db92.tar.gz
freebsd-ports-gnome-aa4c51b3d99d43d5492c5fb1b2e35db9b333db92.tar.zst
freebsd-ports-gnome-aa4c51b3d99d43d5492c5fb1b2e35db9b333db92.zip
Fix build on current by forcing usage of gcc: the code uses nested functions which is a gcc extensions
While here trim headers Convert NOPORTDOCS -> PORT_OPTIONS:MDOCS
Diffstat (limited to 'audio')
-rw-r--r--audio/funktrackergold/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/audio/funktrackergold/Makefile b/audio/funktrackergold/Makefile
index d3b3fefeff3b..fd3feab7a0a9 100644
--- a/audio/funktrackergold/Makefile
+++ b/audio/funktrackergold/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: funktrackergold
-# Date created: Apr 1, 2001
-# Whom: Mark Pulford <mark@kyne.com.au>
-#
+# Created by: Mark Pulford <mark@kyne.com.au>
# $FreeBSD$
-#
PORTNAME= funktrackergold
PORTVERSION= 1.5.2
@@ -19,6 +15,8 @@ COMMENT= A curses MOD/FNK music tracker
LICENSE= GPLv2
+USE_GCC= any
+
WRKSRC= ${WRKDIR}/funkgold
MAKE_ARGS= EXTRA_CFLAGS="${PTHREAD_CFLAGS}" \
EXTRA_LDFLAGS="${PTHREAD_LIBS}"
@@ -26,15 +24,15 @@ MAKE_ARGS= EXTRA_CFLAGS="${PTHREAD_CFLAGS}" \
PORTDOCS= INSTALL
PLIST_FILES= bin/funkgold
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/funkgold ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for docs in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>