aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-01 06:25:47 +0800
committeredwin <edwin@FreeBSD.org>2003-09-01 06:25:47 +0800
commitbc9f926613c901b97bb5f9d07966d0bf63eeb829 (patch)
treeb42688a2dcd86431b4ae7e9659097b2503711c64 /audio
parent3987c01b45eccad0d7abee6643b285dc155727b9 (diff)
downloadfreebsd-ports-gnome-bc9f926613c901b97bb5f9d07966d0bf63eeb829.tar.gz
freebsd-ports-gnome-bc9f926613c901b97bb5f9d07966d0bf63eeb829.tar.zst
freebsd-ports-gnome-bc9f926613c901b97bb5f9d07966d0bf63eeb829.zip
[NEW PORT} audio/asmixer Another mixer for afterstep
This is another mixer for the afterstep window manager. It is different from asmix(1). PR: ports/46708 Submitted by: Mike Makonnen <mtm@identd.net>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/asmixer/Makefile29
-rw-r--r--audio/asmixer/distinfo1
-rw-r--r--audio/asmixer/files/patch-asmixer.c12
-rw-r--r--audio/asmixer/pkg-descr7
-rw-r--r--audio/asmixer/pkg-plist1
6 files changed, 51 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 56fea7c838b1..1ff249bb4ddb 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -16,6 +16,7 @@
SUBDIR += arts
SUBDIR += ascd
SUBDIR += asmix
+ SUBDIR += asmixer
SUBDIR += aube
SUBDIR += audacity
SUBDIR += aumix
diff --git a/audio/asmixer/Makefile b/audio/asmixer/Makefile
new file mode 100644
index 000000000000..95000665a2f9
--- /dev/null
+++ b/audio/asmixer/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: asmixer
+# Date created: 2 January 2003
+# Whom: mtm@identd.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= asmixer
+PORTVERSION= 0.5
+CATEGORIES= audio afterstep
+MASTER_SITES= ${MASTER_SITE_AFTERSTEP} \
+ http://www.tigr.net/afterstep/download/asmixer/
+MASTER_SITE_SUBDIR= apps/asmixer
+
+MAINTAINER= mtm@identd.net
+COMMENT= A mixer control for X, and specifically the AfterStep Window Manager
+
+MAN1= ${PORTNAME}.1x
+
+USE_X_PREFIX= yes
+USE_XPM= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man \
+ ${MAN1PREFIX}/man/man1/${PORTNAME}.1x
+
+.include <bsd.port.mk>
diff --git a/audio/asmixer/distinfo b/audio/asmixer/distinfo
new file mode 100644
index 000000000000..88eb3f9fbfa7
--- /dev/null
+++ b/audio/asmixer/distinfo
@@ -0,0 +1 @@
+MD5 (asmixer-0.5.tar.gz) = 53b06afb220d7ffc113139fd4bfbb4b9
diff --git a/audio/asmixer/files/patch-asmixer.c b/audio/asmixer/files/patch-asmixer.c
new file mode 100644
index 000000000000..7d2d51e2fd57
--- /dev/null
+++ b/audio/asmixer/files/patch-asmixer.c
@@ -0,0 +1,12 @@
+--- asmixer.c.orig Sun Aug 31 15:23:26 2003
++++ asmixer.c Sun Aug 31 15:24:45 2003
+@@ -31,8 +31,8 @@
+ #include <unistd.h>
+
+ #ifdef __FreeBSD__
+-#include <sys/syslimits.h>
+ #include <sys/param.h>
++#include <sys/soundcard.h>
+ #endif
+
+ #include <sys/mount.h>
diff --git a/audio/asmixer/pkg-descr b/audio/asmixer/pkg-descr
new file mode 100644
index 000000000000..364544acdf2a
--- /dev/null
+++ b/audio/asmixer/pkg-descr
@@ -0,0 +1,7 @@
+The asmixer utility is a mixer control for the X Windows environment. It
+is designed to work with the AfterStep Window Manager, but it will
+work with Window Maker or most any other Window Manager. It has
+controls for three configurable channels which are master, pcm, and cd
+volume by default.
+
+WWW: http://www.tigr.net/afterstep/
diff --git a/audio/asmixer/pkg-plist b/audio/asmixer/pkg-plist
new file mode 100644
index 000000000000..6e4a0629195e
--- /dev/null
+++ b/audio/asmixer/pkg-plist
@@ -0,0 +1 @@
+bin/asmixer