aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-09-05 00:02:16 +0800
committermat <mat@FreeBSD.org>2015-09-05 00:02:16 +0800
commitd4128f24283cd93f0120d4a58ec7114798bf4877 (patch)
tree2d206dd00b752621c542c0b063bec6c9471a3355 /audio
parent8b9dfbc45e47a8dc3875beb7d9bacb1046409221 (diff)
downloadfreebsd-ports-gnome-d4128f24283cd93f0120d4a58ec7114798bf4877.tar.gz
freebsd-ports-gnome-d4128f24283cd93f0120d4a58ec7114798bf4877.tar.zst
freebsd-ports-gnome-d4128f24283cd93f0120d4a58ec7114798bf4877.zip
Convert most ports using cloud.github.com to GHC.
Convert a couple to github, and use some options helpers on the way. Sponsored by: Absolight
Diffstat (limited to 'audio')
-rw-r--r--audio/acoustid-fingerprinter/Makefile5
-rw-r--r--audio/libcoverart/Makefile4
-rw-r--r--audio/mous/Makefile4
-rw-r--r--audio/shairport/Makefile7
-rw-r--r--audio/shairport/distinfo4
5 files changed, 15 insertions, 9 deletions
diff --git a/audio/acoustid-fingerprinter/Makefile b/audio/acoustid-fingerprinter/Makefile
index 64a470802ad2..e2e8781dbfcd 100644
--- a/audio/acoustid-fingerprinter/Makefile
+++ b/audio/acoustid-fingerprinter/Makefile
@@ -5,7 +5,7 @@ PORTVERSION= 0.6
PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://bitbucket.org/acoustid/${PORTNAME}/downloads/ \
- http://cloud.github.com/downloads/lalinsky/${PORTNAME}/
+ GHC
MAINTAINER= jhale@FreeBSD.org
COMMENT= AcoustID audio fingerprint submission tool
@@ -19,6 +19,9 @@ LIB_DEPENDS= libchromaprint.so:${PORTSDIR}/audio/chromaprint \
USES= cmake
USE_QT4= gui network \
qmake_build moc_build rcc_build uic_build
+USE_GITHUB= yes
+GH_ACCOUNT= lalinsky
+
INSTALLS_ICONS= yes
post-patch:
diff --git a/audio/libcoverart/Makefile b/audio/libcoverart/Makefile
index b250de20053c..50d255f29b8c 100644
--- a/audio/libcoverart/Makefile
+++ b/audio/libcoverart/Makefile
@@ -4,7 +4,7 @@ PORTNAME= libcoverart
PORTVERSION= 1.0.0
PORTREVISION= 4
CATEGORIES= audio
-MASTER_SITES= https://cloud.github.com/downloads/metabrainz/${PORTNAME}/
+MASTER_SITES= GHC
MAINTAINER= jhale@FreeBSD.org
COMMENT= Library for accessing the MusicBrainz cover art archive
@@ -16,6 +16,8 @@ LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson \
USES= cmake
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= metabrainz
# {PROJECT_VERSION} is not a variable nor a typo, just part of the directory name
WRKSRC= ${WRKDIR}/${PORTNAME}-{PROJECT_VERSION}
diff --git a/audio/mous/Makefile b/audio/mous/Makefile
index 22ff08a56172..4b1b794c1d71 100644
--- a/audio/mous/Makefile
+++ b/audio/mous/Makefile
@@ -5,7 +5,7 @@ PORTNAME= mous
PORTVERSION= 1.1a
PORTREVISION= 4
CATEGORIES= audio
-MASTER_SITES= http://cloud.github.com/downloads/bsdelf/mous/
+MASTER_SITES= GHC
MAINTAINER= shen.elf@gmail.com
COMMENT= Simple yet powerful audio player
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
USES= cmake
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= bsdelf
OPTIONS_DEFINE= ALSA ASSEMBLY FAAC FAAD FLAC LAME AO CUE MAC4DECODER \
MACDECODER MPG123 NCURSES OSS QT4 SDK TAGLIB VORBIS \
diff --git a/audio/shairport/Makefile b/audio/shairport/Makefile
index 1d79536540db..a3ddb9cb7fa1 100644
--- a/audio/shairport/Makefile
+++ b/audio/shairport/Makefile
@@ -5,8 +5,6 @@ PORTNAME= shairport
PORTVERSION= 0.05
PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= http://cloud.github.com/downloads/miks/${PORTNAME}/
-DISTNAME= miks-${PORTNAME}-${REV}
MAINTAINER= miks.mikelsons@gmail.com
COMMENT= Airtunes emulator
@@ -23,6 +21,9 @@ RUN_DEPENDS= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
USES= gmake perl5 pkgconfig
USE_PERL5= run
USE_OPENSSL= yes
+USE_GITHUB= yes
+GH_ACCOUNT= miks
+GH_TAGNAME= b1cb9ea
USE_RC_SUBR= ${PORTNAME}
SUB_LIST= PERL=${PERL}
@@ -30,8 +31,6 @@ SUB_LIST= PERL=${PERL}
PLIST_FILES= bin/${PORTNAME} bin/hairtunes bin/${PORTNAME}.pl
PORTDOCS= README.md
-REV= b1cb9ea
-
OPTIONS_DEFINE= DOCS
post-patch:
diff --git a/audio/shairport/distinfo b/audio/shairport/distinfo
index 5fbdac01a60f..b4afd2c19214 100644
--- a/audio/shairport/distinfo
+++ b/audio/shairport/distinfo
@@ -1,2 +1,2 @@
-SHA256 (miks-shairport-b1cb9ea.tar.gz) = daf55530ba1fecb5a6b5a4c770c97e44cb0ca59a58cd87451975635197e1304f
-SIZE (miks-shairport-b1cb9ea.tar.gz) = 40425
+SHA256 (miks-shairport-0.05-b1cb9ea_GH0.tar.gz) = 0e38b57a90c170a8cd798efe6df00beace91fc30a97da9e6f5568a2e06f6499f
+SIZE (miks-shairport-0.05-b1cb9ea_GH0.tar.gz) = 40413