aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-17 01:07:26 +0800
committerbapt <bapt@FreeBSD.org>2013-09-17 01:07:26 +0800
commite8c033346292b58e029cbed33f2020fa29fab8ec (patch)
tree4fe3821c37cb6d078630d18fa663115222471e1a /audio
parent07673ea56e79850a055955863f379793fb272d54 (diff)
downloadfreebsd-ports-gnome-e8c033346292b58e029cbed33f2020fa29fab8ec.tar.gz
freebsd-ports-gnome-e8c033346292b58e029cbed33f2020fa29fab8ec.tar.zst
freebsd-ports-gnome-e8c033346292b58e029cbed33f2020fa29fab8ec.zip
Convert to new perl framework
Convert from USE_GMAKE to USES=gmake
Diffstat (limited to 'audio')
-rw-r--r--audio/gnormalize/Makefile4
-rw-r--r--audio/ripit/Makefile6
-rw-r--r--audio/squeezeboxserver/Makefile2
3 files changed, 6 insertions, 6 deletions
diff --git a/audio/gnormalize/Makefile b/audio/gnormalize/Makefile
index c6645088556e..10f1e11961d0 100644
--- a/audio/gnormalize/Makefile
+++ b/audio/gnormalize/Makefile
@@ -13,8 +13,8 @@ COMMENT= An alternative for replaygain
RUN_DEPENDS+= p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
wavegain:${PORTSDIR}/audio/wavegain
-USES= shebangfix
-USE_PERL5_RUN= yes
+USES= perl5 shebangfix
+USE_PERL5= run
INSTALLS_ICONS= yes
SHEBANGFILES= ${PORTNAME}
diff --git a/audio/ripit/Makefile b/audio/ripit/Makefile
index 457292749f88..6c86fb6a1849 100644
--- a/audio/ripit/Makefile
+++ b/audio/ripit/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= audio
MASTER_SITES= http://www.suwald.com/ripit/
MAINTAINER= tobias.rehbein@web.de
-COMMENT= A command line audio CD ripper
+COMMENT= Command line audio CD ripper
# See pkg-message about other dependencies.
RUN_DEPENDS= p5-CDDB_get>=0:${PORTSDIR}/audio/p5-CDDB_get \
@@ -18,12 +18,12 @@ RUN_DEPENDS= p5-CDDB_get>=0:${PORTSDIR}/audio/p5-CDDB_get \
lame:${PORTSDIR}/audio/lame \
cdparanoia:${PORTSDIR}/audio/cdparanoia \
-USES= shebangfix
+USES= perl5 shebangfix
NO_BUILD= yes
PLIST_FILES= bin/ripit
MAN1= ripit.1
PORTEXAMPLES= config
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_BZIP2= yes
SHEBANG_FILES= ripit.pl
perl_OLD_CMD= /usr/bin/env perl
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index 7e50c1c970c7..e5574b7074ff 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -44,7 +44,7 @@ RUN_DEPENDS+= p5-Package-DeprecationManager>=0.10:${PORTSDIR}/devel/p5-Package-D
USERS= ${SLIMUSER}
GROUPS= ${SLIMGROUP}
-USE_PERL5= yes
+USES= perl5
.include <bsd.port.pre.mk>