aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-05-16 18:32:07 +0800
committermiwi <miwi@FreeBSD.org>2013-05-16 18:32:07 +0800
commitf63c92b58a2d0aaa465cc59056e58134947c9ea1 (patch)
tree7ebc77a356d09198aa9cc943387283f47e07c2a8 /audio
parentcbd98b5347e0fc46fb8a361257a265a7164fd2db (diff)
downloadfreebsd-ports-gnome-f63c92b58a2d0aaa465cc59056e58134947c9ea1.tar.gz
freebsd-ports-gnome-f63c92b58a2d0aaa465cc59056e58134947c9ea1.tar.zst
freebsd-ports-gnome-f63c92b58a2d0aaa465cc59056e58134947c9ea1.zip
- Update to version 0.1.8
PR: 178597 Submitted by: Ports Fury
Diffstat (limited to 'audio')
-rw-r--r--audio/nekobee/Makefile43
-rw-r--r--audio/nekobee/distinfo4
-rw-r--r--audio/nekobee/pkg-descr16
-rw-r--r--audio/nekobee/pkg-plist3
4 files changed, 41 insertions, 25 deletions
diff --git a/audio/nekobee/Makefile b/audio/nekobee/Makefile
index 3977f6f2e6dd..7389a1401ce8 100644
--- a/audio/nekobee/Makefile
+++ b/audio/nekobee/Makefile
@@ -1,27 +1,42 @@
-# New ports collection makefile for: nekobee
-# Date created: 2007-01-20
-# Whom: trasz <trasz@pin.if.uz.zgora.pl>
-#
+# Created by: trasz <trasz@pin.if.uz.zgora.pl>
# $FreeBSD$
-#
PORTNAME= nekobee
-PORTVERSION= 0.1.7
-PORTREVISION= 5
+PORTVERSION= 0.1.8
CATEGORIES= audio
-MASTER_SITES= http://www.nekosynth.co.uk/releases/
+MASTER_SITES= GH
MAINTAINER= ports@FreeBSD.org
COMMENT= DSSI plugin that emulates the sound of the TB-303 Bassline
-LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
- lo.7:${PORTSDIR}/audio/liblo \
- jack.0:${PORTSDIR}/audio/jack
+LICENSE= GPLv2 # (or later)
+
BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
+LIB_DEPENDS= dssialsacompat:${PORTSDIR}/audio/libdssialsacompat \
+ lo:${PORTSDIR}/audio/liblo \
+ jack:${PORTSDIR}/audio/jack
+
+USE_GITHUB= yes
+GH_ACCOUNT= gordonjcp
+GH_COMMIT= 3f4737f
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_GNOME= gtk20
-CFLAGS+= -I${LOCALBASE}/include/dssi
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include/dssi -I${LOCALBASE}/include
+
+.if !defined(DISABLE_MAKE_JOBS)
+MAKE_JOBS_ARGS= -j${MAKE_JOBS_NUMBER}
+.endif
+
+do-configure:
+ @(cd ${WRKSRC} && ${SETENV} CC="${CC}" CFLAGS="${CFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" ./waf configure --prefix=${PREFIX})
+
+do-build:
+ @(cd ${WRKSRC} && ./waf build -vvv ${MAKE_JOBS_ARGS})
+
+do-install:
+ @(cd ${WRKSRC} && ./waf install)
.include <bsd.port.mk>
diff --git a/audio/nekobee/distinfo b/audio/nekobee/distinfo
index 0c3b85767b50..0470c957ee47 100644
--- a/audio/nekobee/distinfo
+++ b/audio/nekobee/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nekobee-0.1.7.tar.gz) = 9d379eaa25535c3590bb08045db50bca087d80c6594adf96a6b3d909038e6028
-SIZE (nekobee-0.1.7.tar.gz) = 535372
+SHA256 (nekobee-0.1.8.tar.gz) = e9044c58884e87a1f5b396938002419346498c1299d8e87afb6cc27ee163f3be
+SIZE (nekobee-0.1.8.tar.gz) = 350259
diff --git a/audio/nekobee/pkg-descr b/audio/nekobee/pkg-descr
index 8b7c85fd8345..4ed13fd62c3a 100644
--- a/audio/nekobee/pkg-descr
+++ b/audio/nekobee/pkg-descr
@@ -1,8 +1,10 @@
nekobee is a DSSI soft synth plugin that emulates the sound of the
-TB-303 Bassline. It is not an exact copy; rather than make it "just
-like the real thing", the design concentrates on modelling the
-circuitry and was adjusted by comparing the sounds achievable with
-it to those heard on classic acid house tracks. It includes a
-switchable square/saw wave VCO, 24dB/octave VCF, an adjustable decay
-time for the VCF, a fixed decay time for the VCA, and an interesting
-bit of circuitry around the "Accent" control.
+TB-303 Bassline. It is not an exact copy; rather than make it "just like
+the real thing", the design concentrates on modelling the circuitry and
+was adjusted by comparing the sounds achievable with it to those heard
+on classic acid house tracks. It includes a switchable square/saw wave
+VCO, 24dB/octave VCF, an adjustable decay time for the VCF, a fixed
+decay time for the VCA, and an interesting bit of circuitry around the
+"Accent" control.
+
+WWW: https://github.com/gordonjcp/nekobee
diff --git a/audio/nekobee/pkg-plist b/audio/nekobee/pkg-plist
index d25d3156f428..8abacc3b6920 100644
--- a/audio/nekobee/pkg-plist
+++ b/audio/nekobee/pkg-plist
@@ -1,6 +1,5 @@
-lib/dssi/nekobee/nekobee_gtk
lib/dssi/nekobee/knob.png
+lib/dssi/nekobee/nekobee_gtk
lib/dssi/nekobee/switch.png
lib/dssi/nekobee.so
-lib/dssi/nekobee.la
@dirrm lib/dssi/nekobee