aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-05 07:50:54 +0800
committermiwi <miwi@FreeBSD.org>2006-12-05 07:50:54 +0800
commitf93d5b8ac648a4dd252f0ffdc017a9ab5c0882a7 (patch)
tree4dccaab7925e8befd0064f3d1aef6da4412e219f /audio
parent9c8052aec107b51f88e1b2ef96196ee638e3c81b (diff)
downloadfreebsd-ports-gnome-f93d5b8ac648a4dd252f0ffdc017a9ab5c0882a7.tar.gz
freebsd-ports-gnome-f93d5b8ac648a4dd252f0ffdc017a9ab5c0882a7.tar.zst
freebsd-ports-gnome-f93d5b8ac648a4dd252f0ffdc017a9ab5c0882a7.zip
liblo is an implementation of the Open Sound Control
protocol for POSIX systems. WWW: http://liblo.sourceforge.net/ PR: ports/106353 Submitted by: trasz <trasz at pin.if.uz.zgora.pl>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/liblo/Makefile28
-rw-r--r--audio/liblo/distinfo3
-rw-r--r--audio/liblo/files/patch-src-lo_types_internal.h10
-rw-r--r--audio/liblo/pkg-descr4
-rw-r--r--audio/liblo/pkg-plist13
6 files changed, 59 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 98c0ee95df79..a33287e9a833 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -310,6 +310,7 @@
SUBDIR += libgpod
SUBDIR += libid3tag
SUBDIR += libjackasyn
+ SUBDIR += liblo
SUBDIR += libmad
SUBDIR += libmikmod
SUBDIR += libmodplug
diff --git a/audio/liblo/Makefile b/audio/liblo/Makefile
new file mode 100644
index 000000000000..ac1efc74b965
--- /dev/null
+++ b/audio/liblo/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: liblo
+# Date created: 2006-12-04
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liblo
+PORTVERSION= 0.23
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= liblo
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Lightweight Open Sound Control implementation
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/liblo/distinfo b/audio/liblo/distinfo
new file mode 100644
index 000000000000..c2329b2a4dc3
--- /dev/null
+++ b/audio/liblo/distinfo
@@ -0,0 +1,3 @@
+MD5 (liblo-0.23.tar.gz) = e14c9f4fae7ed8d9622d126f6fb9c1d7
+SHA256 (liblo-0.23.tar.gz) = 705937c1ca37de0d274f39719b934f16bef94c48d67550ba79e8e0518fe79a86
+SIZE (liblo-0.23.tar.gz) = 419662
diff --git a/audio/liblo/files/patch-src-lo_types_internal.h b/audio/liblo/files/patch-src-lo_types_internal.h
new file mode 100644
index 000000000000..e223c5c9b424
--- /dev/null
+++ b/audio/liblo/files/patch-src-lo_types_internal.h
@@ -0,0 +1,10 @@
+--- src/lo_types_internal.h.orig Mon Dec 4 23:29:22 2006
++++ src/lo_types_internal.h Mon Dec 4 23:29:32 2006
+@@ -9,6 +9,7 @@
+ #endif
+
+ #include <pthread.h>
++#include <sys/socket.h>
+
+ #include "lo/lo_osc_types.h"
+
diff --git a/audio/liblo/pkg-descr b/audio/liblo/pkg-descr
new file mode 100644
index 000000000000..627ad8490fa1
--- /dev/null
+++ b/audio/liblo/pkg-descr
@@ -0,0 +1,4 @@
+liblo is an implementation of the Open Sound Control
+protocol for POSIX systems.
+
+WWW: http://liblo.sourceforge.net/
diff --git a/audio/liblo/pkg-plist b/audio/liblo/pkg-plist
new file mode 100644
index 000000000000..4a14d5f47b4c
--- /dev/null
+++ b/audio/liblo/pkg-plist
@@ -0,0 +1,13 @@
+include/lo/lo_errors.h
+include/lo/lo.h
+include/lo/lo_lowlevel.h
+include/lo/lo_throw.h
+include/lo/lo_types.h
+include/lo/lo_osc_types.h
+include/lo/lo_endian.h
+include/lo/lo_macros.h
+lib/liblo.so.6
+lib/liblo.so
+lib/liblo.la
+libdata/pkgconfig/liblo.pc
+@dirrmtry include/lo