aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-04-27 19:09:33 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-04-27 19:09:33 +0800
commitfa88ec7f1d46a812bd02c77e904acaee9708572e (patch)
tree633f991a92d1a0ae51d416ab35c2c979531b4ac9 /audio
parenta1500de8d5fdd2b19b2cf96b31ab4b74ea106b68 (diff)
downloadfreebsd-ports-gnome-fa88ec7f1d46a812bd02c77e904acaee9708572e.tar.gz
freebsd-ports-gnome-fa88ec7f1d46a812bd02c77e904acaee9708572e.tar.zst
freebsd-ports-gnome-fa88ec7f1d46a812bd02c77e904acaee9708572e.zip
- Fix memory leak
- Bump PORTREVISION for package change PR: ports/165003 Submitted by: Eugene Grosbein <eugen@grosbein.net> Obtained from: http://old.nabble.com/Memory-leak-on-Icecast-2.3.2---Debian---td26691536.html
Diffstat (limited to 'audio')
-rw-r--r--audio/icecast2/Makefile2
-rw-r--r--audio/icecast2/files/patch-src-stats.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/audio/icecast2/Makefile b/audio/icecast2/Makefile
index 4d7e9049abfe..a686fc20d370 100644
--- a/audio/icecast2/Makefile
+++ b/audio/icecast2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= icecast2
PORTVERSION= 2.3.2
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= audio net ipv6
MASTER_SITES= http://downloads.xiph.org/releases/icecast/ \
diff --git a/audio/icecast2/files/patch-src-stats.c b/audio/icecast2/files/patch-src-stats.c
new file mode 100644
index 000000000000..3d763a99c5e5
--- /dev/null
+++ b/audio/icecast2/files/patch-src-stats.c
@@ -0,0 +1,14 @@
+--- src/stats.c.orig 2008-05-01 10:22:40.000000000 +0800
++++ src/stats.c 2012-04-24 02:22:44.574821557 +0800
+@@ -973,7 +973,11 @@
+ if (event->source)
+ {
+ if (show_mount && strcmp (event->source, show_mount) != 0)
++ {
++ xmlFree (name);
++ xmlFree (value);
+ break;
++ }
+ srcnode = _find_xml_node(event->source, &src_nodes, node);
+ }
+ else