aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-02-24 21:57:23 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-02-24 21:57:23 +0800
commitfe6bac721794719e7cfb819da140b4f084f988bf (patch)
tree83a040254b0a1a6a2a7ffffcec68c97a307d5932 /audio
parent7872f36348ec5a6321afce135a06b17b7bd63d24 (diff)
downloadfreebsd-ports-gnome-fe6bac721794719e7cfb819da140b4f084f988bf.tar.gz
freebsd-ports-gnome-fe6bac721794719e7cfb819da140b4f084f988bf.tar.zst
freebsd-ports-gnome-fe6bac721794719e7cfb819da140b4f084f988bf.zip
- Add LICENSE
- Strip library
Diffstat (limited to 'audio')
-rw-r--r--audio/py-vorbis/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/audio/py-vorbis/Makefile b/audio/py-vorbis/Makefile
index 68eb4e640a42..e995e5373183 100644
--- a/audio/py-vorbis/Makefile
+++ b/audio/py-vorbis/Makefile
@@ -12,6 +12,9 @@ DISTNAME= pyvorbis-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Object-oriented Python bindings for the vorbis library
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/ogg/_ogg.so:${PORTSDIR}/audio/py-ogg
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ogg/_ogg.so:${PORTSDIR}/audio/py-ogg
LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
@@ -26,4 +29,7 @@ post-patch:
do-configure:
@cd ${WRKSRC} && ${PYTHON_CMD} config_unix.py
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/ogg/vorbis.so
+
.include <bsd.port.mk>