aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-08-26 18:45:45 +0800
committerpawel <pawel@FreeBSD.org>2016-08-26 18:45:45 +0800
commit0275745f1f0a598b4af618a8704e481347aeab9e (patch)
tree6e9f58602bf8247c72bae60cd57b4e06b97fee78 /audio
parent672517d20004f70591b14208db9f538e093a4116 (diff)
downloadfreebsd-ports-gnome-0275745f1f0a598b4af618a8704e481347aeab9e.tar.gz
freebsd-ports-gnome-0275745f1f0a598b4af618a8704e481347aeab9e.tar.zst
freebsd-ports-gnome-0275745f1f0a598b4af618a8704e481347aeab9e.zip
- Convert to USES=localbase sqlite
- Add LICENSE info - Register proxy dependencies found by stage-qa
Diffstat (limited to 'audio')
-rw-r--r--audio/gmpc/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/audio/gmpc/Makefile b/audio/gmpc/Makefile
index 4a3c4a8cc94d..e386a1380963 100644
--- a/audio/gmpc/Makefile
+++ b/audio/gmpc/Makefile
@@ -12,21 +12,25 @@ MASTER_SITES= http://download.sarine.nl/Programs/gmpc/${PORTVERSION}/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Full featured GTK2 client for musicpd
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= gob2:devel/gob2 \
valac:lang/vala
LIB_DEPENDS= libmpd.so:audio/libmpd \
libsexy.so:x11-toolkits/libsexy \
- libsqlite3.so:databases/sqlite3 \
libsoup-2.4.so:devel/libsoup \
- libunique-1.0.so:x11-toolkits/unique
+ libunique-1.0.so:x11-toolkits/unique \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
GNU_CONFIGURE= yes
-USES= gettext gmake libtool pathfix pkgconfig
-USE_GNOME= glib20 gtk20 intltool libglade2
+USES= gettext gmake libtool localbase pathfix pkgconfig sqlite
+USE_XORG= ice sm x11
+USE_GNOME= cairo glib20 gtk20 intltool libglade2
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --enable-system-libsexy
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lm
+LIBS+= -lm
OPTIONS_DEFINE= MMKEYS XSPF
OPTIONS_DEFAULT= MMKEYS