aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-11-13 02:15:54 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-11-13 02:15:54 +0800
commit0561a866507288b1d5e995e0ecde1b0b8ddbdbc7 (patch)
treee2a778de0f91058c84e3de95bf9f977e4e5d0e96 /audio
parentbe84d6e3227d5b1e4d35e1ad961f0bdb1e090a13 (diff)
downloadfreebsd-ports-gnome-0561a866507288b1d5e995e0ecde1b0b8ddbdbc7.tar.gz
freebsd-ports-gnome-0561a866507288b1d5e995e0ecde1b0b8ddbdbc7.tar.zst
freebsd-ports-gnome-0561a866507288b1d5e995e0ecde1b0b8ddbdbc7.zip
- Add fplib 20100712
The last.fm fingerprint library The fingerprinting process works in two steps: 1. Get PCM data and pass it to *fplib* which will return byte string to be submitted to the last.fm HTTP fingerprint service. This will return a number (fingerprintID). 2. Query the last.fm API with the fingerprintID and obtain the metadata in xml format. The lastfmfpclient directory contains an example of application that uses fplib and queries both services. WWW: https://github.com/lastfm/Fingerprinter Feature safe: yes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/fplib/Makefile44
-rw-r--r--audio/fplib/distinfo2
-rw-r--r--audio/fplib/pkg-descr13
4 files changed, 60 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 2a3f710896b7..27f7edbf798b 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -190,6 +190,7 @@
SUBDIR += fpc-oggvorbis
SUBDIR += fpc-openal
SUBDIR += fpc-sndfile
+ SUBDIR += fplib
SUBDIR += freealut
SUBDIR += freedesktop-sound-theme
SUBDIR += freepats
diff --git a/audio/fplib/Makefile b/audio/fplib/Makefile
new file mode 100644
index 000000000000..9d26ca8469f1
--- /dev/null
+++ b/audio/fplib/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: fplib
+# Date created: 2011-11-12
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fplib
+PORTVERSION= 20100712
+CATEGORIES= audio
+MASTER_SITES= LOCAL/sunpoet
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Last.fm fingerprint library
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ fftw3f:${PORTSDIR}/math/fftw3-float \
+ mad:${PORTSDIR}/audio/libmad \
+ samplerate:${PORTSDIR}/audio/libsamplerate \
+ tag:${PORTSDIR}/audio/taglib
+
+CPPFLAGS+= -I${LOCALBASE}/include
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+USE_XZ= yes
+
+PLIST_FILES= bin/lastfmfpclient \
+ lib/liblastfmfp.a \
+ lib/liblastfmfp.so \
+ lib/liblastfmfp.so.1 \
+ lib/liblastfmfp.so.1.6.0
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|\(ADD_DEFINITIONS\)(.*)|\1(${CFLAGS} ${CPPFLAGS})|' \
+ -e 's|\(OUTPUT_NAME lastfmfp\)_static|\1|' \
+ ${WRKSRC}/fplib/CMakeLists.txt
+ @${REINPLACE_CMD} \
+ -e 's|\(ADD_DEFINITIONS\)(.*)|\1(${CFLAGS} ${CPPFLAGS})|' \
+ -e 's|^\(LINK_DIRECTORIES\)(.*)|\1(${LOCALBASE}/lib)|' \
+ -e 's| lastfmfp_static| lastfmfp_shared|' \
+ ${WRKSRC}/lastfmfpclient/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/audio/fplib/distinfo b/audio/fplib/distinfo
new file mode 100644
index 000000000000..bca6fe3f74e7
--- /dev/null
+++ b/audio/fplib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fplib-20100712.tar.xz) = 27db1a34a73c67cafb87c3a3f44520b314f6aa1b01ebe9cefd3893ac55147db3
+SIZE (fplib-20100712.tar.xz) = 38932
diff --git a/audio/fplib/pkg-descr b/audio/fplib/pkg-descr
new file mode 100644
index 000000000000..f731e99b5f07
--- /dev/null
+++ b/audio/fplib/pkg-descr
@@ -0,0 +1,13 @@
+The last.fm fingerprint library
+
+The fingerprinting process works in two steps:
+1. Get PCM data and pass it to *fplib* which will return byte string to be
+ submitted to the last.fm HTTP fingerprint service. This will return a number
+ (fingerprintID).
+2. Query the last.fm API with the fingerprintID and obtain the metadata in xml
+ format.
+
+The lastfmfpclient directory contains an example of application that uses fplib
+and queries both services.
+
+WWW: https://github.com/lastfm/Fingerprinter