aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorvg <vg@FreeBSD.org>2017-12-22 16:54:09 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:12:30 +0800
commit0a04046b0809be4dfa28476d63000601d38cb09b (patch)
tree89168ac9b3ead4603a7377260428a5c501700495 /audio
parent1f7a62f5d596ff36dab6970d1c4f5b4b7f108117 (diff)
downloadfreebsd-ports-gnome-0a04046b0809be4dfa28476d63000601d38cb09b.tar.gz
freebsd-ports-gnome-0a04046b0809be4dfa28476d63000601d38cb09b.tar.zst
freebsd-ports-gnome-0a04046b0809be4dfa28476d63000601d38cb09b.zip
- Fix build issue on 11.x+
Diffstat (limited to 'audio')
-rw-r--r--audio/lastfm-desktop/Makefile6
-rw-r--r--audio/lastfm-desktop/files/patch-app_client_Application.cpp11
2 files changed, 12 insertions, 5 deletions
diff --git a/audio/lastfm-desktop/Makefile b/audio/lastfm-desktop/Makefile
index 8863c5e89478..5a008e8f990b 100644
--- a/audio/lastfm-desktop/Makefile
+++ b/audio/lastfm-desktop/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lastfm-desktop
PORTVERSION= 2.1.36
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MAINTAINER= vg@FreeBSD.org
@@ -43,10 +43,6 @@ VLC_RUN_DEPENDS= phonon-vlc>=0.6.1:multimedia/phonon-vlc
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 1100000
-BROKEN= does not buld: Application.cpp:433:25: error: ordered comparison between pointer and zero ('void *' and 'int')
-.endif
-
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/lastfm-desktop.sh ${STAGEDIR}${PREFIX}/bin/lastfm-desktop
diff --git a/audio/lastfm-desktop/files/patch-app_client_Application.cpp b/audio/lastfm-desktop/files/patch-app_client_Application.cpp
new file mode 100644
index 000000000000..15092c0f1b07
--- /dev/null
+++ b/audio/lastfm-desktop/files/patch-app_client_Application.cpp
@@ -0,0 +1,11 @@
+--- app/client/Application.cpp.orig 2017-12-21 08:34:38 UTC
++++ app/client/Application.cpp
+@@ -430,7 +430,7 @@ Application::showAs( bool showAs )
+ void
+ Application::setRaiseHotKey( Qt::KeyboardModifiers mods, int key )
+ {
+- if( m_raiseHotKeyId >= 0 )
++ if( m_raiseHotKeyId >= (void *)0 )
+ unInstallHotKey( m_raiseHotKeyId );
+
+ m_raiseHotKeyId = installHotKey( mods, key, m_toggle_window_action, SLOT(trigger()));