aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-12 18:05:43 +0800
committermiwi <miwi@FreeBSD.org>2013-02-12 18:05:43 +0800
commit0e9fea8b8d9a6b48f9eea481bdb414816ef7b8cf (patch)
tree5074ec0244cb671ce320d2f3a49366ff5d43897d /audio
parent5190465b64de7418d7b9be0fc02fc964fbf977ae (diff)
downloadfreebsd-ports-gnome-0e9fea8b8d9a6b48f9eea481bdb414816ef7b8cf.tar.gz
freebsd-ports-gnome-0e9fea8b8d9a6b48f9eea481bdb414816ef7b8cf.tar.zst
freebsd-ports-gnome-0e9fea8b8d9a6b48f9eea481bdb414816ef7b8cf.zip
GTMixer is a free, simple graphical mixer for FreeBSD.
Based at GTK 2.0 Lib. WWW: https://github.com/svagner/gtmixer PR: ports/174656 Submitted by: Putrya Statislav
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gtmixer/Makefile26
-rw-r--r--audio/gtmixer/distinfo2
-rw-r--r--audio/gtmixer/pkg-descr4
-rw-r--r--audio/gtmixer/pkg-plist10
5 files changed, 43 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f15eb9927d76..37781ba1625a 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -289,6 +289,7 @@
SUBDIR += gtick
SUBDIR += gtkguitune
SUBDIR += gtkpod
+ SUBDIR += gtmixer
SUBDIR += guspat
SUBDIR += gvolwheel
SUBDIR += gxmms2
diff --git a/audio/gtmixer/Makefile b/audio/gtmixer/Makefile
new file mode 100644
index 000000000000..347180a3c314
--- /dev/null
+++ b/audio/gtmixer/Makefile
@@ -0,0 +1,26 @@
+# Created by: Putrya Statislav
+# $FreeBSD$
+
+PORTNAME= gtmixer
+PORTVERSION= 1.0.2
+CATEGORIES= audio
+MASTER_SITES= http://github.com/svagner/gtmixer/archive/
+DISTNAME= ${PORTVERSION}
+
+MAINTAINER= vagner@bsdway.ru
+COMMENT= GTK2.0 Sound Mixer
+
+LICENSE= BSD
+
+USE_GNOME= gtk20
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+FETCH_ARGS= -Fpr
+
+MAN1= gtmixer.1
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/gtmixer
+ @${CP} -r ${WRKSRC}/icons ${PREFIX}/share/gtmixer/
+ @${INSTALL_MAN} ${WRKSRC}/gtmixer.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/audio/gtmixer/distinfo b/audio/gtmixer/distinfo
new file mode 100644
index 000000000000..3ab6428bbea6
--- /dev/null
+++ b/audio/gtmixer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (1.0.2.tar.gz) = 3c9382074427ba6cb6320c747037baac9e38269e40b8383e17681451c8bfe69e
+SIZE (1.0.2.tar.gz) = 126819
diff --git a/audio/gtmixer/pkg-descr b/audio/gtmixer/pkg-descr
new file mode 100644
index 000000000000..65edbebee169
--- /dev/null
+++ b/audio/gtmixer/pkg-descr
@@ -0,0 +1,4 @@
+GTMixer is a free, simple graphical mixer for FreeBSD.
+Based at GTK 2.0 Lib.
+
+WWW: https://github.com/svagner/gtmixer
diff --git a/audio/gtmixer/pkg-plist b/audio/gtmixer/pkg-plist
new file mode 100644
index 000000000000..1aef8092ba47
--- /dev/null
+++ b/audio/gtmixer/pkg-plist
@@ -0,0 +1,10 @@
+%%DATADIR%%/icons/tray/1.png
+%%DATADIR%%/icons/tray/2.png
+%%DATADIR%%/icons/tray/273.png
+%%DATADIR%%/icons/tray/275.png
+%%DATADIR%%/icons/tray/3.png
+%%DATADIR%%/icons/tray/430.png
+%%DATADIR%%/icons/tray/431.png
+@dirrmtry %%DATADIR%%/icons/tray
+@dirrmtry %%DATADIR%%/icons
+@dirrmtry %%DATADIR%%