aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-08-18 05:53:30 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:22:53 +0800
commit0f7e4afa663673a251e388059d137ef0bae34003 (patch)
tree18bfa1df81d8009960daec8b27b85a22f0a11f75 /audio
parentde440ef42de4f437c987c4b75f6d20bd904dc9f9 (diff)
downloadfreebsd-ports-gnome-0f7e4afa663673a251e388059d137ef0bae34003.tar.gz
freebsd-ports-gnome-0f7e4afa663673a251e388059d137ef0bae34003.tar.zst
freebsd-ports-gnome-0f7e4afa663673a251e388059d137ef0bae34003.zip
lv2file is a simple program which you can use to apply effects to your audio
files without much hassle. Possible use cases are: * When you want to apply an effect without having to open a GUI or start a project. * When you want to apply effects to a large number of files, or in an automated manner. * When you need a deterministic environment to debug a plugin. * You like everything to be on the command line. lv2file uses the LV2 plugin format (http://lv2plug.in/) for the effects it uses. WWW: https://github.com/jeremysalwen/lv2file PR: 221214 Submitted by: Yuri Victorovich (maintainer) Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D12058
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/lv2file/Makefile32
-rw-r--r--audio/lv2file/distinfo3
-rw-r--r--audio/lv2file/files/patch-Makefile12
-rw-r--r--audio/lv2file/pkg-descr12
5 files changed, 60 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index a92f5b30c7cc..d54229f29795 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -473,6 +473,7 @@
SUBDIR += lpac
SUBDIR += lua51-mpd
SUBDIR += lv2
+ SUBDIR += lv2file
SUBDIR += lvtk
SUBDIR += lxmusic
SUBDIR += mac
diff --git a/audio/lv2file/Makefile b/audio/lv2file/Makefile
new file mode 100644
index 000000000000..002ba3ea09b9
--- /dev/null
+++ b/audio/lv2file/Makefile
@@ -0,0 +1,32 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= lv2file
+DISTVERSION= 0.82-1-19
+DISTVERSIONSUFFIX= -gaed7c77
+CATEGORIES= audio
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Simple program that apples LV2 effects to audio files
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+LIB_DEPENDS= libargtable2.so:devel/argtable \
+ libserd-0.so:devel/serd \
+ libsord-0.so:devel/sord \
+ liblilv-0.so:audio/lilv \
+ libsndfile.so:audio/libsndfile \
+ libsratom-0.so:audio/sratom
+
+USES= gmake localbase pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= jeremysalwen
+PLIST_FILES= bin/lv2file man/man1/lv2file.1.gz
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/debian/lv2file.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lv2file
+
+.include <bsd.port.mk>
diff --git a/audio/lv2file/distinfo b/audio/lv2file/distinfo
new file mode 100644
index 000000000000..dafa55a6c93f
--- /dev/null
+++ b/audio/lv2file/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502946273
+SHA256 (jeremysalwen-lv2file-0.82-1-19-gaed7c77_GH0.tar.gz) = d5cef1d28d53e365d72f294c3b4eb10edac8079597c81b3f7dd3460a2cba8a6c
+SIZE (jeremysalwen-lv2file-0.82-1-19-gaed7c77_GH0.tar.gz) = 9977
diff --git a/audio/lv2file/files/patch-Makefile b/audio/lv2file/files/patch-Makefile
new file mode 100644
index 000000000000..3ec12cfab5e5
--- /dev/null
+++ b/audio/lv2file/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig 2014-04-06 11:34:47 UTC
++++ Makefile
+@@ -1,6 +1,6 @@
+-CFLAGS = -O3 -Wall -Wextra --std=c99 `pkg-config --cflags argtable2 sndfile lilv-0`
+-LDLIBS = `pkg-config --libs argtable2 sndfile lilv-0` -lm
+-BINDIR = $(DESTDIR)/usr/bin
++CFLAGS += -Wall -Wextra --std=c99 `pkg-config --cflags argtable2 sndfile lilv-0`
++LDLIBS += `pkg-config --libs argtable2 sndfile lilv-0` -lm
++BINDIR = $(DESTDIR)/$(PREFIX)/bin
+ INSTALL_PROGRAM = install
+
+ all: lv2file
diff --git a/audio/lv2file/pkg-descr b/audio/lv2file/pkg-descr
new file mode 100644
index 000000000000..fc6182af17d1
--- /dev/null
+++ b/audio/lv2file/pkg-descr
@@ -0,0 +1,12 @@
+lv2file is a simple program which you can use to apply effects to your audio
+files without much hassle. Possible use cases are:
+* When you want to apply an effect without having to open a GUI or start
+ a project.
+* When you want to apply effects to a large number of files, or in
+ an automated manner.
+* When you need a deterministic environment to debug a plugin.
+* You like everything to be on the command line.
+
+lv2file uses the LV2 plugin format (http://lv2plug.in/) for the effects it uses.
+
+WWW: https://github.com/jeremysalwen/lv2file