aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2004-08-05 22:30:08 +0800
committerroam <roam@FreeBSD.org>2004-08-05 22:30:08 +0800
commit10943889358d073a282eee189f24e91946079996 (patch)
tree6586d8e737b10813c02d2c45964aeea8c8ac36af /audio
parentd4e876d45cf13eed11ea31eb0122d68b9a1c9352 (diff)
downloadfreebsd-ports-gnome-10943889358d073a282eee189f24e91946079996.tar.gz
freebsd-ports-gnome-10943889358d073a282eee189f24e91946079996.tar.zst
freebsd-ports-gnome-10943889358d073a282eee189f24e91946079996.zip
Fix a function prototype to get this to build with -CURRENT's gcc 3.4.
Diffstat (limited to 'audio')
-rw-r--r--audio/wavplay/Makefile1
-rw-r--r--audio/wavplay/files/patch-wavplay.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/audio/wavplay/Makefile b/audio/wavplay/Makefile
index 94416f28207d..308aa50b82b0 100644
--- a/audio/wavplay/Makefile
+++ b/audio/wavplay/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wavplay
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/sound/players
diff --git a/audio/wavplay/files/patch-wavplay.h b/audio/wavplay/files/patch-wavplay.h
new file mode 100644
index 000000000000..ac3a9dd7ac08
--- /dev/null
+++ b/audio/wavplay/files/patch-wavplay.h
@@ -0,0 +1,11 @@
+--- wavplay.h.orig Thu Aug 5 17:24:45 2004
++++ wavplay.h Thu Aug 5 17:24:49 2004
+@@ -500,7 +500,7 @@
+ extern int UnlockDSP(int ipc,int playrecx,ErrFunc erf);
+
+ extern WAVFILE *WavOpenForRead(const char *Pathname,ErrFunc erf);
+-extern WAVFILE *WavOpenForWrite(const char *Pathname,OprMode m,UInt32 sample_rate,UInt16 bits,UInt32 samples,ErrFunc erf);
++extern WAVFILE *WavOpenForWrite(const char *Pathname,Chan chmode,UInt32 sample_rate,UInt16 bits,UInt32 samples,ErrFunc erf);
+ extern void WavReadOverrides(WAVFILE *wfile,WavPlayOpts *wavopts);
+ extern int WavClose(WAVFILE *wfile,ErrFunc erf);
+