aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-10-18 20:40:02 +0800
committerjhale <jhale@FreeBSD.org>2012-10-18 20:40:02 +0800
commit13845330b5a53fcec5f1de00d03b8f67ba68dabf (patch)
tree0390606a257e4104e2f800ff96d34e3ac7eefb0b /audio
parented5c4cd61f9a52bc6bdb5bcec486e2ba4ce9c019 (diff)
downloadfreebsd-ports-gnome-13845330b5a53fcec5f1de00d03b8f67ba68dabf.tar.gz
freebsd-ports-gnome-13845330b5a53fcec5f1de00d03b8f67ba68dabf.tar.zst
freebsd-ports-gnome-13845330b5a53fcec5f1de00d03b8f67ba68dabf.zip
Libcoverart is a client library for accessing the MusicBrainz cover
art archive. WWW: http://coverartarchive.org/ Approved by: makc (mentor) Feature safe: yes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libcoverart/Makefile30
-rw-r--r--audio/libcoverart/distinfo2
-rw-r--r--audio/libcoverart/pkg-descr4
-rw-r--r--audio/libcoverart/pkg-plist15
5 files changed, 52 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index d238215b21af..8b31e5f0f356 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -356,6 +356,7 @@
SUBDIR += libcddb
SUBDIR += libcddb-doc
SUBDIR += libconvolve
+ SUBDIR += libcoverart
SUBDIR += libdiscid
SUBDIR += libdssialsacompat
SUBDIR += libfishsound
diff --git a/audio/libcoverart/Makefile b/audio/libcoverart/Makefile
new file mode 100644
index 000000000000..ea61ab351e5b
--- /dev/null
+++ b/audio/libcoverart/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= libcoverart
+PORTVERSION= 1.0.0
+CATEGORIES= audio
+MASTER_SITES= https://cloud.github.com/downloads/metabrainz/${PORTNAME}/
+
+MAINTAINER= jhale@FreeBSD.org
+COMMENT= Library for accessing the MusicBrainz cover art archive
+
+LICENSE= LGPL20
+
+LIB_DEPENDS= jansson:${PORTSDIR}/devel/jansson \
+ neon:${PORTSDIR}/www/neon29
+
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+MAKE_JOBS_SAFE= yes
+
+# {PROJECT_VERSION} is not a variable nor a typo, just part of the directory name
+WRKSRC= ${WRKDIR}/${PORTNAME}-{PROJECT_VERSION}
+
+post-patch:
+ ${REINPLACE_CMD} -e '/pkgconfig/s|$${LIB_INSTALL_DIR}|libdata|' \
+ ${WRKSRC}/CMakeLists.txt
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/cmake/modules/*.cmake
+
+.include <bsd.port.mk>
diff --git a/audio/libcoverart/distinfo b/audio/libcoverart/distinfo
new file mode 100644
index 000000000000..21bca8632ffd
--- /dev/null
+++ b/audio/libcoverart/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libcoverart-1.0.0.tar.gz) = e4cb78939003a4b5e5c4db68e42e86fbbbea5e69d3166b43ca01a7065916a121
+SIZE (libcoverart-1.0.0.tar.gz) = 57950
diff --git a/audio/libcoverart/pkg-descr b/audio/libcoverart/pkg-descr
new file mode 100644
index 000000000000..1c33d7ec9807
--- /dev/null
+++ b/audio/libcoverart/pkg-descr
@@ -0,0 +1,4 @@
+Libcoverart is a client library for accessing the MusicBrainz cover
+art archive.
+
+WWW: http://coverartarchive.org/
diff --git a/audio/libcoverart/pkg-plist b/audio/libcoverart/pkg-plist
new file mode 100644
index 000000000000..2eabb3604479
--- /dev/null
+++ b/audio/libcoverart/pkg-plist
@@ -0,0 +1,15 @@
+include/coverart/CoverArt.h
+include/coverart/HTTPFetch.h
+include/coverart/Image.h
+include/coverart/ImageList.h
+include/coverart/ReleaseInfo.h
+include/coverart/Thumbnails.h
+include/coverart/Type.h
+include/coverart/TypeList.h
+include/coverart/caa_c.h
+include/coverart/defines.h
+lib/libcoverart.so
+lib/libcoverart.so.0
+lib/libcoverart.so.0.0.1
+libdata/pkgconfig/libcoverart.pc
+@dirrm include/coverart