aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-02-02 17:37:15 +0800
committeralexbl <alexbl@FreeBSD.org>2007-02-02 17:37:15 +0800
commit18a239b5342894eea31f726a8ba4f4aa6c04a72d (patch)
tree859135b805775259299383efa27ccae4cc27391c /audio
parent2168a23d4048ba6f5c31ff19c7da3c8052a62fba (diff)
downloadfreebsd-ports-gnome-18a239b5342894eea31f726a8ba4f4aa6c04a72d.tar.gz
freebsd-ports-gnome-18a239b5342894eea31f726a8ba4f4aa6c04a72d.tar.zst
freebsd-ports-gnome-18a239b5342894eea31f726a8ba4f4aa6c04a72d.zip
- Remove some 4.x stuff
- go over and cleanup the logic for the mDNS checks to hopefully resolve the double target mDNS problem caused by avahi. [1], [2] PR: 108533 [1], 108538 [2]
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms2/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 8ea4f588028d..7f61b58c4da6 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -179,9 +179,6 @@ PLIST_SUB+= SAMBA="@comment "
.endif
.if !defined(WITHOUT_DAAP)
-.if ${OSVERSION} < 500000
-IGNORE= DAAP support is broken on FreeBSD 4.x
-.endif
PLIST_SUB+= DAAP=""
.else
EXCLUDE+= daap
@@ -230,10 +227,10 @@ PLIST_SUB+= AO="@comment "
.endif
.if defined(WITH_MDNS_AVAHI)
-.if defined(WITH_MDNS_APPLE)
+.if !defined(WITHOUT_MDNS_APPLE)
BROKEN= You may choose either MDNS_APPLE or MDNS_AVAHI, but not both
.endif
-EXCLUDE+= dnssd
+EXCLUDE+= dnssd dns_sd
LIB_DEPENDS+= avahi-core:${PORTSDIR}/net/avahi
PLIST_SUB+= MDNS_AVAHI=""
.else
@@ -249,7 +246,7 @@ EXCLUDE+= avahi
LIB_DEPENDS+= dns_sd:${PORTSDIR}/net/mDNSResponder
PLIST_SUB+= MDNS_APPLE=""
.else
-EXCLUDE+= dnssd
+EXCLUDE+= dnssd dns_sd
PLIST_SUB+= MDNS_APPLE="@comment "
.endif
.endif
@@ -263,10 +260,4 @@ EXCLUDE+= vocoder
PLIST_SUB+= VOCODER="@comment "
.endif
-.if defined(XMMS2_SLAVE) && ${XMMS2_SLAVE} != "java"
-.if ${OSVERSION} < 500000
-IGNORE= broken on FreeBSD 4.x
-.endif
-.endif
-
.include <bsd.port.post.mk>