aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-21 09:44:08 +0800
committertrevor <trevor@FreeBSD.org>2003-11-21 09:44:08 +0800
commit18b64c884d1ef8dff329d102ccdb2ec3579a78a6 (patch)
treefb3f071e14bd9b6ab8d23557a9509925ec46b69f /audio
parentbac53b2b18cb65d7c906b3bc6ba8ef9bae8b1ebb (diff)
downloadfreebsd-ports-gnome-18b64c884d1ef8dff329d102ccdb2ec3579a78a6.tar.gz
freebsd-ports-gnome-18b64c884d1ef8dff329d102ccdb2ec3579a78a6.tar.zst
freebsd-ports-gnome-18b64c884d1ef8dff329d102ccdb2ec3579a78a6.zip
Remove OGI support (see ports/audio/festival+OGI).
Diffstat (limited to 'audio')
-rw-r--r--audio/festival/Makefile41
-rw-r--r--audio/festival/files/extra-patch-aa-ogi20
-rw-r--r--audio/festival/pkg-descr2
-rw-r--r--audio/festival/pkg-plist-ogi14
4 files changed, 2 insertions, 75 deletions
diff --git a/audio/festival/Makefile b/audio/festival/Makefile
index f78f62b06d21..aedf60356cdd 100644
--- a/audio/festival/Makefile
+++ b/audio/festival/Makefile
@@ -13,19 +13,8 @@ PORTREVISION= 1
CATEGORIES= audio accessibility
MASTER_SITES= ${MASTER_SITE_FESTIVAL}
MASTER_SITE_SUBDIR= ${PORTVERSION}
-.if defined (WITH_OGI)
-MASTER_SITES+= ${PATCH_SITES}
-PATCH_SITES= ${MASTER_SITE_FESTIVAL_OGI}
-.endif
DISTFILES= ${DISTNAME}.tar.gz \
speech_tools-1.2.1.tar.gz
-.if defined (WITH_OGI)
-DISTFILES+= OGIresLPC-2.0.4.tar.gz
-.endif
-
-.if defined (WITH_OGI)
-PATCHFILES= OGIfestpatch-${PORTVERSION}.tar.gz
-.endif
MAINTAINER= trevor@FreeBSD.org
COMMENT= Multi-lingual speech synthesis system
@@ -36,16 +25,9 @@ LIB_DEPENDS= audio.2:${PORTSDIR}/audio/nas \
DIST_SUBDIR= festival
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-aa
-.if defined (WITH_OGI)
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-aa-ogi
-RESTRICTED= no-commercial-use
-.endif
FESTIVAL_ARCH= ${MACHINE_ARCH:S/i386/ix86/}
USE_GCC= 2.95
-.if defined (WITH_OGI)
-PLIST= ${WRKDIR}/pkg-plist
-.endif
WRKSRC= ${WRKDIR}
@@ -76,24 +58,6 @@ MAKE_ENV+= PKG_EST_HOME=${SPEECHTOOLS} \
MAN1= festival.1 festival_client.1
-.if defined (WITH_OGI)
-post-extract:
- @${GUNZIP_CMD} -dc ${DISTDIR}/${DIST_SUBDIR}/OGIfestpatch-${PORTVERSION}.tar.gz \
- | ${TAR} -C ${WRKSRC} -xf -
-.endif
-
-.if !defined(WITH_OGI)
-pre-fetch:
- @${ECHO}
- @${ECHO_MSG} "********************************************************"
- @${ECHO_MSG} "* To build this port with the OGI enhancements, define *"
- @${ECHO_MSG} "* \"WITH_OGI\" and restart the build. The license for *"
- @${ECHO_MSG} "* the OGI materials prohibits commercial use, but they *"
- @${ECHO_MSG} "* are required by some of the voices. *"
- @${ECHO_MSG} "********************************************************"
- @${ECHO}
-.endif
-
pre-patch:
${CP} ${SPEECHTOOLS}/config/config-dist ${SPEECHTOOLS}/config/config &&\
${CHMOD} u+w ${SPEECHTOOLS}/config/config
@@ -123,11 +87,6 @@ post-patch:
.endfor
.endfor
-pre-install:
-.if defined (WITH_OGI)
- ${CAT} ${PKGDIR}/pkg-plist-ogi ${PKGDIR}/pkg-plist > ${PLIST}
-.endif
-
do-install:
${MKDIR} ${FHOME}/lib/voices/english/
${MKDIR} ${FHOME}/lib/voices/spanish/
diff --git a/audio/festival/files/extra-patch-aa-ogi b/audio/festival/files/extra-patch-aa-ogi
deleted file mode 100644
index 5bd4cb84e40d..000000000000
--- a/audio/festival/files/extra-patch-aa-ogi
+++ /dev/null
@@ -1,20 +0,0 @@
-$NetBSD: patch-aa,v 1.2 1999/10/11 14:13:49 proff Exp $
-
---- festival/config/config Mon Oct 11 07:48:44 1999
-+++ festival/config/config Mon Oct 11 05:48:33 1999
-@@ -20,7 +20,7 @@
- ## You may need to set this explicitly if automounter or NFS
- ## side effects cause problems
-
--FESTIVAL_HOME := $(shell (cd $(TOP); pwd))
-+FESTIVAL_HOME := $(PKG_FESTIVAL_HOME)
-
- ###########################################################################
- ## Feature selection.
-@@ -70,3 +70,6 @@
- ## in config/configs/default.mak.
-
-
-+ALSO_INCLUDE += OGIcommon
-+ALSO_INCLUDE += OGIdbase
-+ALSO_INCLUDE += OGIresLPC
diff --git a/audio/festival/pkg-descr b/audio/festival/pkg-descr
index b5849f03e14a..f3ce17acd94b 100644
--- a/audio/festival/pkg-descr
+++ b/audio/festival/pkg-descr
@@ -13,6 +13,8 @@ For output via esd do:
NAS and direct output are documented in section 23 of the users'
manual.
+If you need the OGI extensions, install ports/audio/festival+OGI instead.
+
WWW: http://www.cstr.ed.ac.uk/projects/festival/
Trevor Johnson
diff --git a/audio/festival/pkg-plist-ogi b/audio/festival/pkg-plist-ogi
deleted file mode 100644
index 61d021b24d7d..000000000000
--- a/audio/festival/pkg-plist-ogi
+++ /dev/null
@@ -1,14 +0,0 @@
-share/festival/lib/ogi_effect.scm
-share/festival/lib/ogi_gswdurtreeZ_wb.scm
-share/festival/lib/ogi_hack.scm
-share/festival/lib/ogi_kddurtreeZ_wb.scm
-share/festival/lib/ogi_klatt_durs_wb.scm
-share/festival/lib/ogi_languages.scm
-share/festival/lib/ogi_lexicons.scm
-share/festival/lib/ogi_lts_worldbet.scm
-share/festival/lib/ogi_phrase.scm
-share/festival/lib/ogi_postlex.scm
-share/festival/lib/ogi_reslpc_analysis.scm
-share/festival/lib/ogi_synthesis.scm
-share/festival/lib/ogi_unitsel.scm
-share/festival/lib/ogi_worldbet_phones.scm