aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-10-06 18:42:36 +0800
committerbapt <bapt@FreeBSD.org>2012-10-06 18:42:36 +0800
commit2fa0350fdb2025afac437aea61f792e0330699a1 (patch)
tree5411b47724a0ad32522bb7aedfd26ba3b254806c /audio
parent44dbd1168637378f50763324e1d05986be3b69ba (diff)
downloadfreebsd-ports-gnome-2fa0350fdb2025afac437aea61f792e0330699a1.tar.gz
freebsd-ports-gnome-2fa0350fdb2025afac437aea61f792e0330699a1.tar.zst
freebsd-ports-gnome-2fa0350fdb2025afac437aea61f792e0330699a1.zip
Convert audio/jack and fluidsynth to only build depend on pkgconf, track
dependency impact
Diffstat (limited to 'audio')
-rw-r--r--audio/aubio/Makefile1
-rw-r--r--audio/cheesetracker/Makefile8
-rw-r--r--audio/dssi/Makefile1
-rw-r--r--audio/fluidsynth/Makefile9
-rw-r--r--audio/linuxsampler/Makefile7
-rw-r--r--audio/milkytracker/Makefile1
-rw-r--r--audio/sooperlooper/Makefile1
7 files changed, 11 insertions, 17 deletions
diff --git a/audio/aubio/Makefile b/audio/aubio/Makefile
index e5d6f3ede261..00cda36029d6 100644
--- a/audio/aubio/Makefile
+++ b/audio/aubio/Makefile
@@ -27,6 +27,7 @@ CONFIGURE_ARGS= --disable-complex
USE_GMAKE= yes
USE_GNOME= gnomehack
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/audio/cheesetracker/Makefile b/audio/cheesetracker/Makefile
index 48405ad88449..5531913f1ca9 100644
--- a/audio/cheesetracker/Makefile
+++ b/audio/cheesetracker/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: cheesetracker
-# Date created: Jan 31, 2002
-# Whom: ijliao
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cheesetracker
PORTVERSION= 0.9.15.4
@@ -24,6 +19,7 @@ LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
USE_BZIP2= yes
USE_QT_VER= 3
USE_SCONS= yes
+USE_PKGCONFIG= build
SCONS_BUILDENV= CXX="${CXX}" QTDIR="${QT_PREFIX}"
PORTEXAMPLES= beek-dolphinisland.it ll-globule.it reduz-maschizo.it \
diff --git a/audio/dssi/Makefile b/audio/dssi/Makefile
index 19b1c8ea98d4..0f276129d340 100644
--- a/audio/dssi/Makefile
+++ b/audio/dssi/Makefile
@@ -28,6 +28,7 @@ OPTIONS_DEFINE= QT4
USE_GNOME= gnomehack
USE_GMAKE= yes
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/audio/fluidsynth/Makefile b/audio/fluidsynth/Makefile
index a215547d442f..493d0b03a5bb 100644
--- a/audio/fluidsynth/Makefile
+++ b/audio/fluidsynth/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: fluidsynth
-# Date created: 27 Nov 2003
-# Whom: Juha Nygard <juha.nygard1@netikka.fi>
-#
+# Created by: Juha Nygard <juha.nygard1@netikka.fi>
# $FreeBSD$
-#
PORTNAME= fluidsynth
PORTVERSION= 1.1.5
@@ -20,7 +16,8 @@ OPTIONS_DEFINE= JACK ALSA DBUS LADSPA LASH PORTAUDIO PULSEAUDIO SNDFILE
OPTIONS_DEFAULT= JACK
USE_BZIP2= yes
-USE_GNOME= glib20 pkgconfig
+USE_GNOME= glib20
+USE_PKGCONFIG= build
USE_CMAKE= yes
CMAKE_ARGS= -Denable-ladcca:BOOL=FALSE \
-Denable-midishare:BOOL=FALSE
diff --git a/audio/linuxsampler/Makefile b/audio/linuxsampler/Makefile
index 2b3ce2e61f3c..4a8fc613c909 100644
--- a/audio/linuxsampler/Makefile
+++ b/audio/linuxsampler/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: linuxsampler
-# Date created: 2007-01-24
-# Whom: trasz <trasz@pin.if.uz.zgora.pl>
-#
+# Created by: trasz <trasz@pin.if.uz.zgora.pl>
# $FreeBSD$
-#
PORTNAME= linuxsampler
PORTVERSION= 1.0.0
@@ -33,6 +29,7 @@ USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= HAVE_UNIX98=1
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
MAKE_JOBS_SAFE= yes
MAN1= linuxsampler.1
diff --git a/audio/milkytracker/Makefile b/audio/milkytracker/Makefile
index ff231fe0e47d..679245c50593 100644
--- a/audio/milkytracker/Makefile
+++ b/audio/milkytracker/Makefile
@@ -23,6 +23,7 @@ LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack \
GNU_CONFIGURE= yes
USE_SDL= sdl
MAKE_JOBS_SAFE= yes
+USE_PKGCONFIG= build
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/audio/sooperlooper/Makefile b/audio/sooperlooper/Makefile
index 340cdce4a7aa..009a60dc9589 100644
--- a/audio/sooperlooper/Makefile
+++ b/audio/sooperlooper/Makefile
@@ -34,6 +34,7 @@ USE_WX= 2.6+
WX_UNICODE= yes
CONFIGURE_ARGS= -with-wxconfig-path=${WX_CONFIG}
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include