aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-11-08 06:38:01 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:53:57 +0800
commit2ff554cc1c9c24541161ef561d9ff735fe5102b3 (patch)
tree4fde8dde1a6b0e2e935c596536b924909eebdbd1 /audio
parentbe8e5d640550cc9dd5e82ba9bf0c2e5d3ba41265 (diff)
downloadfreebsd-ports-gnome-2ff554cc1c9c24541161ef561d9ff735fe5102b3.tar.gz
freebsd-ports-gnome-2ff554cc1c9c24541161ef561d9ff735fe5102b3.tar.zst
freebsd-ports-gnome-2ff554cc1c9c24541161ef561d9ff735fe5102b3.zip
New port: audio/eteroj-lv2: OSC injection/ejection from/to UDP/TCP/Serial for LV2
PR: 221351 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D12956
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/eteroj-lv2/Makefile29
-rw-r--r--audio/eteroj-lv2/distinfo3
-rw-r--r--audio/eteroj-lv2/pkg-descr24
4 files changed, 57 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 724a935de944..0f552943f012 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -130,6 +130,7 @@
SUBDIR += espeak
SUBDIR += esperanza
SUBDIR += etcd
+ SUBDIR += eteroj-lv2
SUBDIR += etktab
SUBDIR += exaile
SUBDIR += exaile-devel
diff --git a/audio/eteroj-lv2/Makefile b/audio/eteroj-lv2/Makefile
new file mode 100644
index 000000000000..50bc4686084f
--- /dev/null
+++ b/audio/eteroj-lv2/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= eteroj
+DISTVERSION= 0.2.0
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= OSC injection/ejection from/to UDP/TCP/Serial for LV2
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+LIB_DEPENDS= libsratom-0.so:audio/sratom \
+ libserd-0.so:devel/serd \
+ libsord-0.so:devel/sord \
+ libuv.so:devel/libuv
+
+USES= cmake:outsource pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= OpenMusicKontrollers
+GH_PROJECT= eteroj.lv2
+
+PLIST_FILES= lib/lv2/eteroj.lv2/eteroj.so \
+ lib/lv2/eteroj.lv2/eteroj.ttl \
+ lib/lv2/eteroj.lv2/manifest.ttl
+
+.include <bsd.port.mk>
diff --git a/audio/eteroj-lv2/distinfo b/audio/eteroj-lv2/distinfo
new file mode 100644
index 000000000000..5619550076b6
--- /dev/null
+++ b/audio/eteroj-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502242041
+SHA256 (OpenMusicKontrollers-eteroj.lv2-0.2.0_GH0.tar.gz) = 56bac231ca7842b7490ec7a6b93d832216e324a844ae8ae7e7d659fe7d0c284a
+SIZE (OpenMusicKontrollers-eteroj.lv2-0.2.0_GH0.tar.gz) = 93630
diff --git a/audio/eteroj-lv2/pkg-descr b/audio/eteroj-lv2/pkg-descr
new file mode 100644
index 000000000000..045dad397601
--- /dev/null
+++ b/audio/eteroj-lv2/pkg-descr
@@ -0,0 +1,24 @@
+LV2 plugin bundle from OpenMusicKontrollers:
+* (De)Cloak
+ Embed OSC in MIDI Sysex messages. Use this to smuggle arbitrary OSC packets
+ via MIDI to a given destination.
+* Control
+ This is an OSC learn plugin. It translates OSC messages directly to LV2
+ Control ports and features automatic range detection.
+* Disk
+ Record/Playback of OSC to/from disk. Record all incoming OSC message with
+ sample accuracy and play them back later from disk.
+* IO
+ A plugin able to inject/eject OSC packets into/from the plugin graph to/from
+ network and serial lines.
+* Ninja
+ Embed Turtle RDF in OSC as string. Use this to smuggle arbitrary LV2 atom
+ messages via OSC to a given destination.
+* (Un)Pack
+ Embed arbitrary 1-3 byte MIDI commands (but Sysex) in OSC messages. Use this
+ to send MIDI commands via OSC to a given destination.
+* Query
+ This plugin implements our OSC Introspect specification. It thus exports any
+ methods and parameters of a given OSC device transparently to LV2 properties.
+
+WWW: https://open-music-kontrollers.ch/lv2/eteroj/