aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-04-29 13:10:19 +0800
committermiwi <miwi@FreeBSD.org>2014-04-29 13:10:19 +0800
commit4ecaf7d48225489b280f21c2b1f41f7ef56dcf5e (patch)
treee28e5b0f83873dcd59d253bbf8c6962180c98022 /audio
parentb881e401f2f9e30bd6289e92df435063b57f9050 (diff)
downloadfreebsd-ports-gnome-4ecaf7d48225489b280f21c2b1f41f7ef56dcf5e.tar.gz
freebsd-ports-gnome-4ecaf7d48225489b280f21c2b1f41f7ef56dcf5e.tar.zst
freebsd-ports-gnome-4ecaf7d48225489b280f21c2b1f41f7ef56dcf5e.zip
- Support CC/CFLAGS properly
PR: 187769 Submitted by: Ports Fury
Diffstat (limited to 'audio')
-rw-r--r--audio/amp/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/audio/amp/Makefile b/audio/amp/Makefile
index bab3128377ad..4333ccace5af 100644
--- a/audio/amp/Makefile
+++ b/audio/amp/Makefile
@@ -10,18 +10,20 @@ MASTER_SITES= http://www-users.cs.umn.edu/~wburdick/ftp/
MAINTAINER= ports@FreeBSD.org
COMMENT= Another mp3 player
-GNU_CONFIGURE= yes
USES= gmake
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= ac_cv_prog_gcc=no
-PLIST_FILES= bin/amp \
- man/man1/amp.1.gz
+PLIST_FILES= bin/amp man/man1/amp.1.gz
-post-configure:
- @${REINPLACE_CMD} -e 's|-O6 -ffast-math -fomit-frame-pointer|${CFLAGS}|' \
- -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/CC="gcc"/s|^|#| ; \
+ /CFLAGS=$$/s|^|#| ; \
+ s|-O6|$$CFLAGS|' ${WRKSRC}/configure
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/amp ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/amp.1 ${STAGEDIR}${PREFIX}/man/man1
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} amp ${STAGEDIR}${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_MAN} amp.1 ${STAGEDIR}${PREFIX}/man/man1)
.include <bsd.port.mk>