aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>1999-04-15 03:55:55 +0800
committermharo <mharo@FreeBSD.org>1999-04-15 03:55:55 +0800
commit5991595adb03b3c9f1583f121b448337d2cb678f (patch)
treec0fb9662c4e9059d41fa21ede877dce7a6e5779e /audio
parent631ebba3f56dc32cca98e5717c3f2b52ef3f6569 (diff)
downloadfreebsd-ports-gnome-5991595adb03b3c9f1583f121b448337d2cb678f.tar.gz
freebsd-ports-gnome-5991595adb03b3c9f1583f121b448337d2cb678f.tar.zst
freebsd-ports-gnome-5991595adb03b3c9f1583f121b448337d2cb678f.zip
support NOPORTDOCS with a different PLIST, don't display message
telling you to read the readme if you didn't install the docs, and expand ${PREFIX} in the MESSAGE file.
Diffstat (limited to 'audio')
-rw-r--r--audio/cmp3/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/audio/cmp3/Makefile b/audio/cmp3/Makefile
index bff7e166b3d7..fc692f14b56d 100644
--- a/audio/cmp3/Makefile
+++ b/audio/cmp3/Makefile
@@ -3,7 +3,7 @@
# Date created: 10 April 1999
# Whom: Chris Piazza <cpiazza@home.net>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/04/13 23:26:27 mharo Exp $
#
DISTNAME= cmp3-2.0pre3
@@ -17,7 +17,11 @@ RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/cmp3
+WRKSRC= ${WRKDIR}/cmp3
+PKGMESSAGE= ${WRKSRC}/MESSAGE
+.if defined(NOPORTDOCS)
+PLIST= ${PKGDIR}/PLIST.nodocs
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cmp3 ${PREFIX}/bin
@@ -28,6 +32,9 @@ do-install:
.endif
post-install:
- @${CAT} ${PKGDIR}/MESSAGE
+.if !defined(NOPORTDOCS)
+ @${SED} 's,PREFIX,${PREFIX},' ${PKGDIR}/MESSAGE > ${WRKSRC}/MESSAGE
+ @${CAT} ${WRKSRC}/MESSAGE
+.endif
.include <bsd.port.mk>