aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-09 06:39:08 +0800
committerwg <wg@FreeBSD.org>2013-10-09 06:39:08 +0800
commit6438e1f5e14883f9beb9c0ad2371b2c0fb25c68c (patch)
tree31bb3b09ea7b8bf2d7dccb8cf6ddd1dcfd92ef6f /audio
parent8739df433f1d5e46e95a64ae08fe2eef3571058a (diff)
downloadfreebsd-ports-gnome-6438e1f5e14883f9beb9c0ad2371b2c0fb25c68c.tar.gz
freebsd-ports-gnome-6438e1f5e14883f9beb9c0ad2371b2c0fb25c68c.tar.zst
freebsd-ports-gnome-6438e1f5e14883f9beb9c0ad2371b2c0fb25c68c.zip
audio/cuberok: link using ffmpeg0
- Link using ffmpeg0 Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'audio')
-rw-r--r--audio/cuberok/Makefile16
-rw-r--r--audio/cuberok/files/patch-src-player_ffmpeg.h17
2 files changed, 22 insertions, 11 deletions
diff --git a/audio/cuberok/Makefile b/audio/cuberok/Makefile
index 9f70d590c021..fc6481f9559a 100644
--- a/audio/cuberok/Makefile
+++ b/audio/cuberok/Makefile
@@ -12,10 +12,10 @@ COMMENT= A music player and a collection manager based on Qt4
BUILD_DEPENDS= audiere-config:${PORTSDIR}/audio/audiere \
${LOCALBASE}/lib/libdumb.a:${PORTSDIR}/audio/dumb
-LIB_DEPENDS= avcodec:${PORTSDIR}/multimedia/ffmpeg \
- avformat:${PORTSDIR}/multimedia/ffmpeg \
- avutil:${PORTSDIR}/multimedia/ffmpeg \
- tag:${PORTSDIR}/audio/taglib
+LIB_DEPENDS= libavcodec0.so:${PORTSDIR}/multimedia/ffmpeg0 \
+ libavformat0.so:${PORTSDIR}/multimedia/ffmpeg0 \
+ libavutil0.so:${PORTSDIR}/multimedia/ffmpeg0 \
+ libtag.so:${PORTSDIR}/audio/taglib
USE_LDCONFIG= yes
USE_QT4= gui xml qmake_build uic_build moc_build rcc_build \
@@ -27,6 +27,14 @@ QMAKEFLAGS+= "CONFIG+=player_phonon"
MAKE_ENV+= INSTALL_ROOT=${PREFIX}
QMAKEPRO= Cuberok.pro
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's,libavcodec,libavcodec0,g' \
+ -e 's,libavutil,libavutil0,g' \
+ -e 's,libavformat,libavformat0,g' \
+ ${WRKSRC}/Cuberok.pro \
+ ${WRKSRC}/plugins/player_ffmpeg/player_ffmpeg.pro
+
do-configure:
cd ${WRKSRC} && ${REINPLACE_CMD} -e 's/lib64/lib/g' \
plugins/plugins_path-x86*
diff --git a/audio/cuberok/files/patch-src-player_ffmpeg.h b/audio/cuberok/files/patch-src-player_ffmpeg.h
index 6443831faeac..01dab60e7993 100644
--- a/audio/cuberok/files/patch-src-player_ffmpeg.h
+++ b/audio/cuberok/files/patch-src-player_ffmpeg.h
@@ -1,13 +1,16 @@
---- src/player_ffmpeg.h.orig 2009-07-10 14:14:03.000000000 +0800
-+++ src/player_ffmpeg.h 2010-05-10 21:49:51.000000000 +0800
-@@ -27,8 +27,8 @@
+--- src/player_ffmpeg.h.orig 2009-07-10 03:14:03.000000000 -0300
++++ src/player_ffmpeg.h 2013-10-08 19:36:06.326157022 -0300
+@@ -23,13 +23,8 @@
+ #include <QtCore>
+ #include "player.h"
+ extern "C" {
+-#ifdef WIN32
#include <libavcodec/avcodec.h>
#include <libavformat/avformat.h>
- #else
+-#else
-#include <avcodec.h>
-#include <avformat.h>
-+#include <ffmpeg/avcodec.h>
-+#include <ffmpeg/avformat.h>
- #endif
+-#endif
}
+ class PlayThread : public QThread