aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-29 01:04:13 +0800
committerbapt <bapt@FreeBSD.org>2014-04-29 01:04:13 +0800
commit66fe6a4a8ffd463cee05b8b2460c7aa887dc7260 (patch)
tree77fc0b1142f92d7b38fb5e483ed83bc04c052ce1 /audio
parent2c73ec1e0a7050e35781eaea8d1ccfae719eeddd (diff)
downloadfreebsd-ports-gnome-66fe6a4a8ffd463cee05b8b2460c7aa887dc7260.tar.gz
freebsd-ports-gnome-66fe6a4a8ffd463cee05b8b2460c7aa887dc7260.tar.zst
freebsd-ports-gnome-66fe6a4a8ffd463cee05b8b2460c7aa887dc7260.zip
Support stage
Use options helpers Add missing dependency on desktop-file-utils
Diffstat (limited to 'audio')
-rw-r--r--audio/decibel-audio-player/Makefile59
-rw-r--r--audio/decibel-audio-player/pkg-plist2
2 files changed, 18 insertions, 43 deletions
diff --git a/audio/decibel-audio-player/Makefile b/audio/decibel-audio-player/Makefile
index 5a9e30b9798e..4e0a8b8fd173 100644
--- a/audio/decibel-audio-player/Makefile
+++ b/audio/decibel-audio-player/Makefile
@@ -3,11 +3,12 @@
PORTNAME= decibel-audio-player
PORTVERSION= 1.08
+PORTREVISION= 1
CATEGORIES= audio multimedia gnome python
MASTER_SITES= http://decibel.silent-blade.org/uploads/Main/
MAINTAINER= somicide@gmail.com
-COMMENT= A fast GTK+ audio player with an clean and user friendly interface
+COMMENT= Fast GTK+ audio player with an clean and user friendly interface
RUN_DEPENDS= py*-dbus>=0.80:${PORTSDIR}/devel/py-dbus \
py*-mutagen>=1.11:${PORTSDIR}/audio/py-mutagen
@@ -17,10 +18,8 @@ LICENSE= GPLv2
USE_PYTHON= yes
USE_GNOME= pygnome2 pygtk2
USE_GSTREAMER= python good bad
-USES= gmake gettext
-NO_STAGE= yes
+USES= gmake gettext desktop-file-utils
NO_BUILD= yes
-MAN1= decibel-audio-player.1 decibel-audio-player-remote.1
#Audio gstreamer plugins
OPTIONS_DEFINE= AUDIOCD FLAC MP3 MPEG4IP OGG VORBIS SPEEX WAVPACK EXTRAS
@@ -31,51 +30,25 @@ MPEG4IP_DESC= AAC/MP4P support
##A few extra requirements if we want to use some nifty plugins in decibel
EXTRAS_DESC= Extra dependencies for plugins
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MAUDIOCD}
-RUN_DEPENDS+= cd-discid>=0.9:${PORTSDIR}/audio/cd-discid \
+AUDIOCD_RUN_DEPENDS= cd-discid>=0.9:${PORTSDIR}/audio/cd-discid \
py*-cddb>=1.4:${PORTSDIR}/audio/py-cddb \
gstreamer-plugins-cdio>=0.10.16:${PORTSDIR}/sysutils/gstreamer-plugins-cdio
-.endif
-
-.if ${PORT_OPTIONS:MEXTRAS}
-RUN_DEPENDS+= py*-imaging>=1.1.6:${PORTSDIR}/graphics/py-imaging \
+EXTRAS_RUN_DEPENDS= py*-imaging>=1.1.6:${PORTSDIR}/graphics/py-imaging \
py*-notify>=0.1.1:${PORTSDIR}/devel/py-notify
-.endif
-
-.if ${PORT_OPTIONS:MFLAC}
-USE_GSTREAMER+= flac
-.endif
-
-.if ${PORT_OPTIONS:MMP3}
-USE_GSTREAMER+= mp3
-.endif
-
-.if ${PORT_OPTIONS:MMPEG4IP}
-LIB_DEPENDS+= libmp4v2.so:${PORTSDIR}/multimedia/mp4v2
-USE_GSTREAMER+= faad
-.endif
-
-.if ${PORT_OPTIONS:MOGG}
-USE_GSTREAMER+= ogg
-.endif
-
-.if ${PORT_OPTIONS:MSPEEX}
-USE_GSTREAMER+= speex
-.endif
-
-.if ${PORT_OPTIONS:MVORBIS}
-USE_GSTREAMER+= vorbis
-.endif
-
-.if ${PORT_OPTIONS:MWAVPACK}
-LIB_DEPENDS+= libwavpack.so:${PORTSDIR}/audio/wavpack
-USE_GSTREAMER+= wavpack
-.endif
+FLAC_USE= GSTREAMER=flac
+MP3_USE= GSTREAMER=mp3
+MPEG4IP_LIB_DEPENDS= libmp4v2.so:${PORTSDIR}/multimedia/mp4v2
+MPEG4IP_USE= GSTREAMER=faad
+OGG_USE= GSTREAMER=ogg
+SPEEX_USE= GSTREAMER=speex
+VORBIS_USE= GSTREAMER=vorbis
+WAVPACK_LIB_DEPENDS= libwavpack.so:${PORTSDIR}/audio/wavpack
+WAVPACK_USE= GSTREAMER=wavpack
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|prefix|${PREFIX}|g' \
+ ${WRKSRC}/start.sh ${WRKSRC}/start-remote.sh
.include <bsd.port.mk>
diff --git a/audio/decibel-audio-player/pkg-plist b/audio/decibel-audio-player/pkg-plist
index b42648c3694e..dba95de30be4 100644
--- a/audio/decibel-audio-player/pkg-plist
+++ b/audio/decibel-audio-player/pkg-plist
@@ -1,5 +1,7 @@
bin/decibel-audio-player
bin/decibel-audio-player-remote
+man/man1/decibel-audio-player-remote.1.gz
+man/man1/decibel-audio-player.1.gz
share/applications/decibel-audio-player.desktop
%%DATADIR%%/pix/audioscrobbler.png
%%DATADIR%%/pix/category-decibel.png