aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-03-08 15:42:51 +0800
committerriggs <riggs@FreeBSD.org>2014-03-08 15:42:51 +0800
commit68773766610dc1aead983fb052b3a252eec8e8ff (patch)
tree61e050eb04d4ef8420c40d828c11b0259370bd5a /audio
parentaafbe9a8cbbd0460495ad4acec9f90872fa27ef2 (diff)
downloadfreebsd-ports-gnome-68773766610dc1aead983fb052b3a252eec8e8ff.tar.gz
freebsd-ports-gnome-68773766610dc1aead983fb052b3a252eec8e8ff.tar.zst
freebsd-ports-gnome-68773766610dc1aead983fb052b3a252eec8e8ff.zip
- Update to upstream version 3.1.16
- Add LICENSE - Add OPTION for esound - General cleanups & petting portlint (USES, autotools handling) - Update WWW in pkg-descr PR: ports/184753 Submitted by: RK <hsn@sendmail.cz> Reviewed by: submitter (RK <hsn@sendmail.cz>) Approved by: thierry (mentor), maintainer timeout
Diffstat (limited to 'audio')
-rw-r--r--audio/libmikmod/Makefile23
-rw-r--r--audio/libmikmod/distinfo4
-rw-r--r--audio/libmikmod/files/patch-64bit-fix24
-rw-r--r--audio/libmikmod/files/patch-CVE-2009-017933
-rw-r--r--audio/libmikmod/files/patch-Makefile.in11
-rw-r--r--audio/libmikmod/files/patch-exitcrash12
-rw-r--r--audio/libmikmod/files/patch-libmikmod__Makefile.in11
-rw-r--r--audio/libmikmod/files/patch-md_sngchn110
-rw-r--r--audio/libmikmod/files/patch-ngvolume12
-rw-r--r--audio/libmikmod/pkg-descr2
-rw-r--r--audio/libmikmod/pkg-plist4
11 files changed, 33 insertions, 213 deletions
diff --git a/audio/libmikmod/Makefile b/audio/libmikmod/Makefile
index d3f2a8b9ef3e..ea33004bb52d 100644
--- a/audio/libmikmod/Makefile
+++ b/audio/libmikmod/Makefile
@@ -2,23 +2,34 @@
# $FreeBSD$
PORTNAME= libmikmod
-PORTVERSION= 3.1.12
-PORTREVISION= 2
+PORTVERSION= 3.1.16
CATEGORIES= audio
-MASTER_SITES= SF/mikmod/libmikmod%20%28source%29/${PORTVERSION}/
+MASTER_SITES= SF/mikmod/${PORTNAME}/${PORTVERSION}/
MAINTAINER= neuroworker@gmail.com
COMMENT= MikMod Sound Library
+LICENSE= LGPL21
+
+USE_AUTOTOOLS= libtool
WANT_GNOME= yes
-USES= gmake libtool
+USE_GNOME= lthack
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
-CONFIGURE_ARGS= --disable-esd
USE_LDCONFIG= yes
INFO= mikmod
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mesound}!=""
+USE_GNOME+= esound
+CONFIGURE_ARGS+= --enable-esd
+.else
+CONFIGURE_ARGS+= --disable-esd
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/docs/mikmod.info-*
@@ -31,4 +42,4 @@ post-patch:
-e 's|-lc_r|${PTHREAD_LIBS:S/"//g}|g' \
${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/libmikmod/distinfo b/audio/libmikmod/distinfo
index bf3b72d07001..3343e93b181a 100644
--- a/audio/libmikmod/distinfo
+++ b/audio/libmikmod/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libmikmod-3.1.12.tar.gz) = 891a2b780306e6ef86e381f459e71a085d4e7f56c970a879d3bf341c01bdfc32
-SIZE (libmikmod-3.1.12.tar.gz) = 618011
+SHA256 (libmikmod-3.1.16.tar.gz) = b9e6c5064e1ba13ee7ad4f873421e794758c6cb9884a571c928e5637a0b02dd3
+SIZE (libmikmod-3.1.16.tar.gz) = 1011780
diff --git a/audio/libmikmod/files/patch-64bit-fix b/audio/libmikmod/files/patch-64bit-fix
deleted file mode 100644
index 0cf716a8d983..000000000000
--- a/audio/libmikmod/files/patch-64bit-fix
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -ru include/mikmod.h.in libmikmod-3.1.12/include/mikmod.h.in
---- include/mikmod.h.in 2007-12-15 01:24:19.000000000 -0800
-+++ include/mikmod.h.in 2009-10-05 00:18:56.000000000 -0700
-@@ -85,7 +85,7 @@
-
- @DOES_NOT_HAVE_SIGNED@
-
--#if defined(__arch64__) || defined(__alpha) || defined(__x86_64)
-+#if defined(__arch64__) || defined(__alpha) || defined(__x86_64) || defined(_LP64)
- /* 64 bit architectures */
-
- typedef signed char SBYTE; /* 1 byte, signed */
-diff -ru include/mikmod_internals.h libmikmod-3.1.12/include/mikmod_internals.h
---- include/mikmod_internals.h 2007-12-15 04:24:51.000000000 -0800
-+++ include/mikmod_internals.h 2009-10-05 00:19:15.000000000 -0700
-@@ -50,7 +50,7 @@
- /*========== More type definitions */
-
- /* SLONGLONG: 64bit, signed */
--#if defined (__arch64__) || defined(__alpha)
-+#if defined(__arch64__) || defined(__alpha) || defined(__x86_64) || defined(_LP64)
- typedef long SLONGLONG;
- #define NATIVE_64BIT_INT
- #elif defined(__WATCOMC__)
diff --git a/audio/libmikmod/files/patch-CVE-2009-0179 b/audio/libmikmod/files/patch-CVE-2009-0179
deleted file mode 100644
index 7833e3b9601a..000000000000
--- a/audio/libmikmod/files/patch-CVE-2009-0179
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -ur loaders/load_xm.c libmikmod-3.1.11/loaders/load_xm.c
---- loaders/load_xm.c 2004-01-21 18:43:53.000000000 +0100
-+++ loaders/load_xm.c 2008-04-16 04:30:45.000000000 +0200
-@@ -622,7 +622,8 @@
- /* read the remainder of the header */
- for(u=headend-_mm_ftell(modreader);u;u--) _mm_read_UBYTE(modreader);
-
-- if(_mm_eof(modreader)) {
-+ /* last instrument is at the end of file in version 0x0104 */
-+ if(_mm_eof(modreader) && (mh->version<0x0104 || t<of.numins-1)) {
- free(nextwav);free(wh);
- nextwav=NULL;wh=NULL;
- _mm_errno = MMERR_LOADING_SAMPLEINFO;
-diff -ur playercode/mloader.c libmikmod-3.1.11/playercode/mloader.c
---- playercode/mloader.c 2004-01-21 18:43:53.000000000 +0100
-+++ playercode/mloader.c 2008-04-16 04:30:45.000000000 +0200
-@@ -450,10 +450,12 @@
- if (!l->Init || l->Init()) {
- _mm_rewind(modreader);
- ok = l->Load(curious);
-- /* propagate inflags=flags for in-module samples */
-- for (t = 0; t < of.numsmp; t++)
-- if (of.samples[t].inflags == 0)
-- of.samples[t].inflags = of.samples[t].flags;
-+ if (ok) {
-+ /* propagate inflags=flags for in-module samples */
-+ for (t = 0; t < of.numsmp; t++)
-+ if (of.samples[t].inflags == 0)
-+ of.samples[t].inflags = of.samples[t].flags;
-+ }
- } else
- ok = 0;
-
diff --git a/audio/libmikmod/files/patch-Makefile.in b/audio/libmikmod/files/patch-Makefile.in
new file mode 100644
index 000000000000..2c19c7102f1f
--- /dev/null
+++ b/audio/libmikmod/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2013-12-30 19:37:12.000000000 +0100
++++ Makefile.in 2014-03-01 19:49:25.164244987 +0100
+@@ -348,7 +348,7 @@
+
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = libmikmod.m4
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = libmikmod.pc
+ ACLOCAL_AMFLAGS = -I m4
+
diff --git a/audio/libmikmod/files/patch-exitcrash b/audio/libmikmod/files/patch-exitcrash
deleted file mode 100644
index f9a43a27ddb1..000000000000
--- a/audio/libmikmod/files/patch-exitcrash
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru playercode/virtch_common.c libmikmod-3.1.12/playercode/virtch_common.c
---- playercode/virtch_common.c 2007-12-15 01:26:53.000000000 -0800
-+++ playercode/virtch_common.c 2009-10-05 00:37:12.000000000 -0700
-@@ -347,7 +347,7 @@
-
- void VC1_SampleUnload(SWORD handle)
- {
-- if (handle<MAXSAMPLEHANDLES) {
-+ if (Samples && handle<MAXSAMPLEHANDLES) {
- if (Samples[handle])
- free(Samples[handle]);
- Samples[handle]=NULL;
diff --git a/audio/libmikmod/files/patch-libmikmod__Makefile.in b/audio/libmikmod/files/patch-libmikmod__Makefile.in
deleted file mode 100644
index 07ba10c60f59..000000000000
--- a/audio/libmikmod/files/patch-libmikmod__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./libmikmod/Makefile.in.orig 2014-01-19 10:54:34.000000000 -0200
-+++ ./libmikmod/Makefile.in 2014-01-19 10:54:45.000000000 -0200
-@@ -72,7 +72,7 @@
- rm -f Makefile
-
- $(LIB): $(OBJ)
-- $(LIBTOOL) --mode=link $(CC) -version-info 2:4:0 -o $@ $(OBJ) $(LIBRARY_LIB) -rpath $(DESTDIR)$(libdir)
-+ $(LIBTOOL) --mode=link $(CC) -version-info 2:4:0 -o $@ $(OBJ) $(LIBRARY_LIB) -rpath $(libdir)
-
- dl_hpux.lo: $(top_srcdir)/dlapi/dl_hpux.c \
- $(top_srcdir)/dlapi/dlfcn.h
diff --git a/audio/libmikmod/files/patch-md_sngchn b/audio/libmikmod/files/patch-md_sngchn
deleted file mode 100644
index 12e0f2893a45..000000000000
--- a/audio/libmikmod/files/patch-md_sngchn
+++ /dev/null
@@ -1,110 +0,0 @@
-diff -ru playercode/mplayer.c libmikmod-3.1.12/playercode/mplayer.c
---- playercode/mplayer.c 2007-12-15 01:26:28.000000000 -0800
-+++ playercode/mplayer.c 2009-10-04 23:48:36.000000000 -0700
-@@ -52,6 +52,8 @@
- will wait */
- /*static*/ MODULE *pf = NULL;
-
-+#define NUMVOICES(mod) (md_sngchn < (mod)->numvoices ? md_sngchn : (mod)->numvoices)
-+
- #define HIGH_OCTAVE 2 /* number of above-range octaves */
-
- static UWORD oldperiods[OCTAVE*2]={
-@@ -248,14 +250,14 @@
- MP_VOICE *a;
- ULONG t,k,tvol,pp;
-
-- for (t=0;t<md_sngchn;t++)
-+ for (t=0;t<NUMVOICES(mod);t++)
- if (((mod->voice[t].main.kick==KICK_ABSENT)||
- (mod->voice[t].main.kick==KICK_ENV))&&
- Voice_Stopped_internal(t))
- return t;
-
- tvol=0xffffffUL;t=-1;a=mod->voice;
-- for (k=0;k<md_sngchn;k++,a++) {
-+ for (k=0;k<NUMVOICES(mod);k++,a++) {
- /* allow us to take over a nonexisting sample */
- if (!a->main.s)
- return k;
-@@ -2249,12 +2251,12 @@
-
- switch (dat) {
- case 0x0: /* past note cut */
-- for (t=0;t<md_sngchn;t++)
-+ for (t=0;t<NUMVOICES(mod);t++)
- if (mod->voice[t].master==a)
- mod->voice[t].main.fadevol=0;
- break;
- case 0x1: /* past note off */
-- for (t=0;t<md_sngchn;t++)
-+ for (t=0;t<NUMVOICES(mod);t++)
- if (mod->voice[t].master==a) {
- mod->voice[t].main.keyoff|=KEY_OFF;
- if ((!(mod->voice[t].venv.flg & EF_ON))||
-@@ -2263,7 +2265,7 @@
- }
- break;
- case 0x2: /* past note fade */
-- for (t=0;t<md_sngchn;t++)
-+ for (t=0;t<NUMVOICES(mod);t++)
- if (mod->voice[t].master==a)
- mod->voice[t].main.keyoff|=KEY_FADE;
- break;
-@@ -2318,7 +2320,7 @@
- SAMPLE *s;
-
- mod->totalchn=mod->realchn=0;
-- for (channel=0;channel<md_sngchn;channel++) {
-+ for (channel=0;channel<NUMVOICES(mod);channel++) {
- aout=&mod->voice[channel];
- i=aout->main.i;
- s=aout->main.s;
-@@ -2736,7 +2738,7 @@
- if (a->dct!=DCT_OFF) {
- int t;
-
-- for (t=0;t<md_sngchn;t++)
-+ for (t=0;t<NUMVOICES(mod);t++)
- if ((!Voice_Stopped_internal(t))&&
- (mod->voice[t].masterchn==channel)&&
- (a->main.sample==mod->voice[t].main.sample)) {
-@@ -2978,6 +2980,11 @@
- if (!(mod->voice=(MP_VOICE*)_mm_calloc(md_sngchn,sizeof(MP_VOICE))))
- return 1;
-
-+ /* mod->numvoices was used during loading to clamp md_sngchn.
-+ After loading it's used to remember how big mod->voice is.
-+ */
-+ mod->numvoices = md_sngchn;
-+
- Player_Init_internal(mod);
- return 0;
- }
-@@ -3086,7 +3093,7 @@
- pf->patbrk=0;
- pf->vbtick=pf->sngspd;
-
-- for (t=0;t<md_sngchn;t++) {
-+ for (t=0;t<NUMVOICES(pf);t++) {
- Voice_Stop_internal(t);
- pf->voice[t].main.i=NULL;
- pf->voice[t].main.s=NULL;
-@@ -3111,7 +3118,7 @@
- pf->patbrk=0;
- pf->vbtick=pf->sngspd;
-
-- for (t=0;t<md_sngchn;t++) {
-+ for (t=0;t<NUMVOICES(pf);t++) {
- Voice_Stop_internal(t);
- pf->voice[t].main.i=NULL;
- pf->voice[t].main.s=NULL;
-@@ -3138,7 +3145,7 @@
- pf->sngpos=pos;
- pf->vbtick=pf->sngspd;
-
-- for (t=0;t<md_sngchn;t++) {
-+ for (t=0;t<NUMVOICES(pf);t++) {
- Voice_Stop_internal(t);
- pf->voice[t].main.i=NULL;
- pf->voice[t].main.s=NULL;
diff --git a/audio/libmikmod/files/patch-ngvolume b/audio/libmikmod/files/patch-ngvolume
deleted file mode 100644
index 2931abfe56ef..000000000000
--- a/audio/libmikmod/files/patch-ngvolume
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru playercode/mplayer.c libmikmod-3.1.12/playercode/mplayer.c
---- playercode/mplayer.c 2009-10-05 00:19:59.000000000 -0700
-+++ playercode/mplayer.c 2009-10-05 00:44:35.000000000 -0700
-@@ -3019,7 +3019,7 @@
- {
- MUTEX_LOCK(vars);
- if (pf)
-- pf->volume=(volume<0)?0:(volume>128)?128:volume;
-+ pf->volume=pf->initvolume=(volume<0)?0:(volume>128)?128:volume;
- MUTEX_UNLOCK(vars);
- }
-
diff --git a/audio/libmikmod/pkg-descr b/audio/libmikmod/pkg-descr
index 23a6f5ac3ac0..602786c6a76f 100644
--- a/audio/libmikmod/pkg-descr
+++ b/audio/libmikmod/pkg-descr
@@ -3,4 +3,4 @@ libmikmod is a portable sound library for Unix.
It is able to play the IT, XM, S3M, MTM, 669, STM, ULT, FAR, MED, AMF, DSM,
IMF, GDM, STX, OKT and of course MOD module formats.
-WWW: http://mikmod.raphnet.net
+WWW: http://mikmod.sourceforge.net/
diff --git a/audio/libmikmod/pkg-plist b/audio/libmikmod/pkg-plist
index 3bbd816b3762..bd0223d57f2c 100644
--- a/audio/libmikmod/pkg-plist
+++ b/audio/libmikmod/pkg-plist
@@ -4,6 +4,6 @@ lib/libmikmod.a
lib/libmikmod.la
lib/libmikmod.so
lib/libmikmod.so.2
-lib/libmikmod.so.2.0.4
-man/man1/libmikmod-config.1.gz
+libdata/pkgconfig/libmikmod.pc
share/aclocal/libmikmod.m4
+man/man1/libmikmod-config.1.gz