aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2013-09-29 00:03:59 +0800
committernaddy <naddy@FreeBSD.org>2013-09-29 00:03:59 +0800
commit73d761244edbe580b01eb78d7e47c1fe5371ce4e (patch)
tree7ab9474f42ed7fe342b9e44b94c6514f97ab685b /audio
parentcc8225c6f63529fef7cd57731433d81dd5c255bc (diff)
downloadfreebsd-ports-gnome-73d761244edbe580b01eb78d7e47c1fe5371ce4e.tar.gz
freebsd-ports-gnome-73d761244edbe580b01eb78d7e47c1fe5371ce4e.tar.zst
freebsd-ports-gnome-73d761244edbe580b01eb78d7e47c1fe5371ce4e.zip
Support staging.
Turn obscure WITH_ variable into OPTION for Last.fm Audioscrobbler support.
Diffstat (limited to 'audio')
-rw-r--r--audio/mpg321/Makefile37
1 files changed, 18 insertions, 19 deletions
diff --git a/audio/mpg321/Makefile b/audio/mpg321/Makefile
index aedf09f0d46e..329dc941c02c 100644
--- a/audio/mpg321/Makefile
+++ b/audio/mpg321/Makefile
@@ -8,34 +8,33 @@ CATEGORIES= audio
MASTER_SITES= SF
MAINTAINER= naddy@FreeBSD.org
-COMMENT= A free command-line mp3 player, compatible with mpg123
+COMMENT= Command-line MP3 player, compatible with mpg123
-LIB_DEPENDS= ao.4:${PORTSDIR}/audio/libao \
- id3tag.0:${PORTSDIR}/audio/libid3tag \
- mad.2:${PORTSDIR}/audio/libmad
-
-NO_STAGE= yes
-.if defined(WITH_MPG321_SCROBBLER_PATCH)
-RUN_DEPENDS= scrobbler-helper:${PORTSDIR}/audio/p5-Audio-Scrobbler
-
-PATCHFILES+= mpg321-0.2.10-scrobbler-01.patch:scrobbler
-PATCH_SITES+= http://people.FreeBSD.org/~roam/ports/audio/:scrobbler \
- http://devel.ringlet.net/audio/mpg321-scrobbler/:scrobbler
-
-
-MPG321_SCROBBLER_PLUGIN_NAME?= 321
-.endif
+LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao \
+ libid3tag.so:${PORTSDIR}/audio/libid3tag \
+ libmad.so:${PORTSDIR}/audio/libmad
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-mpg123-symlink
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= mpg321.1
+PLIST_FILES= bin/mpg321 man/man1/mpg321.1.gz
-PLIST_FILES= bin/mpg321
+OPTIONS_DEFINE= SCROBBLER
+SCROBBLER_DESC= Last.fm Audioscrobbler support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSCROBBLER}
+RUN_DEPENDS+= scrobbler-helper:${PORTSDIR}/audio/p5-Audio-Scrobbler
+
+PATCHFILES+= mpg321-0.2.10-scrobbler-01.patch:scrobbler
+PATCH_SITES+= http://people.FreeBSD.org/~roam/ports/audio/:scrobbler \
+ http://devel.ringlet.net/audio/mpg321-scrobbler/:scrobbler
+
+MPG321_SCROBBLER_PLUGIN_NAME?= 321
-.if defined(WITH_MPG321_SCROBBLER_PATCH)
post-patch:
${REINPLACE_CMD} "s/\"mpg321\"/\"${MPG321_SCROBBLER_PLUGIN_NAME}\"/" ${WRKSRC}/scrobbler.c
.endif