aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-08-18 04:00:47 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:22:51 +0800
commit76b77326b202cd203f1bf7bbe9465044da66ebd0 (patch)
treeef61052cf79470cb0a7fb5c7b09be353559866ce /audio
parentd33f1cb64dcf16b6f2f0820ce7e2815c2a5ff30a (diff)
downloadfreebsd-ports-gnome-76b77326b202cd203f1bf7bbe9465044da66ebd0.tar.gz
freebsd-ports-gnome-76b77326b202cd203f1bf7bbe9465044da66ebd0.tar.zst
freebsd-ports-gnome-76b77326b202cd203f1bf7bbe9465044da66ebd0.zip
QMidiArp is an advanced MIDI arpeggiator, programmable step sequencer and LFO.
It can hold any number of arpeggiator, sequencer, or LFO modules running in parallel. Arpeggiator modules produce sequences depending on the notes sent to their input port, which is typically connected to a keyboard or another sequencer. Step sequencer modules allow you to create simple linear, monophonic and globally transposable sequences similar to the first analog sequencers. MIDI LFO modules independently produce MIDI controller data of adjustable waveform, time resolution, amplitude and duration. A Global Storage Tool can store different setups and switch between them at a given time. It allows you to dynamically combine patterns and LFO wave forms. WWW: http://qmidiarp.sourceforge.net/ PR: 221327 Submitted by: Yuri Victorovich (maintainer) Reviewed by: matthew (mentor), mat Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D12033
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/qmidiarp/Makefile42
-rw-r--r--audio/qmidiarp/distinfo3
-rw-r--r--audio/qmidiarp/pkg-descr17
-rw-r--r--audio/qmidiarp/pkg-plist31
5 files changed, 94 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f4282b19056a..a92f5b30c7cc 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -672,6 +672,7 @@
SUBDIR += py3-pylast
SUBDIR += pytone
SUBDIR += qjackctl
+ SUBDIR += qmidiarp
SUBDIR += qmpdclient
SUBDIR += qsampler
SUBDIR += qsynth
diff --git a/audio/qmidiarp/Makefile b/audio/qmidiarp/Makefile
new file mode 100644
index 000000000000..c0f80cd4faef
--- /dev/null
+++ b/audio/qmidiarp/Makefile
@@ -0,0 +1,42 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= qmidiarp
+DISTVERSIONPREFIX= qmidiarp-
+DISTVERSION= 0.6.4-26
+DISTVERSIONSUFFIX= -g1a15c13
+CATEGORIES= audio
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= MIDI arpeggiator, sequencer and LFO for JACK
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ liblo.so:audio/liblo \
+ libjack.so:audio/jack
+
+USES= autoreconf compiler:c++11-lib desktop-file-utils \
+ gmake localbase libtool pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= emuse
+USE_QT5= core gui network widgets buildtools_build \
+ linguisttools_build
+USE_CXXSTD= c++11
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-qt5 --enable-translations=yes
+INSTALLS_ICONS= yes
+
+OPTIONS_DEFINE= NLS LV2
+OPTIONS_DEFAULT=LV2
+OPTIONS_SUB= yes
+LV2_DESC= Build and install LV2 plugins
+LV2_CONFIGURE_OFF= --disable-lv2plugins
+NLS_CONFIGURE_ON= --enable-translations
+
+post-install-LV2-on:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/qmidiarp_[lsa][fer][oqp].lv2/*.so
+
+.include <bsd.port.mk>
diff --git a/audio/qmidiarp/distinfo b/audio/qmidiarp/distinfo
new file mode 100644
index 000000000000..cf03547baab3
--- /dev/null
+++ b/audio/qmidiarp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502913592
+SHA256 (emuse-qmidiarp-qmidiarp-0.6.4-26-g1a15c13_GH0.tar.gz) = 19a7c9994093947fe2ae502f0ac12a1dec35a9770ef45723ffd5fd054cec23fd
+SIZE (emuse-qmidiarp-qmidiarp-0.6.4-26-g1a15c13_GH0.tar.gz) = 286948
diff --git a/audio/qmidiarp/pkg-descr b/audio/qmidiarp/pkg-descr
new file mode 100644
index 000000000000..2cee574a0863
--- /dev/null
+++ b/audio/qmidiarp/pkg-descr
@@ -0,0 +1,17 @@
+QMidiArp is an advanced MIDI arpeggiator, programmable step sequencer and LFO.
+It can hold any number of arpeggiator, sequencer, or LFO modules running in
+parallel.
+
+Arpeggiator modules produce sequences depending on the notes sent to their input
+port, which is typically connected to a keyboard or another sequencer.
+
+Step sequencer modules allow you to create simple linear, monophonic and
+globally transposable sequences similar to the first analog sequencers.
+
+MIDI LFO modules independently produce MIDI controller data of adjustable
+waveform, time resolution, amplitude and duration.
+
+A Global Storage Tool can store different setups and switch between them at a
+given time. It allows you to dynamically combine patterns and LFO wave forms.
+
+WWW: http://qmidiarp.sourceforge.net/
diff --git a/audio/qmidiarp/pkg-plist b/audio/qmidiarp/pkg-plist
new file mode 100644
index 000000000000..d2ff8abc1a52
--- /dev/null
+++ b/audio/qmidiarp/pkg-plist
@@ -0,0 +1,31 @@
+bin/qmidiarp
+%%LV2%%lib/lv2/qmidiarp_arp.lv2/manifest.ttl
+%%LV2%%lib/lv2/qmidiarp_arp.lv2/qmidiarp_arp.so
+%%LV2%%lib/lv2/qmidiarp_arp.lv2/qmidiarp_arp.ttl
+%%LV2%%lib/lv2/qmidiarp_arp.lv2/qmidiarp_arp_ui.so
+%%LV2%%lib/lv2/qmidiarp_arp.lv2/qmidiarp_arp_ui.ttl
+%%LV2%%lib/lv2/qmidiarp_lfo.lv2/manifest.ttl
+%%LV2%%lib/lv2/qmidiarp_lfo.lv2/qmidiarp_lfo.so
+%%LV2%%lib/lv2/qmidiarp_lfo.lv2/qmidiarp_lfo.ttl
+%%LV2%%lib/lv2/qmidiarp_lfo.lv2/qmidiarp_lfo_ui.so
+%%LV2%%lib/lv2/qmidiarp_lfo.lv2/qmidiarp_lfo_ui.ttl
+%%LV2%%lib/lv2/qmidiarp_seq.lv2/manifest.ttl
+%%LV2%%lib/lv2/qmidiarp_seq.lv2/qmidiarp_seq.so
+%%LV2%%lib/lv2/qmidiarp_seq.lv2/qmidiarp_seq.ttl
+%%LV2%%lib/lv2/qmidiarp_seq.lv2/qmidiarp_seq_ui.so
+%%LV2%%lib/lv2/qmidiarp_seq.lv2/qmidiarp_seq_ui.ttl
+man/de/man1/qmidiarp.1.gz
+man/fr/man1/qmidiarp.1.gz
+man/man1/qmidiarp.1.gz
+share/appdata/qmidiarp.appdata.xml
+share/applications/qmidiarp.desktop
+share/icons/hicolor/scalable/apps/qmidiarp.svg
+%%DATADIR%%/examples/demo.qmax
+%%DATADIR%%/examples/demo_seqlfo.qmax
+%%DATADIR%%/examples/demo_seqlfo2.qmax
+%%DATADIR%%/examples/demo_up_down.qmax
+%%DATADIR%%/examples/old_arp.qmax
+%%LV2%%%%DATADIR%%/translations/qmidiarp_cs.qm
+%%LV2%%%%DATADIR%%/translations/qmidiarp_de.qm
+%%LV2%%%%DATADIR%%/translations/qmidiarp_es.qm
+%%LV2%%%%DATADIR%%/translations/qmidiarp_fr.qm