aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-07-28 19:05:27 +0800
committersobomax <sobomax@FreeBSD.org>2000-07-28 19:05:27 +0800
commit79b55f19e1756864befe7025b145b204b61a226f (patch)
treed698dd32134d1edd149dd2ac5c29bcc50080b872 /audio
parent613ae557d711213647fe516c2fe3f56e1a52026d (diff)
downloadfreebsd-ports-gnome-79b55f19e1756864befe7025b145b204b61a226f.tar.gz
freebsd-ports-gnome-79b55f19e1756864befe7025b145b204b61a226f.tar.zst
freebsd-ports-gnome-79b55f19e1756864befe7025b145b204b61a226f.zip
Add ccaudio - a generic C++ class library for audio files and devices.
PR: 20230 Submitted by: David Sugar <dyfet@gnu.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/ccaudio/Makefile26
-rw-r--r--audio/ccaudio/distinfo1
-rw-r--r--audio/ccaudio/pkg-comment1
-rw-r--r--audio/ccaudio/pkg-descr7
-rw-r--r--audio/ccaudio/pkg-plist4
-rw-r--r--audio/ccaudio2/Makefile26
-rw-r--r--audio/ccaudio2/distinfo1
-rw-r--r--audio/ccaudio2/pkg-comment1
-rw-r--r--audio/ccaudio2/pkg-descr7
-rw-r--r--audio/ccaudio2/pkg-plist4
11 files changed, 79 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 59c645c16985..32a2b5e1840f 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -7,6 +7,7 @@
SUBDIR += aumix
SUBDIR += bladeenc
SUBDIR += cam
+ SUBDIR += ccaudio
SUBDIR += cd-console
SUBDIR += cd2mp3
SUBDIR += cdd
diff --git a/audio/ccaudio/Makefile b/audio/ccaudio/Makefile
new file mode 100644
index 000000000000..aba8b360e2d7
--- /dev/null
+++ b/audio/ccaudio/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ccaudio
+# Date created: 26 July 2000
+# Whom: David Sugar <dyfet@gnu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ccaudio
+PORTVERSION= 0.2.3
+CATEGORIES= audio
+MASTER_SITES= ftp://www.voxilla.org/pub/ccaudio/
+
+MAINTAINER= dyfet@gnu.org
+
+LIB_DEPENDS= ccstd.0:${PORTSDIR}/devel/commoncpp
+
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_AUTOCONF= yes
+INSTALLS_SHLIB= yes
+
+post-extract:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|-release \@LT_RELEASE\@||g'
+
+.include <bsd.port.mk>
diff --git a/audio/ccaudio/distinfo b/audio/ccaudio/distinfo
new file mode 100644
index 000000000000..1b93d9bbe8a9
--- /dev/null
+++ b/audio/ccaudio/distinfo
@@ -0,0 +1 @@
+MD5 (ccaudio-0.2.3.tar.gz) = d612d857400d2e58ac5f12449e4b85e9
diff --git a/audio/ccaudio/pkg-comment b/audio/ccaudio/pkg-comment
new file mode 100644
index 000000000000..9213724ce136
--- /dev/null
+++ b/audio/ccaudio/pkg-comment
@@ -0,0 +1 @@
+Generic C++ class library for audio files and devices
diff --git a/audio/ccaudio/pkg-descr b/audio/ccaudio/pkg-descr
new file mode 100644
index 000000000000..1c1206869fa3
--- /dev/null
+++ b/audio/ccaudio/pkg-descr
@@ -0,0 +1,7 @@
+This library is primary used to access audio files on disk. It differs from
+other audio processing libraries in that ccaudio will automatically frame
+align, merge, and fill audio frames for direct delivery to a DSP audio
+resource.
+
+- David Sugar
+dyfet@gnu.org
diff --git a/audio/ccaudio/pkg-plist b/audio/ccaudio/pkg-plist
new file mode 100644
index 000000000000..98ad68114522
--- /dev/null
+++ b/audio/ccaudio/pkg-plist
@@ -0,0 +1,4 @@
+include/cc++/audio.h
+lib/libccaudio.a
+lib/libccaudio.so
+lib/libccaudio.so.0
diff --git a/audio/ccaudio2/Makefile b/audio/ccaudio2/Makefile
new file mode 100644
index 000000000000..aba8b360e2d7
--- /dev/null
+++ b/audio/ccaudio2/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ccaudio
+# Date created: 26 July 2000
+# Whom: David Sugar <dyfet@gnu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ccaudio
+PORTVERSION= 0.2.3
+CATEGORIES= audio
+MASTER_SITES= ftp://www.voxilla.org/pub/ccaudio/
+
+MAINTAINER= dyfet@gnu.org
+
+LIB_DEPENDS= ccstd.0:${PORTSDIR}/devel/commoncpp
+
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_AUTOCONF= yes
+INSTALLS_SHLIB= yes
+
+post-extract:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|-release \@LT_RELEASE\@||g'
+
+.include <bsd.port.mk>
diff --git a/audio/ccaudio2/distinfo b/audio/ccaudio2/distinfo
new file mode 100644
index 000000000000..1b93d9bbe8a9
--- /dev/null
+++ b/audio/ccaudio2/distinfo
@@ -0,0 +1 @@
+MD5 (ccaudio-0.2.3.tar.gz) = d612d857400d2e58ac5f12449e4b85e9
diff --git a/audio/ccaudio2/pkg-comment b/audio/ccaudio2/pkg-comment
new file mode 100644
index 000000000000..9213724ce136
--- /dev/null
+++ b/audio/ccaudio2/pkg-comment
@@ -0,0 +1 @@
+Generic C++ class library for audio files and devices
diff --git a/audio/ccaudio2/pkg-descr b/audio/ccaudio2/pkg-descr
new file mode 100644
index 000000000000..1c1206869fa3
--- /dev/null
+++ b/audio/ccaudio2/pkg-descr
@@ -0,0 +1,7 @@
+This library is primary used to access audio files on disk. It differs from
+other audio processing libraries in that ccaudio will automatically frame
+align, merge, and fill audio frames for direct delivery to a DSP audio
+resource.
+
+- David Sugar
+dyfet@gnu.org
diff --git a/audio/ccaudio2/pkg-plist b/audio/ccaudio2/pkg-plist
new file mode 100644
index 000000000000..98ad68114522
--- /dev/null
+++ b/audio/ccaudio2/pkg-plist
@@ -0,0 +1,4 @@
+include/cc++/audio.h
+lib/libccaudio.a
+lib/libccaudio.so
+lib/libccaudio.so.0