aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-10-15 17:47:11 +0800
committerbapt <bapt@FreeBSD.org>2013-10-15 17:47:11 +0800
commit84e1b047e2b53a5abd5d34f500e806f5be240d72 (patch)
treefd2d50aa5a504b7a50a2dafa0d703548e9649dc0 /audio
parent32328777a2d5f7186f61eeb1e5c4edb49592da31 (diff)
downloadfreebsd-ports-gnome-84e1b047e2b53a5abd5d34f500e806f5be240d72.tar.gz
freebsd-ports-gnome-84e1b047e2b53a5abd5d34f500e806f5be240d72.tar.zst
freebsd-ports-gnome-84e1b047e2b53a5abd5d34f500e806f5be240d72.zip
Remove all options bringing gnome1 libraries
Diffstat (limited to 'audio')
-rw-r--r--audio/gqmpeg/Makefile9
-rw-r--r--audio/soundtracker/Makefile16
2 files changed, 6 insertions, 19 deletions
diff --git a/audio/gqmpeg/Makefile b/audio/gqmpeg/Makefile
index e9f584861aa6..3522e23fbc2f 100644
--- a/audio/gqmpeg/Makefile
+++ b/audio/gqmpeg/Makefile
@@ -24,8 +24,8 @@ RUN_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
USE_GNOME= gdkpixbuf
NO_STAGE= yes
USES= gettext
-WANT_GNOME= yes
USE_AUTOTOOLS= autoconf213 libtool
+CONFIGURE_ENV+= USE_GNOME=""
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib -lintl
@@ -34,13 +34,6 @@ MAN1= gqmpeg.1
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgnomelibs}!=""
-USE_GNOME+= gnomeprefix gnomelibs
-CONFIGURE_ENV+= USE_GNOME="yes"
-.else
-CONFIGURE_ENV+= USE_GNOME=""
-.endif
-
.if !defined(WITH_MPG321)
pre-everything::
@${ECHO_MSG}
diff --git a/audio/soundtracker/Makefile b/audio/soundtracker/Makefile
index 68d4005a3879..8ac8031180f5 100644
--- a/audio/soundtracker/Makefile
+++ b/audio/soundtracker/Makefile
@@ -4,7 +4,7 @@
PORTNAME= soundtracker
PORTVERSION= 0.6.8
PORTREVISION= 14
-CATEGORIES= audio gnome
+CATEGORIES= audio
MASTER_SITES= http://www.soundtracker.org/dl/%SUBDIR%/
MASTER_SITE_SUBDIR= v${PORTVERSION:R}
@@ -13,7 +13,7 @@ COMMENT= Mod player/tracking tool which supports XM and MOD formats
LICENSE= GPLv2
-LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
GNU_CONFIGURE= yes
USES= pathfix pkgconfig
@@ -23,11 +23,12 @@ USE_GNOME= esound gdkpixbuf
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= GNOME1 JACK SDL NLS
+OPTIONS_DEFINE= JACK SDL NLS
OPTIONS_DEFINE_i386= ASM
-GNOME1_DESC= Use GNOME 1.x (enables envelope editing)
ASM_DESC= Use optimized assembly (potentially unstable)
+CONFIGURE_ARGS+= --disable-gnome
+
DESKTOP_ENTRIES="SoundTracker" "Pattern-oriented music editor" \
"${PREFIX}/share/pixmaps/${PORTNAME}.xpm" \
"soundtracker" "AudioVideo;Audio;AudioVideoEditing;" false
@@ -38,13 +39,6 @@ DESKTOP_ENTRIES="SoundTracker" "Pattern-oriented music editor" \
CONFIGURE_ARGS+= --enable-asm
.endif
-.if ${PORT_OPTIONS:MGNOME}
-USE_GNOME+= gnomelibs gnomeprefix
-CONFIGURE_ARGS+= --enable-gnome
-.else
-CONFIGURE_ARGS+= --disable-gnome
-.endif
-
.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
.else