aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-09-03 23:44:13 +0800
committerrakuco <rakuco@FreeBSD.org>2015-09-03 23:44:13 +0800
commit960b6262cbb3e8ae7f17dc58f88490ad2b0ee41a (patch)
tree05f83f4626cc97a41e5a29dca71409286f46ae35 /audio
parent99dabafbcc120d9a2df35d151fc40a7a35aedaef (diff)
downloadfreebsd-ports-gnome-960b6262cbb3e8ae7f17dc58f88490ad2b0ee41a.tar.gz
freebsd-ports-gnome-960b6262cbb3e8ae7f17dc58f88490ad2b0ee41a.tar.zst
freebsd-ports-gnome-960b6262cbb3e8ae7f17dc58f88490ad2b0ee41a.zip
Uses/iconv.mk: Set iconv-related CMake variables.
The way we deal with iconv in base and ports across different FreeBSD releases is complicated: 9.x does not have iconv.h in base, 10.1 has it with a different prototype for iconv(3) and later versions have the right iconv(3) prototype. And, in some cases (USES=iconv:{translit,wchar_t}), we must always use the libiconv port. This is why there are so many checks in Uses/iconv.mk: we need to know the situation we currently have in order to decide whether to pull iconv from converters/libiconv, whether to just use its header (and pull the library from base) or whether to use everything from base. r384038 adjusted several CMake-based ports, but did so in a way that was not very scalable and required a few intrusive patches to some ports. Most ports that have both USES=cmake and USES=iconv use variations of FindIconv.cmake that behave similarly. This change passes the header and library values we really want to use to CMake using the most common variable names, bypassing the calls to find_path() and find_library() that would sometimes end up finding the wrong file. The few ports that use different variable names have had their Makefiles adjusted (we manually pass the values we want via CMAKE_ARGS). Other changes: - chinese/fcitx: Explicitly set LIBICONV_LIBC_HAS_ICONV_OPEN=OFF as we always want the version from ports because of USES=iconv:wchar_t. - editors/calligra: Explicitly use iconv:translit because Kexi needs it. - irc/weechat and irc/weechat-devel: The FindIconv.cmake patches could not be entirely removed because the check_library_exists() calls are wrong. Sent upstream: https://github.com/weechat/weechat/pull/513 - textproc/ctpp2: Use iconv:translit when the TRANSLITERATE option is used. PORTREVISION has been bumped in editors/calligra and textproc/ctpp2 because their dependency list has changed in 10.2 and later as the ports version is always used now. PR: 202798 Reviewed by: antoine, tijl Approved by: portmgr (antoine)
Diffstat (limited to 'audio')
-rw-r--r--audio/tagutil/files/patch-FindIconv.cmake31
1 files changed, 0 insertions, 31 deletions
diff --git a/audio/tagutil/files/patch-FindIconv.cmake b/audio/tagutil/files/patch-FindIconv.cmake
deleted file mode 100644
index 2cbf4f8c659d..000000000000
--- a/audio/tagutil/files/patch-FindIconv.cmake
+++ /dev/null
@@ -1,31 +0,0 @@
---- FindIconv.cmake.orig 2014-07-23 14:37:21 UTC
-+++ FindIconv.cmake
-@@ -9,6 +9,7 @@
- # ICONV_SECOND_ARGUMENT_IS_CONST - the second argument for iconv() is const
- #
- include(CheckCSourceCompiles)
-+include(CheckFunctionExists)
-
- IF (ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
- # Already in cache, be silent
-@@ -17,11 +18,15 @@ ENDIF (ICONV_INCLUDE_DIR AND ICONV_LIBRA
-
- FIND_PATH(ICONV_INCLUDE_DIR iconv.h)
-
--FIND_LIBRARY(ICONV_LIBRARIES NAMES iconv libiconv libiconv-2 c)
--
--IF(ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
-- SET(ICONV_FOUND TRUE)
--ENDIF(ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
-+IF(ICONV_INCLUDE_DIR)
-+ CHECK_FUNCTION_EXISTS(iconv ICONV_FOUND)
-+ IF(NOT ICONV_FOUND)
-+ FIND_LIBRARY(ICONV_LIBRARIES NAMES iconv libiconv libiconv-2)
-+ IF(ICONV_LIBRARIES)
-+ SET(ICONV_FOUND TRUE)
-+ ENDIF(ICONV_LIBRARIES)
-+ ENDIF(NOT ICONV_FOUND)
-+ENDIF(ICONV_INCLUDE_DIR)
-
- set(CMAKE_REQUIRED_INCLUDES ${ICONV_INCLUDE_DIR})
- set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBRARIES})