aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-05-05 22:40:49 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-05-05 22:40:49 +0800
commit9837c01bd4a3fc2f87c474d384c3c794d87e99d1 (patch)
tree1eb24e5652e067c66e1302958cc8ef60e1bc40d9 /audio
parente4fbff480a0e3e02cec21d81bd137c3ed912ea92 (diff)
downloadfreebsd-ports-gnome-9837c01bd4a3fc2f87c474d384c3c794d87e99d1.tar.gz
freebsd-ports-gnome-9837c01bd4a3fc2f87c474d384c3c794d87e99d1.tar.zst
freebsd-ports-gnome-9837c01bd4a3fc2f87c474d384c3c794d87e99d1.zip
- Sort LIB_DEPENDS
- Use USES=tar:bzip2 - Remove deprecated PTHREAD_* - Take maintainership
Diffstat (limited to 'audio')
-rw-r--r--audio/ices/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/audio/ices/Makefile b/audio/ices/Makefile
index 1ec253fd5887..e380217b4392 100644
--- a/audio/ices/Makefile
+++ b/audio/ices/Makefile
@@ -6,30 +6,28 @@ PORTVERSION= 2.0.2
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= audio net
-MASTER_SITES= http://downloads.xiph.org/releases/ices/ \
- http://svn.xiph.org/releases/ices/
+MASTER_SITES= http://downloads.xiph.org/releases/${PORTNAME}/ \
+ http://svn.xiph.org/releases/${PORTNAME}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Vorbis streaming source client for icecast 2
LICENSE= GPLv2
LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg \
- libshout.so:${PORTSDIR}/audio/libshout2 \
- libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libshout.so:${PORTSDIR}/audio/libshout \
libspeex.so:${PORTSDIR}/audio/speex \
- libtheora.so:${PORTSDIR}/multimedia/libtheora
+ libtheora.so:${PORTSDIR}/multimedia/libtheora \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
OPTIONS_DEFINE= ALSA
-USES= gmake iconv pkgconfig
-USE_BZIP2= yes
-USE_GNOME= libxml2
-GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-roaraudio --disable-sun-audio
-
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
+USE_GNOME= libxml2
+USES= gmake iconv pkgconfig tar:bzip2
ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
ALSA_CONFIGURE_ENABLE= alsa