aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-08-05 07:04:15 +0800
committerbapt <bapt@FreeBSD.org>2014-08-05 07:04:15 +0800
commit9baacd58693e77dd5d9711fa102919e19af1050e (patch)
tree112a8f78d6491222afa165f7621bf14da4ee73d9 /audio
parent84f97f003b660ca2eef29ad1f37d4df20284a60d (diff)
downloadfreebsd-ports-gnome-9baacd58693e77dd5d9711fa102919e19af1050e.tar.gz
freebsd-ports-gnome-9baacd58693e77dd5d9711fa102919e19af1050e.tar.zst
freebsd-ports-gnome-9baacd58693e77dd5d9711fa102919e19af1050e.zip
USES=execinfo
Diffstat (limited to 'audio')
-rw-r--r--audio/clementine-player/Makefile7
-rw-r--r--audio/pulseaudio/Makefile3
2 files changed, 4 insertions, 6 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index fc43c7390e0e..08d2708f8898 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -18,11 +18,10 @@ COMMENT= Cross-platform music player based on Amarok 1.4
LICENSE= GPLv3
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libtag.so:${PORTSDIR}/audio/taglib \
+LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib \
libchromaprint.so:${PORTSDIR}/audio/chromaprint \
libprotobuf.so:${PORTSDIR}/devel/protobuf \
- libqca.so:${PORTSDIR}/devel/qca \
+ libqca.so:${PORTSDIR}/devel/qca \
libqjson.so:${PORTSDIR}/devel/qjson \
libfftw3.so:${PORTSDIR}/math/fftw3 \
libechonest.so:${PORTSDIR}/audio/libechonest
@@ -33,7 +32,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
PROJECTHOST= ${PORTNAME}${PKGNAMESUFFIX}
-USES= compiler:c++11-lib cmake pkgconfig desktop-file-utils
+USES= compiler:c++11-lib cmake pkgconfig desktop-file-utils execinfo
USE_GL= glew
USE_QT4= dbus gui xml qmake_build uic_build moc_build rcc_build \
linguist_build network sql opengl qtestlib corelib webkit \
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index 09b3e04e933e..350b016dc902 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -21,13 +21,12 @@ LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libspeexdsp.so:${PORTSDIR}/audio/speex \
libdbus-1.so:${PORTSDIR}/devel/dbus \
libgdbm.so:${PORTSDIR}/databases/gdbm \
- libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
libck-connector.so:${PORTSDIR}/sysutils/consolekit
USE_GNOME= gnomehack glib20 intltool ltverhack
USE_XORG= x11 sm xtst ice
USE_LDCONFIG= yes
-USES= gettext gmake pkgconfig
+USES= gettext gmake pkgconfig execinfo
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libltdl libtool
MAKE_JOBS_UNSAFE=yes