aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-10-08 07:19:25 +0800
committersat <sat@FreeBSD.org>2006-10-08 07:19:25 +0800
commit9c5e7071744fe62f7274d006dc24a0ea9985920b (patch)
tree25cd75d4c0189700ade5e82bf88fed69d890a05c /audio
parent6a1cd1b0b2499fb50fe86c1a480e5c6ea15d0b6b (diff)
downloadfreebsd-ports-gnome-9c5e7071744fe62f7274d006dc24a0ea9985920b.tar.gz
freebsd-ports-gnome-9c5e7071744fe62f7274d006dc24a0ea9985920b.tar.zst
freebsd-ports-gnome-9c5e7071744fe62f7274d006dc24a0ea9985920b.zip
Add port audio/liblrdf:
This is a library to make it easy to manipulate RDF files describing LADSPA plugins. It can also be used for general RDF manipulation. It can read RDF/XLM and N3 files and export N3 files, it also has a light taxonomic inference capablility. WWW: http://sourceforge.net/projects/lrdf/
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/liblrdf/Makefile25
-rw-r--r--audio/liblrdf/distinfo3
-rw-r--r--audio/liblrdf/pkg-descr9
-rw-r--r--audio/liblrdf/pkg-plist12
5 files changed, 50 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 69ac4632f89a..9882c196abd7 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -304,6 +304,7 @@
SUBDIR += libgpod
SUBDIR += libid3tag
SUBDIR += libjackasyn
+ SUBDIR += liblrdf
SUBDIR += libmad
SUBDIR += libmikmod
SUBDIR += libmodplug
diff --git a/audio/liblrdf/Makefile b/audio/liblrdf/Makefile
new file mode 100644
index 000000000000..e9f87ce4e82a
--- /dev/null
+++ b/audio/liblrdf/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: liblrdf
+# Date created: 08 October 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liblrdf
+DISTVERSION= 0.4.0
+CATEGORIES= audio
+MASTER_SITES= SF/lrdf
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= RDF library with support for LADSPA plugins
+
+LIB_DEPENDS= raptor.2:${PORTSDIR}/textproc/raptor
+
+GNU_CONFIGURE= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^pkgconfigdir/s!=.*!= ${PREFIX}/libdata/pkgconfig!' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/audio/liblrdf/distinfo b/audio/liblrdf/distinfo
new file mode 100644
index 000000000000..b6d77e396e13
--- /dev/null
+++ b/audio/liblrdf/distinfo
@@ -0,0 +1,3 @@
+MD5 (liblrdf-0.4.0.tar.gz) = 327a5674f671c4b360c6353800226877
+SHA256 (liblrdf-0.4.0.tar.gz) = 95e98e86ba06ed73a5571cbcff3ee88e481b403b6eb727e9eb182870efd9b204
+SIZE (liblrdf-0.4.0.tar.gz) = 336959
diff --git a/audio/liblrdf/pkg-descr b/audio/liblrdf/pkg-descr
new file mode 100644
index 000000000000..03f5b09befc0
--- /dev/null
+++ b/audio/liblrdf/pkg-descr
@@ -0,0 +1,9 @@
+This is a library to make it easy to manipulate RDF files describing LADSPA
+plugins.
+
+It can also be used for general RDF manipulation.
+
+It can read RDF/XLM and N3 files and export N3 files, it also has a light
+taxonomic inference capablility.
+
+WWW: http://sourceforge.net/projects/lrdf/
diff --git a/audio/liblrdf/pkg-plist b/audio/liblrdf/pkg-plist
new file mode 100644
index 000000000000..3e4e33031e51
--- /dev/null
+++ b/audio/liblrdf/pkg-plist
@@ -0,0 +1,12 @@
+include/lrdf.h
+include/lrdf_types.h
+lib/liblrdf.a
+lib/liblrdf.la
+lib/liblrdf.so
+lib/liblrdf.so.2
+libdata/pkgconfig/lrdf.pc
+share/ladspa/rdf/ladspa.rdfs
+@dirrmtry libdata/pkgconfig
+@dirrmtry share/ladspa/rdf/ladspa.rdfs
+@dirrmtry share/ladspa/rdf
+@dirrmtry share/ladspa