aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-01 14:57:16 +0800
committerbapt <bapt@FreeBSD.org>2012-06-01 14:57:16 +0800
commitb557076221bc64a31bd5b376790cb714f486c893 (patch)
treeba92db0751c943ce993ff1ab39dfac9c225c1981 /audio
parent8033973ca84c7935f11bc3068cf3a5d5f6287da8 (diff)
downloadfreebsd-ports-gnome-b557076221bc64a31bd5b376790cb714f486c893.tar.gz
freebsd-ports-gnome-b557076221bc64a31bd5b376790cb714f486c893.tar.zst
freebsd-ports-gnome-b557076221bc64a31bd5b376790cb714f486c893.zip
Convert to new options framework
Diffstat (limited to 'audio')
-rw-r--r--audio/blop/Makefile14
-rw-r--r--audio/csound/Makefile47
-rw-r--r--audio/csound/pkg-plist10
-rw-r--r--audio/darkice/Makefile34
-rw-r--r--audio/dssi/Makefile6
-rw-r--r--audio/ecasound/Makefile26
-rw-r--r--audio/fmit/Makefile22
-rw-r--r--audio/gnuitar/Makefile12
-rw-r--r--audio/gnupod/Makefile13
-rw-r--r--audio/gogo-petit/Makefile8
-rw-r--r--audio/ices0/Makefile28
-rw-r--r--audio/jokosher/Makefile29
12 files changed, 116 insertions, 133 deletions
diff --git a/audio/blop/Makefile b/audio/blop/Makefile
index 101dd97a164e..704433b874cd 100644
--- a/audio/blop/Makefile
+++ b/audio/blop/Makefile
@@ -19,19 +19,19 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ladspa-prefix="${LOCALBASE}"
-OPTIONS= NLS "Native language support" on
+OPTIONS_DEFINE= NLS
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@@ -39,4 +39,4 @@ post-patch:
's|$$(LIBS)$$|$$(LIBS) $$(LDFLAGS)|g ; \
s|-lc | |g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index d6e8b6fd2d54..cf98946c88d6 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -27,14 +27,11 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13 \
${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
-OPTIONS= ALSA "Build ALSA I/O module" off \
- DSSI "Build DSSI/LADSPA host opcodes" off \
- FLUIDSYNTH "Building FluidSynth opcodes" off \
- JACK "Build Jack I/O module and opcodes" off \
- OSC "Build OSC opcodes" off \
- PORTAUDIO "Build the PortAudio I/O module" off \
- PULSEAUDIO "Build the PulseAudio I/O module" off \
- FLTKGUI "Build FLTK plugin and GUI" on
+OPTIONS_DEFINE= ALSA LADSPA FLUIDSYNTH JACK OSC PORTAUDIO PULSEAUDIO FLTK
+OPTIONS_DEFAULT= FLTK
+FLTK_DESC= Build FLTK plugin and GUI
+OSC_DESC= Build OSC opcodes
+FLUIDSYNTH_DESC= Build FluidSynth opcodes
CONFLICTS_INSTALL= outguess-*
@@ -56,7 +53,7 @@ SUB_FILES= pkg-message
.include <bsd.port.options.mk>
-.if defined(WITH_ALSA)
+.if ${PORT_OPTIONS:MALSA}
LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
SCONS_ARGS+= useALSA=1
PLIST_SUB+= ALSA=""
@@ -67,17 +64,17 @@ PLIST_SUB+= ALSA="@comment "
ALSA_H= ##alsa/asoundlib.h##
.endif
-.if defined(WITH_DSSI)
+.if ${PORT_OPTIONS:MLADSPA}
BUILD_DEPENDS+= dssi>=0:${PORTSDIR}/audio/dssi
RUN_DEPENDS+= dssi>=0:${PORTSDIR}/audio/dssi
-SCONS_ARGS+= buildDSSI=1
-PLIST_SUB+= DSSI=""
+SCONS_ARGS+= buildLADSPA=1
+PLIST_SUB+= LADSPA=""
.else
-SCONS_ARGS+= buildDSSI=0
-PLIST_SUB+= DSSI="@comment "
+SCONS_ARGS+= buildLADSPA=0
+PLIST_SUB+= LADSPA="@comment "
.endif
-.if defined(WITH_FLUIDSYNTH)
+.if ${PORT_OPTIONS:MFLUIDSYNTH}
LIB_DEPENDS+= fluidsynth.1:${PORTSDIR}/audio/fluidsynth
PLIST_SUB+= FLUIDSYNTH=""
FLUIDSYNTH_H= fluidsynth.h
@@ -86,7 +83,7 @@ PLIST_SUB+= FLUIDSYNTH="@comment "
FLUIDSYNTH_H= ##fluidsynth.h##
.endif
-.if defined(WITH_JACK)
+.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
SCONS_ARGS+= useJack=1
PLIST_SUB+= JACK=""
@@ -95,7 +92,7 @@ SCONS_ARGS+= useJack=0
PLIST_SUB+= JACK="@comment "
.endif
-.if defined(WITH_OSC)
+.if ${PORT_OPTIONS:MOSC}
LIB_DEPENDS+= lo.7:${PORTSDIR}/audio/liblo
SCONS_ARGS+= useOSC=1
PLIST_SUB+= OSC=""
@@ -104,7 +101,7 @@ SCONS_ARGS+= useOSC=0
PLIST_SUB+= OSC="@comment "
.endif
-.if defined(WITH_PORTAUDIO)
+.if ${PORT_OPTIONS:MPORTAUDIO}
BUILD_DEPENDS+= portaudio>=19:${PORTSDIR}/audio/portaudio2
RUN_DEPENDS+= portaudio>=19:${PORTSDIR}/audio/portaudio2
SCONS_ARGS+= usePortAudio=1
@@ -118,7 +115,7 @@ PORTAUDIO_L= # empty
PORTAUDIO_R= # empty
.endif
-.if defined(WITH_PULSEAUDIO)
+.if ${PORT_OPTIONS:MPULSEAUDIO}
LIB_DEPENDS+= pulse-simple.0:${PORTSDIR}/audio/pulseaudio
PLIST_SUB+= PULSEAUDIO=""
PULSEAUDIO_H= pulse/simple.h
@@ -127,16 +124,16 @@ PLIST_SUB+= PULSEAUDIO="@comment "
PULSEAUDIO_H= ##pulse/simple.h##
.endif
-.if !defined(WITHOUT_FLTKGUI)
+.if ${PORT_OPTIONS:MFLTK}
LIB_DEPENDS+= fltk.1:${PORTSDIR}/x11-toolkits/fltk
-PLIST_SUB+= FLTKGUI=""
+PLIST_SUB+= FLTK=""
SCONS_ARGS+= buildCsound5GUI=1 buildCSEditor=1 buildWinsound=1 useFLTK=1
.else
-PLIST_SUB+= FLTKGUI="@comment "
+PLIST_SUB+= FLTK="@comment "
SCONS_ARGS+= buildCsound5GUI=0 buildCSEditor=0 buildWinsound=0 useFLTK=0
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
EXTRACT_DEPENDS+=${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
DISTFILES+= Csound${PORTVERSION:R}_manual_html.zip:manual
.endif
@@ -148,7 +145,7 @@ CMAKE_ARGS+= Word64=1
.endif
post-extract:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@(cd ${DISTDIR}/${DIST_SUBDIR} && ${UNZIP_CMD} -qo \
Csound${PORTVERSION:R}_manual_html.zip -d ${WRKDIR})
.endif
@@ -197,7 +194,7 @@ post-patch:
post-install:
@${LN} -sf libcsound64.so.5 ${PREFIX}/lib/libcsound64.so
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${ECHO_MSG} " Installing the manual."
@(cd ${WRKDIR}/html && ${COPYTREE_SHARE} . ${DOCSDIR})
diff --git a/audio/csound/pkg-plist b/audio/csound/pkg-plist
index 89e4cdef434f..b2b9e07b0de3 100644
--- a/audio/csound/pkg-plist
+++ b/audio/csound/pkg-plist
@@ -4,7 +4,7 @@ bin/csb64enc
bin/csbeats
bin/csmixer
bin/csound
-%%FLTKGUI%%bin/csound5gui
+%%FLTK%%bin/csound5gui
bin/cvanal
bin/dnoise
bin/envext
@@ -27,7 +27,7 @@ bin/scsort
bin/sdif2ad
bin/sndinfo
bin/srconv
-%%FLTKGUI%%bin/winsound
+%%FLTK%%bin/winsound
include/csound/CppSound.hpp
include/csound/CsoundFile.hpp
include/csound/OpcodeBase.hpp
@@ -53,7 +53,7 @@ lib/csound/plugins64/libcellular.so
lib/csound/plugins64/libcontrol.so
lib/csound/plugins64/libcs_date.so
lib/csound/plugins64/libdoppler.so
-%%DSSI%%lib/csound/plugins64/libdssi4cs.so
+%%LADSPA%%lib/csound/plugins64/libdssi4cs.so
lib/csound/plugins64/libfareygen.so
%%FLUIDSYNTH%%lib/csound/plugins64/libfluidOpcodes.so
lib/csound/plugins64/libfractalnoise.so
@@ -75,8 +75,8 @@ lib/csound/plugins64/libsystem_call.so
lib/csound/plugins64/libudprecv.so
lib/csound/plugins64/libudpsend.so
lib/csound/plugins64/liburandom.so
-%%FLTKGUI%%lib/csound/plugins64/libvirtual.so
-%%FLTKGUI%%lib/csound/plugins64/libwidgets.so
+%%FLTK%%lib/csound/plugins64/libvirtual.so
+%%FLTK%%lib/csound/plugins64/libwidgets.so
lib/libcsladspa.so
lib/libcsnd.so.5
lib/libcsound64.so
diff --git a/audio/darkice/Makefile b/audio/darkice/Makefile
index 07bce45bd338..337d0c1e3303 100644
--- a/audio/darkice/Makefile
+++ b/audio/darkice/Makefile
@@ -17,12 +17,13 @@ COMMENT= An IceCast, IceCast2 and ShoutCast live audio streamer
LICENSE= GPLv3
-OPTIONS= VORBIS "Ogg Vorbis support" on \
- LAME "LAME support for MP3" off \
- TWOLAME "TwoLAME support for MP2" off \
- FAAC "FAAC support for AAC" off \
- JACK "Jack support" off \
- AACPLUS "AAC HEv2 and libsamplerate support" off
+OPTIONS_DEFINE= JACK
+OPTIONS_MULTI= CODEC
+OPTIONS_MULTI_CODEC= VORBIS LAME TWOLAME FAAC AACPLUS
+OPTIONS_DEFAULT= VORBIS
+
+AACPLUS_DESC= AAC HEv2 and libsamplerate support
+TWOLAME_DESC= TwoLAME support for MP2
USE_AUTOTOOLS= aclocal autoconf
GNU_CONFIGURE= yes
@@ -39,42 +40,42 @@ MAN5= darkice.cfg.5
.include <bsd.port.options.mk>
-.if defined(WITHOUT_VORBIS)
-CONFIGURE_ARGS+= --without-vorbis
-.else
+.if ${PORT_OPTIONS:MVORBIS}
CONFIGURE_ARGS+= --with-vorbis-prefix=${LOCALBASE}
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.else
+CONFIGURE_ARGS+= --without-vorbis
.endif
-.if defined(WITH_LAME)
+.if ${PORT_OPTIONS:MLAME}
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
CONFIGURE_ARGS+= --with-lame-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-lame
.endif
-.if defined(WITH_TWOLAME)
+.if ${PORT_OPTIONS:MTWOLAME}
LIB_DEPENDS+= twolame.0:${PORTSDIR}/audio/twolame
CONFIGURE_ARGS+= --with-twolame-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-twolame
.endif
-.if defined(WITH_FAAC)
+.if ${PORT_OPTIONS:MFAAC}
LIB_DEPENDS+= faac.0:${PORTSDIR}/audio/faac
CONFIGURE_ARGS+= --with-faac-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-faac
.endif
-.if defined(WITH_JACK)
+.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
CONFIGURE_ARGS+= --with-jack-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-jack
.endif
-.if defined(WITH_AACPLUS)
+.if ${PORT_OPTIONS:MAACPLUS}
LIB_DEPENDS+= aacplus.2:${PORTSDIR}/audio/libaacplus \
samplerate.1:${PORTSDIR}/audio/libsamplerate
CONFIGURE_ARGS+= --with-aacplus-prefix=${LOCALBASE} --with-samplerate-prefix=${LOCALBASE}
@@ -82,11 +83,6 @@ CONFIGURE_ARGS+= --with-aacplus-prefix=${LOCALBASE} --with-samplerate-prefix=${L
CONFIGURE_ARGS+= --without-aacplus --without-samplerate
.endif
-.if defined(WITHOUT_VORBIS) && defined(WITHOUT_LAME) && defined(WITHOUT_TWOLAME) && \
- defined(WITHOUT_FAAC) && defined(WITHOUT_AACPLUS)
-IGNORE=at least one of VORBIS,LAME,TWOLAME,FAAC,AACPLUS options must be set
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/test/s|==|=|g'\
-e 's/sbr_main.h/libaacplus\/sbr_main.h/' ${WRKSRC}/configure
diff --git a/audio/dssi/Makefile b/audio/dssi/Makefile
index 401aaed0f8a5..70f0484bd8a2 100644
--- a/audio/dssi/Makefile
+++ b/audio/dssi/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
jack.0:${PORTSDIR}/audio/jack
RUN_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
-OPTIONS= QT "Enable Qt4 support" off
+OPTIONS_DEFINE= QT4
USE_GNOME= gnomehack
USE_GMAKE= yes
@@ -39,7 +39,7 @@ MAN1= dssi_analyse_plugin.1 dssi_list_plugins.1 dssi_osc_send.1 \
.include <bsd.port.options.mk>
-.if defined(WITH_QT)
+.if ${PORT_OPTIONS:MQT4}
USE_QT_VER= 4
QT_COMPONENTS= corelib gui
QT_NONSTANDARD= yes
@@ -57,7 +57,7 @@ post-patch:
's|-ldl$$||' ${WRKSRC}/jack-dssi-host/Makefile.in
@${REINPLACE_CMD} -e \
'/alsa >=/s|$$PKG_CONFIG|${FALSE}|' ${WRKSRC}/configure
-.if !defined(WITH_QT)
+.if empty(PORT_OPTIONS:MQT4)
@${REINPLACE_CMD} -e \
'/QtCore >=/s|$$PKG_CONFIG|${FALSE}|' ${WRKSRC}/configure
.endif
diff --git a/audio/ecasound/Makefile b/audio/ecasound/Makefile
index 4d5da8528b5c..6b0a6b646d60 100644
--- a/audio/ecasound/Makefile
+++ b/audio/ecasound/Makefile
@@ -15,12 +15,10 @@ COMMENT= Multitrack audio processing software
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
-OPTIONS= ARTS "Enable aRts support" off \
- AUDIOFILE "Enable libaudiofile support" off \
- JACK "Enable JACK support" off \
- LO "Enable liblo support" off \
- OIL "Enable liboil support" off \
- SAMPLERATE "Enable libsamplerate support" off
+OPTIONS_DEFINE= ARTS AUDIOFILE JACK LO OIL SAMPLERATE
+AUDIOFILE_DESC= Enable libaudiofile support
+LO_DESC= Enable liblo support
+OIL_DESC= Enable liboil support
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
@@ -40,43 +38,43 @@ MAN5= ecasoundrc.5
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if exists(${LOCALBASE}/lib/libreadline.so.6)
LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
-.if defined(WITH_ARTS)
+.if ${PORT_OPTIONS:MARTS}
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
.else
CONFIGURE_ARGS+= --disable-arts
.endif
-.if defined(WITH_AUDIOFILE)
+.if ${PORT_OPTIONS:MAUDIOFILE}
LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
.else
CONFIGURE_ARGS+= --disable-audiofile
.endif
-.if defined(WITH_JACK)
+.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
.else
CONFIGURE_ARGS+= --disable-jack
.endif
-.if defined(WITH_LO)
+.if ${PORT_OPTIONS:MLO}
LIB_DEPENDS+= lo.7:${PORTSDIR}/audio/liblo
.else
CONFIGURE_ARGS+= --disable-liblo
.endif
-.if defined(WITH_OIL)
+.if ${PORT_OPTIONS:MOIL}
LIB_DEPENDS+= oil-0.3.0:${PORTSDIR}/devel/liboil
.else
CONFIGURE_ARGS+= --disable-liboil
.endif
-.if defined(WITH_SAMPLERATE)
+.if ${PORT_OPTIONS:MSAMPLERATE}
LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
.else
CONFIGURE_ARGS+= --disable-libsamplerate --disable-sndfile
@@ -90,4 +88,4 @@ post-patch:
s| -D_THREAD_SAFE||g ; \
s| -D_P1003_1B_VISIBLE||' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/fmit/Makefile b/audio/fmit/Makefile
index d89ac9aa9e9a..57c46481984c 100644
--- a/audio/fmit/Makefile
+++ b/audio/fmit/Makefile
@@ -19,10 +19,8 @@ LICENSE= GPLv2
LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3
-OPTIONS= OSS "Enable OSS support" on \
- ALSA "Enable ALSA support" off \
- PORTAUDIO "Enable PortAudio support" off \
- JACK "Enable JACK support" on \
+OPTIONS_DEFINE= OSS ALSA PORTAUDIO JACK
+OPTIONS_DEFAULT= OSS JACK
USE_BZIP2= yes
USE_QT_VER= 4
@@ -35,20 +33,20 @@ MAKE_JOBS_SAFE= yes
.include <bsd.port.options.mk>
-.if defined(WITHOUT_OSS)
-CMAKE_ARGS+= -DSOUNDSYSTEM_USE_OSS:BOOL=false
-.else
+.if ${PORT_OPTIONS:MOSS}
CMAKE_ARGS+= -DSOUNDSYSTEM_USE_OSS:BOOL=true
+.else
+CMAKE_ARGS+= -DSOUNDSYSTEM_USE_OSS:BOOL=false
.endif
-.if defined(WITH_ALSA)
+.if ${PORT_OPTIONS:MALSA}
LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
CMAKE_ARGS+= -DSOUNDSYSTEM_USE_ALSA:BOOL=true
.else
CMAKE_ARGS+= -DSOUNDSYSTEM_USE_ALSA:BOOL=false
.endif
-.if defined(WITH_PORTAUDIO)
+.if ${PORT_OPTIONS:MPORTAUDIO}
BUILD_DEPENDS+= portaudio>=19:${PORTSDIR}/audio/portaudio2
RUN_DEPENDS+= portaudio>=19:${PORTSDIR}/audio/portaudio2
CMAKE_ARGS+= -DSOUNDSYSTEM_USE_PORTAUDIO:BOOL=true
@@ -56,11 +54,11 @@ CMAKE_ARGS+= -DSOUNDSYSTEM_USE_PORTAUDIO:BOOL=true
CMAKE_ARGS+= -DSOUNDSYSTEM_USE_PORTAUDIO:BOOL=false
.endif
-.if defined(WITHOUT_JACK)
-CMAKE_ARGS+= -DSOUNDSYSTEM_USE_JACK:BOOL=false
-.else
+.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
CMAKE_ARGS+= -DSOUNDSYSTEM_USE_JACK:BOOL=true
+.else
+CMAKE_ARGS+= -DSOUNDSYSTEM_USE_JACK:BOOL=false
.endif
.include <bsd.port.mk>
diff --git a/audio/gnuitar/Makefile b/audio/gnuitar/Makefile
index 9543d99f896a..0528ee9f2378 100644
--- a/audio/gnuitar/Makefile
+++ b/audio/gnuitar/Makefile
@@ -23,7 +23,9 @@ TXT_DOCS= AUTHORS COPYING FAQ INSTALL NEWS README TODO ChangeLog
HTML_DOCS= faq.html index.html install.html readme.html
PORTDOCS= ${TXT_DOCS} ${HTML_DOCS}
-OPTIONS= SUID "Use suid to allow highest priority (priv. dropped)" On
+OPTIONS_DEFINE= SUID DOCS
+OPTIONS_DEFAULT= SUID
+SUID_DESC= Use suid to allow highest priority (priv. dropped)
DESKTOP_ENTRIES="GNUitar" \
"Apply guitar effects in real-time" \
@@ -32,7 +34,7 @@ DESKTOP_ENTRIES="GNUitar" \
"" \
true
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
pre-fetch:
@${CAT} pkg-message
@@ -47,7 +49,7 @@ do-install:
post-install:
@${MKDIR} ${PREFIX}/share/pixmaps
@${INSTALL_DATA} ${WRKSRC}/src/gnuitar.xpm ${PREFIX}/share/pixmaps
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in ${TXT_DOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
@@ -56,10 +58,10 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}
.endfor
.endif
-.if defined(WITH_SUID)
+.if ${PORT_OPTIONS:MSUID}
# make it setuid-root to be able to set realtime priority (root
# privileges are dropped in the main routine)
@${CHMOD} u+s ${PREFIX}/bin/gnuitar
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/gnupod/Makefile b/audio/gnupod/Makefile
index da08ba2f24fe..0ecfa5f857b6 100644
--- a/audio/gnupod/Makefile
+++ b/audio/gnupod/Makefile
@@ -37,21 +37,20 @@ NO_BUILD= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
CONFIGURE_ENV= ac_cv_path_PERL=${PERL}
-OPTIONS= FLAC "Enable FLAC support" off \
- VORBIS "Enable Ogg Vorbis support" off
+OPTIONS_DEFINE= FLAC VORBIS DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_FLAC) || exists(${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm)
+.if ${PORT_OPTIONS:MFLAC} || exists(${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm)
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm:${PORTSDIR}/audio/p5-Audio-FLAC-Header
.endif
-.if defined(WITH_VORBIS) || exists(${SITE_PERL}/Ogg/Vorbis/Header/PurePerl.pm)
+.if ${PORT_OPTIONS:MVORBIS} || exists(${SITE_PERL}/Ogg/Vorbis/Header/PurePerl.pm)
BUILD_DEPENDS+= ${SITE_PERL}/Ogg/Vorbis/Header/PurePerl.pm:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header-PurePerl
BUILD_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
.endif
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}
@@ -65,4 +64,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/doc/ipod.svg ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/gogo-petit/Makefile b/audio/gogo-petit/Makefile
index 841773723c07..5181dd296550 100644
--- a/audio/gogo-petit/Makefile
+++ b/audio/gogo-petit/Makefile
@@ -30,11 +30,11 @@ MAKE_ENV+= AS="${AS}" \
ONLY_FOR_ARCHS= i386
PLIST_FILES= bin/gogo-petit
-OPTIONS= THREADS "build a multithreaded encoder for SMP" Off
+OPTIONS_DEFINE= THREADS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.ifdef(WITH_THREADS)
+.if ${PORT_OPTIONS:MTHREADS}
LDFLAGS+= ${PTHREAD_LIBS}
CFLAGS+= ${PTHREAD_CFLAGS}
MAKEFILE= ${FILESDIR}/Makefile.rfork
@@ -42,4 +42,4 @@ MAKEFILE= ${FILESDIR}/Makefile.rfork
MAKEFILE= ${FILESDIR}/Makefile.unthreaded
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/ices0/Makefile b/audio/ices0/Makefile
index 64a1b3ae93c1..e054f820b12a 100644
--- a/audio/ices0/Makefile
+++ b/audio/ices0/Makefile
@@ -17,10 +17,8 @@ COMMENT= An mp3 streaming source client for icecast 2
LIB_DEPENDS= shout.5:${PORTSDIR}/audio/libshout2 \
xml2.5:${PORTSDIR}/textproc/libxml2
-OPTIONS= FLAC "Enable flac transcoding support" Off \
- FAAD "Enable mpep4 transcoding support" Off \
- VORBIS "Enable ogg/vorbis transcoding support" Off \
- PYTHON "Enable Python scripting" On
+OPTIONS_DEFINE= FLAC FAAD VORBIS PYTHON
+OPTIONS_DEFAULT= PYTHON
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
@@ -42,35 +40,35 @@ MAN1= ices0.1
.include <bsd.port.pre.mk>
-.if !defined(WITH_FLAC)
-CONFIGURE_ARGS+=--without-flac
-.else
+.if ${PORT_OPTIONS:MFLAC}
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac \
mp3lame:${PORTSDIR}/audio/lame
+.else
+CONFIGURE_ARGS+=--without-flac
.endif
-.if !defined(WITH_FAAD)
-CONFIGURE_ARGS+=--without-faad
-.else
+.if ${PORT_OPTIONS:MFAAD}
LIB_DEPENDS+= faad:${PORTSDIR}/audio/faad \
mp3lame:${PORTSDIR}/audio/lame
+.else
+CONFIGURE_ARGS+=--without-faad
.endif
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
BUILD_DEPENDS+= python:${PORTSDIR}/lang/python
RUN_DEPENDS+= python:${PORTSDIR}/lang/python
.else
CONFIGURE_ARGS+=--without-python
.endif
-.if !defined(WITH_VORBIS)
-CONFIGURE_ARGS+=--without-vorbis
-.else
+.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis \
mp3lame:${PORTSDIR}/audio/lame
+.else
+CONFIGURE_ARGS+=--without-vorbis
.endif
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/jokosher/Makefile b/audio/jokosher/Makefile
index d2140d92f406..9c5b8b8e507b 100644
--- a/audio/jokosher/Makefile
+++ b/audio/jokosher/Makefile
@@ -26,37 +26,32 @@ USE_GNOME= gnomehier
USE_GSTREAMER= gnonlin good python
INSTALLS_ICONS= yes
-OPTIONS= DBUS "D-Bus extension" on \
- FLAC "Flac export/import" on \
- GCONF "Gnome Audio playback/record" on \
- JACK "Jack audio playback/record" off \
- LADSPA "Instrument effects" on \
- LAME "Mp3 export" off \
- MP3 "Mp3 import" off \
- PIDGIN "Pidgin status extension" off \
- PROFILES "Gnome Audio Profiles extension" off \
- PULSE "PulseAudio playback/record" off \
- VORBIS "Ogg Vorbis export/import" on
+OPTIONS_DEFINE= DBUS FLAC GCONF JACK LADSPA LAME MP3 PIDGIN PROFILES PULSE VORBIS
+OPTIONS_DEFAULT= DBUS FLAC GCONF LADSPA VORBIS
+MP3_DESC= MP3 import
+PIDGIN_DESC= Pidgin status extension
+PROFILES_DESC= Gnome Audio Profiels extension
+PULSE_DESC= ${PULSEAUDIO_DESC}
.include <bsd.port.pre.mk>
-.if defined(WITH_DBUS)
+.if ${PORT_OPTIONS:MDBUS}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus
.endif
-.if defined(WITH_GNOME) || defined(WITH_PROFILES) \
+.if ${PORT_OPTIONS:MGNOME} || ${PORT_OPTIONS:MPROFILES}
|| ${HAVE_GNOME:Mpygnome2}!=""
USE_GNOME+= pygnome2
.endif
-.if defined(WITH_PIDGIN)
-. if defined(WITHOUT_DBUS)
+.if ${PORT_OPTIONS:MPIDGIN}
+.if empty(PORT_OPTIONS:MDBUS)
IGNORE= requires DBUS support
. endif
RUN_DEPENDS+= pidgin:${PORTSDIR}/net-im/pidgin
.endif
-.if !defined(WITHOUT_OMF) || exists(${LOCALBASE}/bin/scrollkeeper-update)
+.if ${PORT_OPTIONS:MOMF} || exists(${LOCALBASE}/bin/scrollkeeper-update)
RUN_DEPENDS+= scrollkeeper-update:${PORTSDIR}/textproc/scrollkeeper
INSTALLS_OMF= yes
PLIST_SUB+= OMF=""
@@ -65,7 +60,7 @@ PLIST_SUB+= OMF="@comment "
.endif
.for plugin in flac gconf jack ladspa lame mp3 pulse vorbis
-. if defined(WITH_${plugin:U})
+. if ${PORT_OPTIONS:M${plugin:U})
USE_GSTREAMER+=${plugin}
. endif
.endfor