aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-08-19 04:14:55 +0800
committerpawel <pawel@FreeBSD.org>2016-08-19 04:14:55 +0800
commitb96d82c8e7cb3609a5b628795bcbf23f4c96ad4f (patch)
tree273093580a06dc8d8bd763fa82981be655fb1364 /audio
parentd62cdbab7f1e4aedd54ad93fc66579cc569f8d11 (diff)
downloadfreebsd-ports-gnome-b96d82c8e7cb3609a5b628795bcbf23f4c96ad4f.tar.gz
freebsd-ports-gnome-b96d82c8e7cb3609a5b628795bcbf23f4c96ad4f.tar.zst
freebsd-ports-gnome-b96d82c8e7cb3609a5b628795bcbf23f4c96ad4f.zip
A module for PulseAudio to support playing to sndio servers.
WWW: https://github.com/t6/pulseaudio-module-sndio/ PR: 211670 Submitted by: Tobias Kortkamp <t@tobik.me>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/pulseaudio-module-sndio/Makefile30
-rw-r--r--audio/pulseaudio-module-sndio/distinfo3
-rw-r--r--audio/pulseaudio-module-sndio/pkg-descr3
-rw-r--r--audio/pulseaudio-module-sndio/pkg-message9
5 files changed, 46 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 338299a886e8..d473d9b2f965 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -610,6 +610,7 @@
SUBDIR += pragha
SUBDIR += puddletag
SUBDIR += pulseaudio
+ SUBDIR += pulseaudio-module-sndio
SUBDIR += py-al
SUBDIR += py-ao
SUBDIR += py-apetag
diff --git a/audio/pulseaudio-module-sndio/Makefile b/audio/pulseaudio-module-sndio/Makefile
new file mode 100644
index 000000000000..bfd2b46a8a1b
--- /dev/null
+++ b/audio/pulseaudio-module-sndio/Makefile
@@ -0,0 +1,30 @@
+# Created by: Tobias Kortkamp <t@tobik.me>
+# $FreeBSD$
+
+PORTNAME= pulseaudio-module-sndio
+PORTVERSION= 8.0
+CATEGORIES= audio
+
+MAINTAINER= t@tobik.me
+COMMENT= Sndio module for PulseAudio
+
+LICENSE= ISCL
+
+LIB_DEPENDS+= libsndio.so:audio/sndio \
+ libpulse.so:audio/pulseaudio
+
+USES= pkgconfig
+
+PULSE_VERSION?= ${PORTVERSION}
+PULSE_MODDIR= ${LOCALBASE}/lib/pulse-${PULSE_VERSION}/modules
+
+USE_GITHUB= yes
+GH_ACCOUNT= t6
+
+MAKE_ARGS= PULSE_VERSION="${PULSE_VERSION}" \
+ PULSE_MODDIR="${PULSE_MODDIR}" \
+ STAGEDIR="${STAGEDIR}"
+
+PLIST_FILES= ${PULSE_MODDIR}/module-sndio.so
+
+.include <bsd.port.mk>
diff --git a/audio/pulseaudio-module-sndio/distinfo b/audio/pulseaudio-module-sndio/distinfo
new file mode 100644
index 000000000000..09bbfd467d76
--- /dev/null
+++ b/audio/pulseaudio-module-sndio/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470670520
+SHA256 (t6-pulseaudio-module-sndio-8.0_GH0.tar.gz) = eae7dce7220af6a508a42fcfe22d365c495e9dd2ab4d2eb1dae4c0bef0f9581a
+SIZE (t6-pulseaudio-module-sndio-8.0_GH0.tar.gz) = 92204
diff --git a/audio/pulseaudio-module-sndio/pkg-descr b/audio/pulseaudio-module-sndio/pkg-descr
new file mode 100644
index 000000000000..c2a6faab6a5a
--- /dev/null
+++ b/audio/pulseaudio-module-sndio/pkg-descr
@@ -0,0 +1,3 @@
+A module for PulseAudio to support playing to sndio servers.
+
+WWW: https://github.com/t6/pulseaudio-module-sndio/
diff --git a/audio/pulseaudio-module-sndio/pkg-message b/audio/pulseaudio-module-sndio/pkg-message
new file mode 100644
index 000000000000..5d08d096c4b8
--- /dev/null
+++ b/audio/pulseaudio-module-sndio/pkg-message
@@ -0,0 +1,9 @@
+To use the sndio PulseAudio module load it with
+
+ pacmd load-module module-sndio
+
+You can use audio/pavucontrol or pacmd to switch a specific stream
+over to use it. Unloading the OSS module will send all streams over
+sndio:
+
+ pacmd unload-module module-oss