aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-05-28 00:22:17 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-05-28 00:22:17 +0800
commitbdeeba27721580779fff75cdf343df30fb48390b (patch)
tree172f65a2e7d94dcb832b3a4dba79174713d59550 /audio
parent2adcf95237e5f773613dcaefa925bf0f563aeef5 (diff)
downloadfreebsd-ports-gnome-bdeeba27721580779fff75cdf343df30fb48390b.tar.gz
freebsd-ports-gnome-bdeeba27721580779fff75cdf343df30fb48390b.tar.zst
freebsd-ports-gnome-bdeeba27721580779fff75cdf343df30fb48390b.zip
- Move audio/rubygem-shout to audio/rubygem-ruby-shout
- Fix build with ruby22 - Add LICENSE - Update WWW
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile2
-rw-r--r--audio/rubygem-ruby-shout/Makefile (renamed from audio/rubygem-shout/Makefile)16
-rw-r--r--audio/rubygem-ruby-shout/distinfo (renamed from audio/rubygem-shout/distinfo)0
-rw-r--r--audio/rubygem-ruby-shout/files/patch-ext-shout_ext.c11
-rw-r--r--audio/rubygem-ruby-shout/pkg-descr (renamed from audio/rubygem-shout/pkg-descr)2
5 files changed, 18 insertions, 13 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 07083e7b9b07..8645f0c84717 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -658,7 +658,7 @@
SUBDIR += rubygem-librmpd
SUBDIR += rubygem-ruby-mp3info
SUBDIR += rubygem-ruby-ogginfo
- SUBDIR += rubygem-shout
+ SUBDIR += rubygem-ruby-shout
SUBDIR += rubyripper
SUBDIR += s3mod
SUBDIR += sbagen
diff --git a/audio/rubygem-shout/Makefile b/audio/rubygem-ruby-shout/Makefile
index e6442969172e..08c2a5d706cf 100644
--- a/audio/rubygem-shout/Makefile
+++ b/audio/rubygem-ruby-shout/Makefile
@@ -1,28 +1,22 @@
# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-PORTNAME= shout
+PORTNAME= ruby-shout
PORTVERSION= 2.2.1
PORTREVISION= 1
CATEGORIES= audio rubygems
MASTER_SITES= RG
-DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby binding to the libshout library
+LICENSE= BSD3CLAUSE
+
LIB_DEPENDS= libshout.so:${PORTSDIR}/audio/libshout
+CONFIGURE_ARGS= --with-opt-include="${LOCALBASE}/include"
USE_RUBY= yes
USE_RUBYGEMS= yes
-GEM_NAME= ${DISTNAME}
RUBYGEM_AUTOPLIST= yes
-CONFIGURE_ARGS= --with-opt-include="${LOCALBASE}/include"
-
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} >= 2.2
-BROKEN= Does not build
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/rubygem-shout/distinfo b/audio/rubygem-ruby-shout/distinfo
index f512f20b831c..f512f20b831c 100644
--- a/audio/rubygem-shout/distinfo
+++ b/audio/rubygem-ruby-shout/distinfo
diff --git a/audio/rubygem-ruby-shout/files/patch-ext-shout_ext.c b/audio/rubygem-ruby-shout/files/patch-ext-shout_ext.c
new file mode 100644
index 000000000000..a07ff0a02b16
--- /dev/null
+++ b/audio/rubygem-ruby-shout/files/patch-ext-shout_ext.c
@@ -0,0 +1,11 @@
+--- ext/shout_ext.c.orig 2015-05-27 15:58:04 UTC
++++ ext/shout_ext.c
+@@ -250,7 +250,7 @@ static VALUE _sh_send(VALUE self, VALUE
+ shout_connection *s;
+ GET_SC(self, s);
+
+- Check_SafeStr(to_send);
++ SafeStringValue(to_send);
+ err = shout_send(s->conn, (unsigned char *) (RSTRING_PTR(to_send)),
+ RSTRING_LEN(to_send));
+ if(err != SHOUTERR_SUCCESS) {
diff --git a/audio/rubygem-shout/pkg-descr b/audio/rubygem-ruby-shout/pkg-descr
index 83dbfc06ebca..30c9bb03d9af 100644
--- a/audio/rubygem-shout/pkg-descr
+++ b/audio/rubygem-ruby-shout/pkg-descr
@@ -1,4 +1,4 @@
Ruby-shout is a binding to the libshout library, which sends streaming
MP3/Vorbis to an icecast server with libshout.
-WWW: http://rubygems.org/gems/ruby-shout
+WWW: https://github.com/niko/ruby-shout