aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2005-09-28 06:35:13 +0800
committermi <mi@FreeBSD.org>2005-09-28 06:35:13 +0800
commitc3b03d7cd496f0d3c8622ec11f29d65f7c1b20d9 (patch)
treec065eec1c01bd949ab30e0566292b67304948b7e /audio
parent13984fdf94d243af60725bf7456837c0c97a632f (diff)
downloadfreebsd-ports-gnome-c3b03d7cd496f0d3c8622ec11f29d65f7c1b20d9.tar.gz
freebsd-ports-gnome-c3b03d7cd496f0d3c8622ec11f29d65f7c1b20d9.tar.zst
freebsd-ports-gnome-c3b03d7cd496f0d3c8622ec11f29d65f7c1b20d9.zip
Pass the location of slang headers and library in the CONFIGURE_ARGS
and make the sub-master port (timidity++-emacs) _append_ its own CONFIGURE_ARGS instead of resetting them anew. Woof, these ports are an insteresting tangle... Notified by: pointyhat (via kris)
Diffstat (limited to 'audio')
-rw-r--r--audio/timidity++-emacs/Makefile2
-rw-r--r--audio/timidity++-slang/Makefile4
2 files changed, 4 insertions, 2 deletions
diff --git a/audio/timidity++-emacs/Makefile b/audio/timidity++-emacs/Makefile
index b547dac96810..95930577cf09 100644
--- a/audio/timidity++-emacs/Makefile
+++ b/audio/timidity++-emacs/Makefile
@@ -33,7 +33,7 @@ USE_GMAKE= yes
USE_XLIB= yes
.endif
-CONFIGURE_ARGS= --enable-dynamic=${INTERFACE}
+CONFIGURE_ARGS+=--enable-dynamic=${INTERFACE}
MASTERDIR= ${.CURDIR}/../../audio/timidity++
PKGDIR= ${.CURDIR}
diff --git a/audio/timidity++-slang/Makefile b/audio/timidity++-slang/Makefile
index cdac2c6e4594..b7ba627f8448 100644
--- a/audio/timidity++-slang/Makefile
+++ b/audio/timidity++-slang/Makefile
@@ -10,7 +10,9 @@ INTERFACE= slang
MAINTAINER= ports@FreeBSD.org
COMMENT= Slang interface for TiMidity++
-MASTERDIR= ${.CURDIR}/../../audio/timidity++-emacs
+MASTERDIR= ${.CURDIR:H:H}/audio/timidity++-emacs
+CONFIGURE_ARGS+=--with-includes=${LOCALBASE}/include \
+ --with-libraries=${LOCALBASE}/lib
PLIST_FILES= lib/timidity/interface_s.so
.include "${MASTERDIR}/Makefile"