aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-06-25 08:29:09 +0800
committerlinimon <linimon@FreeBSD.org>2017-06-25 08:29:09 +0800
commitc5d08e42102d70dcbd448ae11773f148e7c79c69 (patch)
treeec081b06d4ac1171d90c17f7c227c9b2007dc591 /audio
parentd8546a60b4e8aaa6ea5579bab8bf414d0f3a7fc8 (diff)
downloadfreebsd-ports-gnome-c5d08e42102d70dcbd448ae11773f148e7c79c69.tar.gz
freebsd-ports-gnome-c5d08e42102d70dcbd448ae11773f148e7c79c69.tar.zst
freebsd-ports-gnome-c5d08e42102d70dcbd448ae11773f148e7c79c69.zip
Begin deorbit burn of ia64. We have not attempted to build packages for
it for many years. While here, alphabetize ARCHs, pet portlint, and modernize usages. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'audio')
-rw-r--r--audio/boodler/Makefile2
-rw-r--r--audio/csound/Makefile6
-rw-r--r--audio/openal/Makefile3
-rw-r--r--audio/spiralsynthmodular/Makefile2
-rw-r--r--audio/xmms-sapplug/Makefile1
5 files changed, 4 insertions, 10 deletions
diff --git a/audio/boodler/Makefile b/audio/boodler/Makefile
index ff97d3b4704a..a6e286edb1e3 100644
--- a/audio/boodler/Makefile
+++ b/audio/boodler/Makefile
@@ -45,7 +45,7 @@ OSS_CONFIGURE_ON= --driver oss
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+.if ${ARCH} == "amd64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
CONFIGURE_ARGS+= --PIC
.endif
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 86a6030b3f98..c057f6048acf 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -21,6 +21,8 @@ BUILD_DEPENDS= swig13>0:devel/swig13 \
gmm++>0:math/gmm++
LIB_DEPENDS= libsndfile.so:audio/libsndfile
+BROKEN_powerpc64= Does not build
+
PORTSCOUT= limit:^5\.
CONFLICTS_INSTALL= outguess-* csound6
@@ -104,7 +106,7 @@ DOCS_DISTFILES= Csound${PORTVERSION:R}_manual_html.zip:manual
.include <bsd.port.pre.mk>
-.if ${ARCH} == amd64 || ${ARCH} == sparc64 || ${ARCH} == ia64
+.if ${ARCH} == amd64 || ${ARCH} == sparc64
MAKE_ARGS+= Word64=1
.endif
@@ -112,8 +114,6 @@ MAKE_ARGS+= Word64=1
CXXLIB= c++
.endif
-BROKEN_powerpc64= Does not build
-
post-patch:
@${SED} -e "s|%%LOCALBASE%%|${LOCALBASE}|g; \
s|%%PYTHON_INCLUDEDIR%%|${PYTHON_INCLUDEDIR}|" \
diff --git a/audio/openal/Makefile b/audio/openal/Makefile
index 3a1a8cd01835..2e596332d9f1 100644
--- a/audio/openal/Makefile
+++ b/audio/openal/Makefile
@@ -41,9 +41,6 @@ ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_CONFIGURE_ENABLE= alsa
ASM_BUILD_DEPENDS= nasm:devel/nasm
-NOT_FOR_ARCHS= ia64
-NOT_FOR_ARCHS_REASON_ia64= does not compile
-
post-patch:
@${REINPLACE_CMD} -e 's/x86_64\*/amd64\* | \*ia64\*/g; \
/CPPFLAGS=/ d; s/ \*linux\*)/ \*bsd\*)/' ${WRKSRC}/configure
diff --git a/audio/spiralsynthmodular/Makefile b/audio/spiralsynthmodular/Makefile
index 397ac54e509b..05553f048e2a 100644
--- a/audio/spiralsynthmodular/Makefile
+++ b/audio/spiralsynthmodular/Makefile
@@ -24,8 +24,6 @@ LIBS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/spiralmodular-0.2.2
-BROKEN_ia64= Does not compile on ia64
-
OPTIONS_DEFINE= OPTIMIZED_CFLAGS
OPTIMIZED_CFLAGS_CFLAGS=-O3 -ffast-math
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
index f8c8fdc1e186..5546d2d0867d 100644
--- a/audio/xmms-sapplug/Makefile
+++ b/audio/xmms-sapplug/Makefile
@@ -28,7 +28,6 @@ PLIST_FILES= lib/xmms/Input/libsap.so
OPTIONS_DEFINE= OPTIMIZED_CFLAGS
CFLAGS_amd64= -fpic -DPIC
-CFLAGS_ia64= -fpic -DPIC
.include <bsd.port.pre.mk>