aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-08-08 20:39:49 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-08-08 20:39:49 +0800
commitc60b75bcefe3132dc0f42d701da0f87c6bc486e2 (patch)
tree9dd9f8cb123392dcad861241fbb991fcd8cd8fb8 /audio
parentd2315ed138df1595efc98bd8299c3bba05665cc2 (diff)
downloadfreebsd-ports-gnome-c60b75bcefe3132dc0f42d701da0f87c6bc486e2.tar.gz
freebsd-ports-gnome-c60b75bcefe3132dc0f42d701da0f87c6bc486e2.tar.zst
freebsd-ports-gnome-c60b75bcefe3132dc0f42d701da0f87c6bc486e2.zip
Update to version 3.13
PR: 159422 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/gogo/Makefile56
-rw-r--r--audio/gogo/distinfo4
-rw-r--r--audio/gogo/files/patch-ac32
-rw-r--r--audio/gogo/files/patch-engine__i386__cpu.c10
-rw-r--r--audio/gogo/files/patch-engine__i386__fftsse.nas25
-rw-r--r--audio/gogo/pkg-descr2
6 files changed, 63 insertions, 66 deletions
diff --git a/audio/gogo/Makefile b/audio/gogo/Makefile
index 5dd4c8e2b055..2c98aa5527fb 100644
--- a/audio/gogo/Makefile
+++ b/audio/gogo/Makefile
@@ -6,57 +6,51 @@
#
PORTNAME= gogo
-PORTVERSION= 2.39b
-PORTREVISION= 1
+PORTVERSION= 3.13
CATEGORIES= audio
-MASTER_SITES= ftp://ftp.csie.ncu.edu.tw/FreeBSD/ports/distfiles/ \
- ftp://ftp.thu.edu.tw/FreeBSD/ports/distfiles/ \
- ftp://ftp.42.org/pub/FreeBSD/distfiles/
-
-DISTNAME= gogo239b
+MASTER_SITES= http://homepage2.nifty.com/kei-i/petit/
+DISTNAME= petit313
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Very fast MP3 encoder using recent x86 processors' features
-OPTIONS= THREADS "Use linuxthreads for increased SMP performance" off
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
# More than version 0.98
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-USE_GMAKE= yes
-ALL_TARGET= gogo
-MAKE_ARGS= CC="${CC}" LD="${CC}"
-
RESTRICTED= Condition is not clear
ONLY_FOR_ARCHS= i386
-PLIST_FILES= bin/cdda2mp3.gogo bin/gogo
-PORTDOCS= cdda2mp3.gogo.en cdda2mp3.gogo.ja
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
-# A sample of heavily optimized CFLAGS(typically used with pgcc).
-# Recommended ONLY for benchmarks.
-# CFLAGS=-march=pentiumpro -O6 -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -foptimize-register-move -ffast-math -fdefer-pop -mfancy-math-387
+CFLAGS+= -fomit-frame-pointer -ffast-math -funroll-loops
-.include <bsd.port.pre.mk>
+PORTDOCS= cdda2mp3.gogo.en cdda2mp3.gogo.ja
+PLIST_FILES= bin/cdda2mp3.gogo bin/gogo
-.if defined(WITHOUT_THREADS)
-MAKE_ARGS+= "USE_MT=no"
-.else
-MAKE_ARGS+= "USE_MT=yes"
-LIB_DEPENDS= lthread.3:${PORTSDIR}/devel/linuxthreads
-.endif
+post-extract:
+ @${TOUCH} ${WRKSRC}/readme.txt
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s| -pipe| $${CFLAGS}|g ; \
+ s|^CFLAGS|#CFLAGS|g' ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gogo ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/cdda2mp3.bsd \
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/cdda2mp3/cdda2mp3.bsd \
${PREFIX}/bin/cdda2mp3.gogo
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/gogo
- ${INSTALL_DATA} ${WRKSRC}/contrib/cdda2mp3.txt \
- ${PREFIX}/share/doc/gogo/cdda2mp3.gogo.en
- ${INSTALL_DATA} ${WRKSRC}/contrib/cdda2mp3.euc \
- ${PREFIX}/share/doc/gogo/cdda2mp3.gogo.ja
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/contrib/cdda2mp3/cdda2mp3.txt \
+ ${DOCSDIR}/cdda2mp3.gogo.en
+ ${INSTALL_DATA} ${WRKSRC}/contrib/cdda2mp3/cdda2mp3.euc \
+ ${DOCSDIR}/cdda2mp3.gogo.ja
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/gogo/distinfo b/audio/gogo/distinfo
index 265d973291f3..8a38e481d731 100644
--- a/audio/gogo/distinfo
+++ b/audio/gogo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gogo239b.tgz) = 4e6e5e78d9f33b4baad5107ef506d978d99891b0fee9df83ac1dfb7ba49c359d
-SIZE (gogo239b.tgz) = 293494
+SHA256 (petit313.tgz) = 8dfb28f0af57c3b442cf9ceafdab903358e27a7a1aa905b5cebd66df804c71f1
+SIZE (petit313.tgz) = 389322
diff --git a/audio/gogo/files/patch-ac b/audio/gogo/files/patch-ac
deleted file mode 100644
index 86d9e379437a..000000000000
--- a/audio/gogo/files/patch-ac
+++ /dev/null
@@ -1,32 +0,0 @@
---- Makefile.orig Sat Jan 6 22:36:06 2001
-+++ Makefile Sun Jan 7 06:15:55 2001
-@@ -12,8 +12,8 @@
- # This option is available for gcc-2.8.x
- #CC=gcc -c -mcpu=pentiumpro -malign-double -O6 -fstrength-reduce -fexpensive-optimizations -finline-functions -fomit-frame-pointer -funroll-loops
- # This option is available for gcc-2.95.1, gcc-2.95.2, gcc-2.95.3,... on P6 or later
- #CC=gcc -c -mcpu=pentiumpro -march=pentiumpro -O9 -fstrength-reduce -fexpensive-optimizations -finline-functions -fomit-frame-pointer -funroll-loops -ffast-math -foptimize-register-move -fdefer-pop -mfancy-math-387
--CFLAGS=-Wall $(PROF) -DNDEBUG $(E3DN) $(VBR) -DRAW_INPUT
-+CFLAGS+=-Wall $(PROF) -DNDEBUG $(E3DN) $(VBR) -DRAW_INPUT
-
-
- # OS specific definition
-@@ -62,8 +62,8 @@
- ifeq ($(OS),FreeBSD)
- CFLAGS+= -DDISPLAY_REALTIME
- ifeq ($(USE_MT),yes)
-- LIBS+= -L/usr/local/lib -llthread -llgcc_r
-- CFLAGS+= -DUSE_PTHREAD -D_THREAD_SAFE -I/usr/local/include/pthread/linuxthreads
-+ LIBS+= -L${LOCALBASE}/lib -llthread -llgcc_r
-+ CFLAGS+= -DUSE_PTHREAD -D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
- endif
- endif
- ifeq ($(OS),OpenBSD)
-@@ -110,7 +110,7 @@
- # $(AS) $(ASFLAGS) $< -o $@
-
- .c.o:
-- $(CC) $(CFLAGS) $<
-+ $(CC) -c $(CFLAGS) $<
-
-
- clean:
diff --git a/audio/gogo/files/patch-engine__i386__cpu.c b/audio/gogo/files/patch-engine__i386__cpu.c
new file mode 100644
index 000000000000..4f42c0a835cd
--- /dev/null
+++ b/audio/gogo/files/patch-engine__i386__cpu.c
@@ -0,0 +1,10 @@
+--- engine/i386/cpu.c.orig 2003-10-05 09:50:36.000000000 +0900
++++ engine/i386/cpu.c 2011-08-02 21:40:31.000000000 +0900
+@@ -12,6 +12,7 @@
+ #include <pthread.h>
+ #include <semaphore.h>
+ #if defined(__FreeBSD__)
++ #include <sys/types.h>
+ #include <sys/sysctl.h>
+ #endif
+ #endif
diff --git a/audio/gogo/files/patch-engine__i386__fftsse.nas b/audio/gogo/files/patch-engine__i386__fftsse.nas
new file mode 100644
index 000000000000..d012a757e350
--- /dev/null
+++ b/audio/gogo/files/patch-engine__i386__fftsse.nas
@@ -0,0 +1,25 @@
+--- engine/i386/fftsse.nas.orig 2003-10-05 09:50:37.000000000 +0900
++++ engine/i386/fftsse.nas 2011-08-02 21:49:00.000000000 +0900
+@@ -23,14 +23,14 @@
+ Q_SQRT2 dd 1.41421356237, 1.41421356237, 1.41421356237, 1.41421356237
+
+ Q_1 dd 1.0, 1.0, 1.0, 1.0
+-costab dd 9.238795325112867e-01F, 9.238795325112867e-01F, 9.238795325112867e-01F, 9.238795325112867e-01F
+- dd 3.826834323650898e-01F, 3.826834323650898e-01F, 3.826834323650898e-01F, 3.826834323650898e-01F
+- dd 9.951847266721969e-01F, 9.951847266721969e-01F, 9.951847266721969e-01F, 9.951847266721969e-01F
+- dd 9.801714032956060e-02F, 9.801714032956060e-02F, 9.801714032956060e-02F, 9.801714032956060e-02F
+- dd 9.996988186962042e-01F, 9.996988186962042e-01F, 9.996988186962042e-01F, 9.996988186962042e-01F
+- dd 2.454122852291229e-02F, 2.454122852291229e-02F, 2.454122852291229e-02F, 2.454122852291229e-02F
+- dd 9.999811752826011e-01F, 9.999811752826011e-01F, 9.999811752826011e-01F, 9.999811752826011e-01F
+- dd 6.135884649154475e-03F, 6.135884649154475e-03F, 6.135884649154475e-03F, 6.135884649154475e-03F
++costab dd 9.238795325112867e-01, 9.238795325112867e-01, 9.238795325112867e-01, 9.238795325112867e-01
++ dd 3.826834323650898e-01, 3.826834323650898e-01, 3.826834323650898e-01, 3.826834323650898e-01
++ dd 9.951847266721969e-01, 9.951847266721969e-01, 9.951847266721969e-01, 9.951847266721969e-01
++ dd 9.801714032956060e-02, 9.801714032956060e-02, 9.801714032956060e-02, 9.801714032956060e-02
++ dd 9.996988186962042e-01, 9.996988186962042e-01, 9.996988186962042e-01, 9.996988186962042e-01
++ dd 2.454122852291229e-02, 2.454122852291229e-02, 2.454122852291229e-02, 2.454122852291229e-02
++ dd 9.999811752826011e-01, 9.999811752826011e-01, 9.999811752826011e-01, 9.999811752826011e-01
++ dd 6.135884649154475e-03, 6.135884649154475e-03, 6.135884649154475e-03, 6.135884649154475e-03
+
+ align 32
+ revLongInit db 0x00, 0x80, 0x80, 0x80, 0x80, 0x80, 0x80, 0x80
diff --git a/audio/gogo/pkg-descr b/audio/gogo/pkg-descr
index 6ad6b3df6dfe..5edc70521bc4 100644
--- a/audio/gogo/pkg-descr
+++ b/audio/gogo/pkg-descr
@@ -9,4 +9,4 @@ so makes them very hot even it runs standard clock.
Overclocking may cause serious internal errors and crazy results.
Or you need gigantic heatsink and extra-noisy fans. :-)
-WWW: http://homepage1.nifty.com/herumi/gogo_e.html
+WWW: http://www.marinecat.net/free/windows/mct_free.htm