aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-01-08 09:26:12 +0800
committerscheidell <scheidell@FreeBSD.org>2012-01-08 09:26:12 +0800
commitcef505bec83a5e30560270336482efb56d3d365b (patch)
treee96bd9caa7d88b9018948611c5c8521a88ffcaac /audio
parent807edd0e665370d24d077c3f343b2f97c7468239 (diff)
downloadfreebsd-ports-gnome-cef505bec83a5e30560270336482efb56d3d365b.tar.gz
freebsd-ports-gnome-cef505bec83a5e30560270336482efb56d3d365b.tar.zst
freebsd-ports-gnome-cef505bec83a5e30560270336482efb56d3d365b.zip
- reopen logs on SIGHUP
PR: ports/147645 Submitted by: Christopher Key <cjk32@cam.ac.uk> Approved by: maintainer (timeout, 3 years) gabor (mentor)
Diffstat (limited to 'audio')
-rw-r--r--audio/squeezeboxserver/Makefile5
-rw-r--r--audio/squeezeboxserver/files/patch-Slim-Utils-Log.pm20
-rw-r--r--audio/squeezeboxserver/pkg-plist8
3 files changed, 27 insertions, 6 deletions
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index 47ba4ef74d74..b6ba1bcb5ce9 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= squeezeboxserver
PORTVERSION= 7.5.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://downloads.slimdevices.com/SqueezeboxServer_v${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-noCPAN
@@ -135,7 +135,8 @@ EXCEPTDIRS= Bin \
CPAN/YAML
CPIOARGS= --quiet -pdum -R
-PLIST_SUB= SLIMDIR=${SLIMDIR}
+PLIST_SUB= SLIMDIR=${SLIMDIR} \
+ SLIMDBDIR=${SLIMDBDIR}
SUB_FILES= Custom.pm \
pkg-install \
diff --git a/audio/squeezeboxserver/files/patch-Slim-Utils-Log.pm b/audio/squeezeboxserver/files/patch-Slim-Utils-Log.pm
new file mode 100644
index 000000000000..ea3d28920fc2
--- /dev/null
+++ b/audio/squeezeboxserver/files/patch-Slim-Utils-Log.pm
@@ -0,0 +1,20 @@
+--- Slim/Utils/Log.pm 2010-04-01 13:21:54.000000000 +0100
++++ Slim/Utils/Log.pm 2010-06-07 09:08:34.000000000 +0100
+@@ -134,7 +134,7 @@
+ # Make sure recreate option is set if user has an existing log.conf
+ if ( !main::ISWINDOWS && !$ENV{NYTPROF} ) {
+ $config{'log4perl.appender.server.recreate'} = 1;
+- $config{'log4perl.appender.server.recreate_check_signal'} = 'USR1';
++ $config{'log4perl.appender.server.recreate_check_signal'} = 'HUP';
+ }
+
+ # Change to syslog if requested
+@@ -985,7 +985,7 @@
+
+ if ( !main::ISWINDOWS && !$ENV{NYTPROF} ) {
+ $defaultAppenders{server}->{recreate} = 1;
+- $defaultAppenders{server}->{recreate_check_signal} = 'USR1';
++ $defaultAppenders{server}->{recreate_check_signal} = 'HUP';
+ }
+
+ return $class->_fixupAppenders(\%defaultAppenders); \ No newline at end of file
diff --git a/audio/squeezeboxserver/pkg-plist b/audio/squeezeboxserver/pkg-plist
index d8f8781174ac..51014f09cdd1 100644
--- a/audio/squeezeboxserver/pkg-plist
+++ b/audio/squeezeboxserver/pkg-plist
@@ -2588,7 +2588,7 @@ bin/softsqueeze
@dirrmtry %%SLIMDIR%%/Plugins
@dirrmtry %%SLIMDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@unexec rm -rf /var/db/squeezeboxserver/cache > /dev/null 2>&1 || true
-@dirrmtry /var/db/squeezeboxserver/playlists
-@dirrmtry /var/db/squeezeboxserver
-@unexec test -d /var/db/squeezeboxserver && (echo "Configuration information saved. If you will *NOT* use this package anymore," && echo "please remove /var/db/squeezeboxserver and its contents manually.")
+@unexec rm -rf %%SLIMDBDIR%%/cachee
+@unexec rmdir %%SLIMDBDIR%%/playlists 2>/dev/null || true
+@unexec rmdir %%SLIMDBDIR%% 2>/dev/null || true
+@unexec test -d %%SLIMDBDIR%% && (echo "Configuration information saved. If you will *NOT* use this package anymore," && echo "please remove %%SLIMDBDIR%% and its contents manually.")